Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-13-2012, 10:57 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2012
Location: Prescott Arizona
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 879
kharrar has a reputation beyond reputekharrar has a reputation beyond repute
Trailer Wiring Harness Problem; help?

The factory trailer tow hitch install went really well, got a new rear valence with dual cutouts and the magnaflow tips look great.

I had to get the complete trailer wiring harness as my jeep was not factory wired. After completing the wiring my right rear turn signal does not work! It is not the bulb or fuse. Have not taken it to get it reprogrammed from the dealer yet. How can just attaching these wires cause the loss of the turn signal. I was very careful and the install seemed to go very well and all wiring was not difficult.

Anyone have any ideas? Thanks in advance ; Karl
__________________

__________________
Reply With Quote
  #2  
Old 10-14-2012, 07:22 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,372
Thanks: 97
Thanked 28 Times in 26 Posts
Rep Power: 11275
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Trailer Wiring Harness Problem; help?

You used the Mopar harness? If so, then the dealer needs to "enable" it via programming.

Not sure why your right turn signal isn't working though. Perhaps go through the instructions and double check everything?
__________________

__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
  #3  
Old 10-14-2012, 08:18 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2012
Location: Prescott Arizona
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 879
kharrar has a reputation beyond reputekharrar has a reputation beyond repute
Re: Trailer Wiring Harness Problem; help?

Yes, wanted to keep everything factory. Used the correct harness.

I will bring it to the dealer Friday and have it programmed and get them to check the turn signal.

Thanks...
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring Trailer Harness maltesesteeze Tech Tips DIY/How To 1 05-15-2013 11:01 AM
Corroded Wiring Harness for Trailer hitch on WJ RYANSWJ Troubleshooting/Problems Discussion 1 07-03-2011 08:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.