Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-04-2013, 07:51 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Sep 2010
Location: Chicago
Posts: 108
Thanks: 2
Thanked 8 Times in 5 Posts
Rep Power: 1627
RKlimas is on a distinguished road
Send a message via ICQ to RKlimas
Transmission goes into "limp" mode

I was just starting to accelerate on the entrance ramp to an expressway in the Chicago area and my transmission becomes stuck in 4th gear. Then the MIL illuminates. I was now in "limp" mode. Took it to the dealer yesterday and was told a solenoid went bad. Hope that is all it is. Should be picking it up today.
__________________

__________________
2012 Grand Cherokee Overland 4x4
Maximum Steel, V-8
Reply With Quote
  #2  
Old 04-04-2013, 01:44 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,560
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80243
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Transmission goes into "limp" mode

Sounds reasonable but without the trouble code cannot say much. Hope the dealer is right.
__________________

Reply With Quote
  #3  
Old 04-04-2013, 04:35 PM
Member
 
Join Date: Mar 2013
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 671
Taws600 is on a distinguished road
What year and engine? How many miles on your truck?
__________________
Reply With Quote
  #4  
Old 04-04-2013, 06:59 PM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Sep 2010
Location: Chicago
Posts: 108
Thanks: 2
Thanked 8 Times in 5 Posts
Rep Power: 1627
RKlimas is on a distinguished road
Send a message via ICQ to RKlimas
Re: Transmission goes into "limp" mode

Update-

Got the 2012 Jeep GC back today. It has the 5.7L engine. Threw Code #P0750- Solenoid failure. The dealer fixed it under warranty. I have 26,250 miles on it. Runs great. If in the Chicago area- Napleton's at River Oaks is a very good dealer to work with.
__________________
2012 Grand Cherokee Overland 4x4
Maximum Steel, V-8
Reply With Quote
  #5  
Old 04-04-2013, 10:59 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,560
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80243
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Transmission goes into "limp" mode

Thank you - LR Solenoid failure 65RFE (Hemi) trans. Had to remove the pan and valve body to get at it. Sounds like a good dealer.
Reply With Quote
  #6  
Old 04-15-2014, 12:10 PM
Member
 
Join Date: Aug 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1216
falcon_o is on a distinguished road
Re: Transmission goes into "limp" mode

Quote:
Originally Posted by RKlimas View Post
Update-

Got the 2012 Jeep GC back today. It has the 5.7L engine. Threw Code #P0750- Solenoid failure. The dealer fixed it under warranty. I have 26,250 miles on it. Runs great. If in the Chicago area- Napleton's at River Oaks is a very good dealer to work with.
@ 59,000, 4/2/14, had the exact same problem/code/solution on my 5.7L 2012 JGC.

Curious if this is indicative of a design flaw with this part.
__________________
Reply With Quote
  #7  
Old 06-24-2014, 01:29 PM
mjlemon's Avatar
Member
 
Join Date: Jun 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 175
mjlemon is on a distinguished road
Re: Transmission goes into "limp" mode

I have the exact same problem over the last 3 weeks. First they replaced the TIPM Module, then a shift Module, and it's back again for a third time. I suspect they will replace the Solenoid. Jeep is covering all of it. This is for a 2011 Jeep GC Overland 5.7, 53,000 miles. From what I've discovered, it seems the TIPM and Solnoids are defective and should have been part of a recall.
__________________
Reply With Quote
  #8  
Old 07-09-2014, 08:01 AM
mjlemon's Avatar
Member
 
Join Date: Jun 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 175
mjlemon is on a distinguished road
Re: Transmission goes into "limp" mode

CEL went off after engine turned off when I dropped off car at dealer and dealer refuses to replace solenoid even though there's a stored error code because there isn't an active error code from the car automatically going into 4th when shifted into drive. So I took it to another dealer and paid $700 to put in new solenoid. Warning--If your car goes into limp mode leaving running at the dealer or you loose the active code. If it fails again I'm trading for a Lexus SUV. I've given up on Jeep.


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp mode ..transmission problems? hotqld Troubleshooting/Problems Discussion 1 01-16-2013 03:07 PM
HVAC "Auto Mode" questions Mark W Trouble Shooting/Problems/Service 5 06-17-2012 12:31 AM
Mygig "Engineering Mode" suzieque Audio, Video, Navigation & Electronic Modifications 24 11-18-2010 09:19 PM
Can't get VES to come up when I hit "MODE" for my ipod thex2 Grand Cherokee - WK 9 10-31-2010 12:46 AM
HVAC "Mode" Knob pushed in sam555 Troubleshooting/Problems 0 06-01-2010 10:37 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.