Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-22-2013, 10:36 PM
shad0whawk's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Parker, Colorado
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 526
shad0whawk is on a distinguished road
They've been in contact with me providing updates. Right now I'm just waiting for the transmission to arrive. No loss since I still have full use of my vehicle--just annoyance at having to wait.
__________________

__________________
Reply With Quote
  #14  
Old 05-29-2013, 11:02 PM
shad0whawk's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Parker, Colorado
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 526
shad0whawk is on a distinguished road
Re: Transmission Issues

So after several weeks of waiting, my new transmission arrived direct from the assembly line. It was installed and thoroughly tested over the course of 8 hours. First impressions...seems to run great--no more "bump" or "jerk" around 10 mph. Overall it seems much smoother than the original one. I'll have to test it out some more of the next few days and give it some time to adjust to my driving habits.

The service department at AutoNation Chrysler Jeep Broadway in Denver was awesome! They were easy to work with and genuinely interested in solving my problem. They immediately noticed the behavior wasn't "normal" (the answer we tend to get from a dealership) and worked diligently with Chrysler to solve it. I can honestly say I was impressed by their great customer service. Unfortunately I can't say the same about my previous Jeep dealership--which shall remain nameless.

BTW...my Summit was built in March so I'm assuming the transmission was assembled roughly the same time. I figured the date might help if someone else is having similar issues.
__________________

__________________
Reply With Quote
  #15  
Old 05-30-2013, 05:46 AM
Imanthony's Avatar
Member
 
Join Date: May 2013
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
Imanthony is on a distinguished road
Quote:
Originally Posted by shad0whawk View Post
BTW...my Summit was built in March so I'm assuming the transmission was assembled roughly the same time. I figured the date might help if someone else is having similar issues.
Was the original transmission built in Germany or USA? It lists country of origin on the window sticker if you till have it.
__________________
2014 Jeep Grand Cherokee Overland - 4x2 Hemi
Reply With Quote
  #16  
Old 05-30-2013, 10:52 PM
shad0whawk's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Parker, Colorado
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 526
shad0whawk is on a distinguished road
Just looked at the sticker...Germany. I wonder if the replacement originated from Germany???
__________________
Reply With Quote
  #17  
Old 05-31-2013, 07:33 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,128
Thanks: 213
Thanked 156 Times in 126 Posts
Rep Power: 89562
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Transmission Issues

Right now all V8 trannys are built in Germany, and V6 are built in USA.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #18  
Old 05-31-2013, 08:12 AM
imcraz's Avatar
Member
 
Join Date: Feb 2013
Posts: 60
Thanks: 2
Thanked 3 Times in 2 Posts
Rep Power: 643
imcraz is on a distinguished road
Re: Transmission Issues

In heavy traffic yesteday, I noticed the clunking mentioned here in the lower gears. I am working on making an appointment to take it to the dealership to look at as well as the Uconnect issues that I have had.
__________________
2014 Overland 4x4 w/Advanced Tehnology and Mopar chrome edition
Reply With Quote
  #19  
Old 05-31-2013, 11:23 AM
Member
My Jeep: 2013 WK2
 
Join Date: Mar 2013
Location: Parsippany, NJ
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 618
headrushNJ is on a distinguished road
Re: Transmission Issues

Quote:
Originally Posted by imcraz View Post
In heavy traffic yesteday, I noticed the clunking mentioned here in the lower gears. I am working on making an appointment to take it to the dealership to look at as well as the Uconnect issues that I have had.
Is that clunking in ECO-mode only? Do you still hear it whe eco is off?
__________________
2014 GC Limited 4x4 3.6L, Black/Black, 20", Lux II, RA4
Reply With Quote
  #20  
Old 05-31-2013, 12:11 PM
imcraz's Avatar
Member
 
Join Date: Feb 2013
Posts: 60
Thanks: 2
Thanked 3 Times in 2 Posts
Rep Power: 643
imcraz is on a distinguished road
Re: Transmission Issues

Quote:
Originally Posted by headrushNJ View Post
Is that clunking in ECO-mode only? Do you still hear it whe eco is off?
I believe it was in eco mode yes. I am going to experiment with it this weekend and I have made an appointment at the dealership to let them check it out on Monday.
__________________
2014 Overland 4x4 w/Advanced Tehnology and Mopar chrome edition
Reply With Quote
  #21  
Old 06-04-2013, 07:34 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 900
Thanks: 0
Thanked 40 Times in 31 Posts
Rep Power: 3477
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Transmission Issues

Just turned 1000 miles on my 2014 Limited V6 4x4, and my 1st and 2nd gear shifts are rough & slow...mostly when downshifting...all in "ECO" mode.

Still hoping it's just a break-in issue.
__________________
Still waiting for the next V6 transmission update from Chrysler!
Reply With Quote
  #22  
Old 06-04-2013, 04:22 PM
imcraz's Avatar
Member
 
Join Date: Feb 2013
Posts: 60
Thanks: 2
Thanked 3 Times in 2 Posts
Rep Power: 643
imcraz is on a distinguished road
Re: Transmission Issues

So I finally heard back from the dealership and they have done a software update for the transmission so hopefully this will stop the clunking I was feeling. I won't know until later this week unfortunately if it actually resolved the issue as they are waiting for additional parts for things that need to be fixed.
__________________
2014 Overland 4x4 w/Advanced Tehnology and Mopar chrome edition
Reply With Quote
  #23  
Old 06-04-2013, 09:11 PM
jaxkxx's Avatar
Member
 
Join Date: Feb 2012
Location: Lindenhurst IL
Posts: 206
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1177
jaxkxx is a jewel in the rough
Re: Transmission Issues

Quote:
Originally Posted by imcraz View Post
So I finally heard back from the dealership and they have done a software update for the transmission so hopefully this will stop the clunking I was feeling. I won't know until later this week unfortunately if it actually resolved the issue as they are waiting for additional parts for things that need to be fixed.
Keep us posted
__________________
Reply With Quote
  #24  
Old 06-06-2013, 11:06 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Caribbean
Posts: 22
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 493
OverlandAzul is on a distinguished road
Re: Transmission Issues

I have the same issue when coming to a stop and the transmission downshifts from 2nd into 1st gear. In one week I have put about 320 miles on my 2014 Overland 5.7 with no other noticeable issue other than condensation in the headlights. When I talked to my salesman he gave me the "its normal" answer. I just completed a soft battery "reset" as recommended by GCLimited but it did not work. I will see my dealer in the next few days... wish me luck.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Grand Cherokee Transmission issues bhdiscgolf Troubleshooting/Problems 15 01-13-2013 01:15 PM
Torque Converter / Transmission issues. harkinsc Troubleshooting/Problems 7 05-08-2012 12:11 AM
2011 WK2 transmission issues Richl Trouble Shooting/Problems/Service 8 11-22-2011 02:02 AM
Transmission Issues Crestwood1001 Grand Cherokee - WK 34 08-07-2011 09:45 PM
HELP! Transmission issues? 2004wjmedic Troubleshooting/Problems 6 07-28-2011 03:14 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community