Trouble starting, then starts with a knocking sound and gas smell - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-07-2016, 10:03 AM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Engine had trouble starting, then starts with a knocking sound and gas smell

This is '11 WK2 Laredo X 4x4 3.6l that I owned since new.

It had troubles starting in the past 2-3 times at most that were resolved by trying again and it never failed to start on 2-nd try. That was before TIPM recall was performed.

TIPM recall was performed about a year ago and I never had any problems until yesterday.

As of yesterday car sat unused for 2 days which usually never happens (I drive it to work every day and on weekends).

When I tried to start it wouldn't start after multiple attempts. It was not completely dead, just kind of struggling while cranking up. I tried maybe 8 times and at the end it did start with a knocking sound (similar to one that I had on my old ZJ when it needed exhaust replaced due to exhaust leak) and strong gas smell. I didn't notice any fuel leaks though.

I am attaching a sound capture.

No Check engine light at any time but I do recall seeing battery light a couple times after it failed to start.

So I decide not to drive it and left it alone for about half an hour while I went to run some errands. Came back and it started seemingly OK but didn't have more than a minute to wait and see anymore.

What do you think about all this? I think it could be replacement TIPM relay failing or bad battery (battery was never replaced). But I thought this battery is supposed to last for the lifetime of the vehicle.

I am concerned about knocking sound and gas smell. Can I drive it? Don't want to damage it more if it is already damaged, let alone get stuck on the highway.

Will go out and check it again soon.
Attached Files
File Type: zip Recording7.zip (290.1 KB, 5 views)

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-07-2016, 10:17 AM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Trouble starting, then starts with a knocking sound and gas smell

Had some trouble uploading audio as forum is picky about file formats but now it says "This video is currently processing..." for OGG ASF format (ogg didnt seem to work).

Sorry but nothing except ZIP-ed MP3 really seems to work.
Reply With Quote
  #3  
Old 08-07-2016, 07:07 PM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Trouble starting, then starts with a knocking sound and gas smell

Went out and checked again and it started right away.

Drove it for half an hour to get battery charged and no problems.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-07-2016, 10:19 PM
The Evil Twin's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2013
Location: Gainesville, VA
Posts: 684
Thanks: 37
Thanked 81 Times in 63 Posts
Rep Power: 440591
The Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond repute
Garage
Re: Trouble starting, then starts with a knocking sound and gas smell

The gas smell Gould have been unspent fuel through the exhaust since it didn't start.
__________________
#132-Motosylum Racing

2017 Sponsors: Amsoil, SHOEI, www.DC-MOTO.net, Woodcraft-CFM, VP Racing Fuels, www.MARRC.org
Amsoil 5w-20 synthetic meets Chrysler MS-6395 for my Jeep!
Reply With Quote
The Following User Says Thank You to The Evil Twin For This Useful Post:
  #5  
Old 08-07-2016, 10:23 PM
Member
My Jeep: 2015 3.2L KL
 
Join Date: Jun 2016
Location: South of Omaha, NE
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 2107
1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute1Hatchet has a reputation beyond repute
Re: Engine had trouble starting, then starts with a knocking sound and gas smell

Try having your battery tested at your local parts store.

No batteries do not last the life of your car four to six years is about max.


Sent from my iPad using JeepGarage
Reply With Quote
  #6  
Old 08-09-2016, 06:13 PM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Trouble starting, then starts with a knocking sound and gas smell

Quote:
Originally Posted by The Evil Twin View Post
The gas smell Gould have been unspent fuel through the exhaust since it didn't start.
That makes perfect sense.
Reply With Quote
  #7  
Old 08-09-2016, 06:16 PM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Engine had trouble starting, then starts with a knocking sound and gas smell

Quote:
Originally Posted by 1Hatchet View Post
Try having your battery tested at your local parts store.

No batteries do not last the life of your car four to six years is about max.


Sent from my iPad using JeepGarage
Tested it at AutoZone and they said it is at 100%. But I don't think their tester has a special setting for AGM batteries. Ordered this from Amazon: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Will let you know what it shows.
Reply With Quote
The Following User Says Thank You to JoeSchmoe007 For This Useful Post:
  #8  
Old 08-10-2016, 03:22 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,105
Thanks: 74
Thanked 293 Times in 257 Posts
Rep Power: 46531
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Engine had trouble starting, then starts with a knocking sound and gas smell

Quote:
Originally Posted by JoeSchmoe007 View Post
Tested it at AutoZone and they said it is at 100%. But I don't think their tester has a special setting for AGM batteries. Ordered this from Amazon: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Will let you know what it shows.
AGM batteries tend to have a service life that looks like this:

_____________________________
|
|


New ones are cheaper than tow trucks.

Any chance you have the evap canister that tends to make knocking sounds on start up as it purges?
Reply With Quote
  #9  
Old 08-10-2016, 05:27 PM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,332
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 8965
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Engine had trouble starting, then starts with a knocking sound and gas smell

Quote:
Originally Posted by lstowell View Post
...
Any chance you have the evap canister that tends to make knocking sounds on start up as it purges?
I don't know. I know I haven't added it myself, so if 3.6 V6 engine comes with it then I do have it.

It hadn't made that noise again.
Reply With Quote
  #10  
Old 08-20-2016, 09:57 PM
Member
 
Join Date: Aug 2016
Posts: 29
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 320
LQBlues is on a distinguished road
Re: Engine had trouble starting, then starts with a knocking sound and gas smell

Had a similar problem on my 97 ZJ 4L.replaced the fuel pump after 150,000 moles and it started up right away. But kept getting OBD error message pointing to Emma ions leak. First I replaced the gas cap but it sister stop the strong gas odor. To make the long story short, the problem turned out to be a cracked hose coming off the gas tank. Hose was 18 years old and I had the hoses and clamps replaced. Sure enough no more emissions error code or gas odor on the 97 ZJ. Also let checking the emissions system and found a cracked charcoal canister on the front driver side by the driver side fender and replaced this as well.
Everything is running fine now with no gas odor coming from rear fill up tube or front canister. Not expensive but should have replaced the rear hoses when the fuel pump was replaces. Could have been included in the same labor charge.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine starts then stops CHESH New Members - Welcome! 16 09-10-2014 06:50 AM
Starts THEN stalls, unless key is inserted... JeepJunkie Trouble Shooting/Problems/Service 0 04-28-2014 10:33 AM
Cranks and cranks and cranks then starts MWR1 Troubleshooting/Problems 6 03-23-2013 03:31 PM
jeep cranks sometimes and then finally starts wkjeepgirl86 Troubleshooting/Problems 15 05-26-2012 07:06 AM
2008 wk 4.7 v8 starts and then wont start crystalkekela Troubleshooting/Problems 0 05-12-2012 05:13 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.