Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-02-2013, 01:41 PM
Member
 
Join Date: Nov 2011
Posts: 854
Thanks: 19
Thanked 17 Times in 16 Posts
Rep Power: 44006
JeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond repute
UConnect 5.0 software update.

Hi guys, apologies if this has been posted but I didn't see anything on the first or second page. For those with UConnect 5.0 (and perhaps 8.4?), an update has been made available that you can actually do yourself:

https://rsur.extra.chrysler.com/rsur/Uconnect.do

The current release date shows as being 5/1/2013.

For the 5.0, the PDF containing the instructions says the update contains "Improvements to Phone Pairing capability" and "Increased ease of use". The former is apparently a fix relevant to TSB 08-028-13 (
"RA2 PAIRED PHONE LIST IS DELETED AFTER IGNITION CYCLE"), which was issued on 4/25. I've experienced this problem since I first got the vehicle and I just assumed it was my phone (which is non-iPhone/Android). I'm curious to see what the "increased ease of use" changes bring...
__________________

__________________
Reply With Quote
  #2  
Old 05-02-2013, 02:40 PM
Member
 
Join Date: Apr 2013
Posts: 175
Thanks: 0
Thanked 9 Times in 4 Posts
Rep Power: 2124
nikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond reputenikon858 has a reputation beyond repute
Re: UConnect 5.0 software update.

No updates come up when I put in my VIN, I have the 8.4 though.
__________________

__________________
14' Grand Cherokee Limited Hemi 4x2
http://s107.photobucket.com/user/nik...and%20Cherokee
Reply With Quote
  #3  
Old 05-02-2013, 02:42 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 599
HeadShrinkerMD is on a distinguished road
Re: UConnect 5.0 software update.

I did this update the other day. Very simple. Iphone pairing issue totally resolved.
__________________
2014 Grand Cherokee Laredo E, QT1, V6
Reply With Quote
  #4  
Old 05-03-2013, 05:03 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 841
Thanks: 8
Thanked 18 Times in 13 Posts
Rep Power: 127273
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
Re: UConnect 5.0 software update.

Thanks for posting this! While I was sitting at the dealer last friday I went to this website on my phone and it said I had a update available, so I asked about it and they said they would hook it up to the computer and see if there was anything, it said there wasn't an update available, which I thought was weird. I'm thinking someone jumped the gun or something with it.
__________________
Reply With Quote
  #5  
Old 05-03-2013, 06:36 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 841
Thanks: 8
Thanked 18 Times in 13 Posts
Rep Power: 127273
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
Well, i tried to go install it, turns out the dealer must have updated it and not told me. Now the menus are changed a little and I now have the ability to enable and disable drl's like what is on the 8.4 " radio, I lost the ability to turn the hill start assist on and off though...
__________________
Reply With Quote
  #6  
Old 05-03-2013, 07:39 PM
Member
 
Join Date: Apr 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 555
JeffC is on a distinguished road
Re: UConnect 5.0 software update.

I have a 2013 Laredo E with the RA2 - Uconnect 5.0 I assume. I've already had the phone pairing issue corrected by the dealer and it works fine; but I am curious about the "increased ease of use" so I wanted to see if I should update.

When I input my VIN on the Uconnect page I see that the update is listed, along with a link to the instructions. But...the model radio shown in pictures in the instructions is slightly different that what I have in my Jeep. In place of a settings button as shown in the instructions, I have a 'Climate' button.

I have a +More button just like the model shown in the pictures in the instructions, and when I press there I can access a 'Settings' menu, but scrolling through that menu don't have the 'System Information' selection shown in the pictures.

Anyone have this version of radio and know how to check your SW version?

Thanks, Jeff
__________________
Reply With Quote
  #7  
Old 05-03-2013, 07:44 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 841
Thanks: 8
Thanked 18 Times in 13 Posts
Rep Power: 127273
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
Quote:
Originally Posted by JeffC View Post
I have a 2013 Laredo E with the RA2 - Uconnect 5.0 I assume. I've already had the phone pairing issue corrected by the dealer and it works fine; but I am curious about the "increased ease of use" so I wanted to see if I should update.

When I input my VIN on the Uconnect page I see that the update is listed, along with a link to the instructions. But...the model radio shown in pictures in the instructions is slightly different that what I have in my Jeep. In place of a settings button as shown in the instructions, I have a 'Climate' button.

I have a +More button just like the model shown in the pictures in the instructions, and when I press there I can access a 'Settings' menu, but scrolling through that menu don't have the 'System Information' selection shown in the pictures.

Anyone have this version of radio and know how to check your SW version?

Thanks, Jeff
2013's didn't come with the ra2 radio... Mine isn't like pictured either and the software version isn't anywhere in there either, I just plugged the flash drive in and it says what you have and what it would go to, if the numbers match you are up to date.
__________________
Reply With Quote
  #8  
Old 05-03-2013, 08:14 PM
Member
 
Join Date: Apr 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 555
JeffC is on a distinguished road
Re: UConnect 5.0 software update.

Thanks for the response & sorry for my typo - I do have a 2014.
__________________
Reply With Quote
  #9  
Old 05-05-2013, 06:04 PM
Member
 
Join Date: Nov 2011
Posts: 854
Thanks: 19
Thanked 17 Times in 16 Posts
Rep Power: 44006
JeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond reputeJeepersCreepers has a reputation beyond repute
Re: UConnect 5.0 software update.

Quote:
Originally Posted by loveracing1988 View Post
2013's didn't come with the ra2 radio... Mine isn't like pictured either and the software version isn't anywhere in there either, I just plugged the flash drive in and it says what you have and what it would go to
Likewise.
__________________
Reply With Quote
  #10  
Old 05-09-2013, 03:30 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 841
Thanks: 8
Thanked 18 Times in 13 Posts
Rep Power: 127273
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
I'm so glad that Chrysler came out with a update. It sure wasn't perfect before but now we are having issues with my wife's phone disappearing altogether and she has to re-pair it every time she gets in it... Thanks Chrysler!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHB software update camaro430sut Audio/Visual/Navigation 4 10-15-2012 09:30 AM
Software Update MrWow Engine Performance/Intakes/Exhausts 8 12-16-2011 02:04 PM
Software update: darkrt Grand Cherokee - WK2 - 14 08-21-2011 08:08 AM
430 (without N) Software Update? Angel Audio/Visual/Navigation 2 07-21-2011 05:11 PM
Help with this Software Update Sticker fireguy Trouble Shooting/Problems/Service 4 04-14-2011 09:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community