Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-22-2014, 06:10 AM
EV1L's Avatar
Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1599
EV1L is on a distinguished road
Exclamation Uconnect 8.4-inch Not Working

The screen went out and right now its not working, nothing, blank. I can't figure what went wrong.

It froze on me for a bit, and when I restated the vehicle it didn't start.

My Jeep is '14 limited.
__________________

__________________
Reply With Quote
  #2  
Old 07-22-2014, 12:02 PM
sanitarium16's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2009
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2145
sanitarium16 is on a distinguished road
Re: Uconnect 8.4-inch Not Working

Happened to my dads 14 SRT Jeep. Screen we blank...nothing. They had to replace the unit.
__________________

__________________
2014 Jeep Grand Cherokee Altitude
Reply With Quote
  #3  
Old 07-22-2014, 08:30 PM
EV1L's Avatar
Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1599
EV1L is on a distinguished road
Re: Uconnect 8.4-inch Not Working

Well, I tried disconnecting the battery in hope that it would reset itself, but that didnt fix it. Still dead.

Im hoping it is something minor as loose wiring.. I dont want the wait for a new unit as the local dealer sucks.

Any thoughts!?
__________________
Reply With Quote
  #4  
Old 07-22-2014, 09:05 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927089
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Uconnect 8.4-inch Not Working

Quote:
Originally Posted by EV1L View Post
Well, I tried disconnecting the battery in hope that it would reset itself, but that didnt fix it. Still dead.

Im hoping it is something minor as loose wiring.. I dont want the wait for a new unit as the local dealer sucks.

Any thoughts!?
Have you done any of the updates on the radio?

leave the unit overnight, if it recovers, make sure to update it.
__________________
Reply With Quote
  #5  
Old 07-23-2014, 10:25 AM
EV1L's Avatar
Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1599
EV1L is on a distinguished road
Re: Uconnect 8.4-inch Not Working

Quote:
Originally Posted by Willx View Post
Have you done any of the updates on the radio?

leave the unit overnight, if it recovers, make sure to update it.
No I havent, as I wasnt aware of such updates.

Do you know what they are for?
__________________
Reply With Quote
  #6  
Old 07-23-2014, 10:49 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927089
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by EV1L View Post

No I havent, as I wasnt aware of such updates.

Do you know what they are for?
Numerous things including black screen.

Did the radio come back?
__________________
Reply With Quote
  #7  
Old 07-23-2014, 02:05 PM
EV1L's Avatar
Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1599
EV1L is on a distinguished road
Re: Uconnect 8.4-inch Not Working

No radio, and nothing else within the unit is functioning.

Also, there are no messages or errors either displayed concerning it.
__________________
Reply With Quote
  #8  
Old 07-23-2014, 02:27 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927089
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by EV1L View Post
No radio, and nothing else within the unit is functioning.

Also, there are no messages or errors either displayed concerning it.
It is likely a straight replacement and you will need to talk to your dealer for that. When you get your new radio make sure it is running 14.25.05
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a tire shop switch out my oem 17 inch wheels to eom 20 inch Overland wheels vjs5150 Suspension/Driveline/Brakes/Wheels/Tires 10 11-23-2013 02:28 PM
20" inch and 22" inch rim Pictures NikonKiem Grand Cherokee - WK 28 08-14-2012 07:28 PM
Bilsteins with half inch strut spacer equal almost one inch lift? mosier Suspension/Brakes/Wheels/Tires 6 03-03-2012 04:36 PM
20-Inch x 8.0-Inch BRIGHT Polished Aluminum Wheels jgc4ever Suspension/Driveline/Brakes/Wheels/Tires 4 03-23-2011 09:33 AM
20 inch chrome wheel? 20 inch polished? Same? CitizenNick Suspension/Driveline/Brakes/Wheels/Tires 1 01-18-2011 10:31 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.