Uconnect bluetooth disconnecting - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-13-2015, 12:24 AM
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Feb 2015
Location: Chicago, IL
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 814
PTTOverland is on a distinguished road
Uconnect bluetooth disconnecting

Hey guys,
Is anyone experiencing this issue.. I have a 2015 Overland and a Iphone 6. Since doing the ios 9.0.2 update which cane out couple weeks ago, I keep having issues with my bluetooth disconnecting from my jeep. Im not sure if its because of the update but it started since i did the update. When i start my car and turn on (e.g Pandora) on my phone, it starts playing normally. 10 seconds later the bluetooth disconnects and i go to my bluetooth settings and manually push the Uconnect bluetooth tab to connect it back up. Sometimes it remains on, and sometimes i have to turn it on 3-4 times untill it stays on. Once it stays on for at least 20 seconds then it wont disconnect any more. Is there a way to fix this?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-13-2015, 06:59 AM
Ollie's Avatar
Member
 
Join Date: Aug 2015
Posts: 130
Thanks: 26
Thanked 19 Times in 16 Posts
Rep Power: 751
Ollie is on a distinguished road
Re: Uconnect bluetooth disconnecting

I've got a 2015 WK2 and from iOS 8 to iOS 9, it has been disconnecting a few times a week.

It's quite horrible.


Sent from my iPad using JeepGarage
Reply With Quote
  #3  
Old 10-13-2015, 08:06 PM
Member
 
Join Date: Jan 2015
Posts: 24
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 860
quikduk is on a distinguished road
Re: Uconnect bluetooth disconnecting

I only have a 5S (work provided so IDK that it isn't the latest...) but mine does this from time to time. Better yet, if I plug in via the USB before I "accept" the radio's initial message AND connect via the "Device" touch button, the entire unit hangs up. No control of any radio function.

I have to shut off the vehicle, exit and lock it until the DTRL and interior lights go out. Then I can get back in and try the "right" way.

What a PITA. Maybe there is a flash for the radios.
Reply With Quote
  #4  
Old 10-14-2015, 06:22 AM
New Member
 
Join Date: Oct 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
4knee07 is on a distinguished road
Re: Uconnect bluetooth disconnecting

Definitely having the same issues as yourself PTTOverland since updating to IOS 9.0.2. It's definitely a Bluetooth issue, cause as soon as I turn that off and connect through USB, music will work but obviously phone calls won't connect through the speaker system which is kind of the most important feature! Haven't found a fix yet but hopefully someone has and posts here soon!!
Reply With Quote
  #5  
Old 10-14-2015, 08:01 AM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 196
Thanks: 156
Thanked 28 Times in 23 Posts
Rep Power: 2228
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

I had my iPhone behave in a similar fashion on 8.4.1. It connected, then disconnected. Very frustrating! I removed the bluetooth pairing in UConnect, restarted it and did the same in IPhone. It did not give me any problems after that. Then I upgraded to a new iPhone which meant 9.0. I've been running on 9.0.2 since it came out and am not experiencing these issues.

You might want to try the above methods first, but if that doesn't work, I would suggest erasing the Network Settings in iPhone. Settings>General>Reset>Reset Network Settings

Doing so will wipe out all of the paired bluetooth devices and unfortunately any of your previously setup WiFi networks but it can resolve some connectivity problems.
Reply With Quote
  #6  
Old 10-14-2015, 09:44 AM
AirBull's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Jun 2015
Location: Texas
Posts: 153
Thanks: 10
Thanked 35 Times in 26 Posts
Rep Power: 1484
AirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond reputeAirBull has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

I noticed this last weekend myself, as well. Latest update via the recall on the Uconnect. Bluetooth just turned off while on a call, and conversation routed over to my phone. Had never experienced that before.
__________________
2015 Jeep Grand Cherokee Summit California Edition 4x4 EcoDiesel

Reply With Quote
  #7  
Old 02-24-2016, 10:24 AM
New Member
 
Join Date: Feb 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jerce301 is on a distinguished road
Re: Uconnect bluetooth disconnecting

Uconnect is a piece of crap software. I have a 2015 Jeep Grand Cherokee I purchased in August. Ucgonnect keeps disconnecting my Sirius radio and switching to my phone. Then screen says connect device. This is insanely annoying. I couldn't make calls or listen to anything without it cutting out and reverting to the sound just on my phone. I am seriously considering trading it in on a vehicle with sync - I previously had a 2010 Lincoln and had no issues whatsoever with the hands free system. The only work around I found with the bluetooth disconnect and reconnect is that I have to have the music player on my phone already running before I turn on the Jeep and accept the Uconnect on the screen. I also turned power save off on my phone and set display timeout to an hour.
Reply With Quote
  #8  
Old 02-24-2016, 11:46 AM
ssgunner's Avatar
Senior Member
My Jeep: 2017 3.6L WK2
 
Join Date: Jun 2014
Location: So Cal
Posts: 1,006
Thanks: 20
Thanked 63 Times in 58 Posts
Rep Power: 2137
ssgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

I agree, uconnect is not the best. Won't say its crap cause it works for me until recent.

I did the latest update to the software last July so its current. What i have noticed though, the system quacks out i believe with all the new IOS updates that keep getting released. Never had a problem with android. (sort of regret switching to iphone for that reason alone). Even after i got my iphone last August didnt have any issues on ios 7. It all started after ios 8 - to current. Music > song titles are displayed incorrectly and also lose BT connectivity sometimes. The uconnect app works (sometimes) and its a mission to actually connect if it doesn't launch automatically.

Latest issue i've had is my nav directions. My icon showing me where i am currently located in the nave instead of appearing upright, it shows sideways and its annoying. Luckily i have the directions on the dash enabled so that helps but on the uconnect it appears sideways. I mean not the entire nav is sideways but the icon appears sideways and doesn't correct it self after each turn.

Sorry for hijacking thread just annoyed at this.
__________________
2014 Jeep Grand Cherokee Overland 4x2 5.7 HEMI MAX Steel>Build Date:Oct/13-Mods: Billet CC Blue, Searching for best exhaust option...
Reply With Quote
  #9  
Old 02-24-2016, 12:34 PM
New Member
 
Join Date: Feb 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jerce301 is on a distinguished road
Re: Uconnect bluetooth disconnecting

Ssgunner - I have an HTC One android phone, so I don't believe the issue is with the OS on any phone. I also have downloaded and applied the latest Uconnect update for my vehicle. There are way too many people experiencing these disconnects and the common denominator is Uconnect. I've read posts from people with Audi's, BMW's, Dodges, etc. with various models of phones and phone OS software. I did get a reply from Uconnect regarding my issue and am awaiting a call from their techs. If I get no resolution, I am going to trade my vehicle to something that uses AutoSync.
Reply With Quote
  #10  
Old 02-24-2016, 01:46 PM
Member
 
Join Date: Feb 2011
Posts: 856
Thanks: 23
Thanked 97 Times in 73 Posts
Rep Power: 3144
Snipe315 has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

I've used several Android devices (HTC, Sony, Samsung, & Motorola) with my 2015 Overland and none of them have had any issues. This is when using the older UConnect software or the latest version.

I suspect this is an APPLE issue.
__________________
2015 WK2 Overland 4x4 V8, Granite Exterior/Black Interior, ORA II, Advance Tech Package, Rear Seat DVD/Blu-ray
Reply With Quote
  #11  
Old 02-24-2016, 02:51 PM
ssgunner's Avatar
Senior Member
My Jeep: 2017 3.6L WK2
 
Join Date: Jun 2014
Location: So Cal
Posts: 1,006
Thanks: 20
Thanked 63 Times in 58 Posts
Rep Power: 2137
ssgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond reputessgunner has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

Quote:
Originally Posted by Snipe315 View Post
I've used several Android devices (HTC, Sony, Samsung, & Motorola) with my 2015 Overland and none of them have had any issues. This is when using the older UConnect software or the latest version.

I suspect this is an APPLE issue.
That's what I'm starting to believe. Never had issues with Samsung Galaxy S3 or S5. I had the S3 when I picked up my truck almost 2 yrs ago and promptly switched to S5 that I dumped for the iPhone 6 Plus last August. Even then I didn't have issues with the iPhone until iOS 8 came out and I updated. I don't remember exactly what iOS update following the release of 8, maybe 8.0.1 or so might have fixed the song titles issue but was later broken again with a later update. It doesn't surprise me at all being in my line of work and working with IS when enhancements or system updates are done its prone to have something overlooked and breaking something that was working before on future updates. It's imperative to validate system mock ups to avoid things being broken that previously where working.

None the less apple and uconnect need to get their shiz together. My main peev is the damn NAV right now. Did I mention it's annoying? Lol.
__________________
2014 Jeep Grand Cherokee Overland 4x2 5.7 HEMI MAX Steel>Build Date:Oct/13-Mods: Billet CC Blue, Searching for best exhaust option...
Reply With Quote
  #12  
Old 02-24-2016, 04:27 PM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 196
Thanks: 156
Thanked 28 Times in 23 Posts
Rep Power: 2228
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Uconnect bluetooth disconnecting

Since 2011, I've had 3 different iPhones and have upgraded from iOS 6 to iOS 9 spanning 2 different Jeep vehicles.

The only major issue I had was when I upgraded to iOS 7 and I wasn't alone. People with many different types of vehicles ranging from US brands to luxury imports had the same problems I did. The update had broken the bluetooth stack for many of us. They worked on the issue and within a couple of weeks released an update which fixed my problem. Since then I've had one hiccup--the WK2's UConnect lost my pairing. I simply removed the pairing from each device and repaired. Since then no issues (knock on wood).

I've learned that any time you deal with technology there are going to be isolated issues with individual devices or between devices, it's just something I've accepted as part of the game. Widespread issues, especially with Apple products are well documented all over social media and various websites, including Apple support forums. You might try investigating the Apple Forum to see if others are reporting similar issues.

I also am inclined to believe that UConnect may be an issue. Have you tried rebooting UConnect? Have you reached out to UConnect to attempt to resolve the issue?

I commented earlier in this thread that erasing the Network Settings in the iPhone has been known to resolve connectivity problems, you may consider giving that a shot if you've not already done so. Last resort would be to backup, wipe it and then set up the phone fresh. It is not convenient to say the very least, but worth the effort especially if it resolves the issue.
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Bluetooth connecting and disconnecting and Navi black 7777777 Trouble Shooting/Problems/Service 0 09-14-2015 10:35 PM
disconnecting front drive shaft Jeep4u3 Grand Cherokee - WK 2 03-31-2013 10:49 PM
Disconnecting Lights from Alarm system DJCompaq Interior/Exterior/Visual/Lighting 11 05-08-2012 05:27 PM
Disconnecting Front/Rear Swaybar for Off Road? Crashtown Off Road Modifications 9 09-06-2011 01:45 PM
Disconnecting/Reconnecting Sub batman Audio, Video, Navigation & Electronic Modifications 13 05-14-2011 02:11 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.