Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-01-2011, 08:29 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Ridgeland, MS
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1185
Parrot is on a distinguished road
UConnect problems with Samsung Galaxy

I apologize if this has been asked but I did not see anything when I did a quick search for Samsung Galaxy and UConnect.

The UConnect worked fine with a Blackberry Tour. I switched to the Samsung Galaxy and the problems began. When I run through the pairing process, the phone pairs and will show connected. On occasion, I can hit the steering wheel phone button and call the number I speak (phonebook will not download), but the call plays through the phone not through the radio (RBZ). Again, on occasion, the radio display will show the display the number called. Most times when I can get UConnect to make a call, it only dials and terminates the call. Other times, the phone shows paired and connected but UConnect will not do anything. My phone will pair, connect and make calls through the UConnect on another Jeep with the 430N.

When I call the UConnect toll free number, they tell me that the phone isn't on the compatibility list my RBZ or the 430N and that I should get an error message on the screen. No error message at any time.

I took it into the local dealer and received a "we don't know." The service technician said he is researching it with "Star," whatever that is.

Any help or suggestions?
__________________

__________________
Reply With Quote
  #2  
Old 06-02-2011, 02:35 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652942
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: UConnect problems with Samsung Galaxy

well that is crappy... only because I just purchased a galaxy S... not that I have uconnect or plan on getting it any time soon, but it was nice having a phone to test customer vehicles as required.

www.Jeep.com has ALL that you want to know, the "for owners" tab at the top is where I got this information. There is a couple problems that techs face with phone paring, mainly all diagnostic information "given" to techs is "look in e-files for a phone compatibility list" so you go look in e-files and find a compatibility list dated 07-09 (or something like that). NOWHERE does it mention ON THE MANUFACTURER WEBSITE is your answer. I have had the same issue, an obvious phone issue because my old phone paired to the vehicle just fine, but the customer said they called and were told the phone wasnt a the problem that it was compatible so naturally my outdated printoff didnt satisfy them and I made a starcase, which for your information would just be a tech contacting a higher power . This would be done to see if there is known unpublished, or unpublic information on common issues showing up.

if you go to the jeep website you can pull up the "bluetooth phone compatibility test results" link in the middle of the page. You will see the galaxy S SCHi500 (the part number off my phone) along with all other part numbers wiki had for the galaxy S, were NOT on the compatibility list.

You need a different phone, sorry.
__________________

__________________
Reply With Quote
  #3  
Old 06-02-2011, 05:08 AM
ENFORCER's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,962
Thanks: 23
Thanked 81 Times in 65 Posts
Rep Power: 321938
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: UConnect problems with Samsung Galaxy

Have you updated your phones software and the 430's firmware ?
It would be a good idea to have a look at the updates available to fix it yourself.
__________________
Previous Ride = 2011 JGC CRD Overland
Current Ride = 2014 Silver JGC SRT with Pano, HK and Spider monkeys.
Mods = CLSTech Ribbon Mod
Reply With Quote
  #4  
Old 06-02-2011, 09:58 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Ridgeland, MS
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1185
Parrot is on a distinguished road
Re: UConnect problems with Samsung Galaxy

I checked the Jeep Owners' site, thanks for the info. While it does not list the Galaxy as a compatible phone for the RBZ, it also says that the Galaxy isn't compatible with the 430N and I have used the UConnect without any problems in the GF's jeep. Are the 2 systems' UConnect or BT components that different?
__________________
Reply With Quote
  #5  
Old 06-04-2011, 03:45 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Ridgeland, MS
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1185
Parrot is on a distinguished road
Re: UConnect problems with Samsung Galaxy

And today, out of the blue, UConnect paired, connected and functioned as it should with my phone. I have no clue how, why or if it will continue to work.
__________________
Reply With Quote
  #6  
Old 06-10-2011, 03:50 AM
CherokeeGuy's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Los Angeles, CA
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1225
CherokeeGuy is on a distinguished road
Re: UConnect problems with Samsung Galaxy

Did your phone have a software update by any chance?

When I had my old WK, my Uconnect worked fine with my old Motorola. When I got my iPhone 3G, it was a disaster. The system recognized my phone, and my phone listed UConnect as a Bluetooth pairing...by no audio worked during calls. I called Chrysler several times, as well as my dealer, and finally Apple...no luck. Everybody said the other system was a fault. magically after 6 months and software updates on both ends, it started to work.

My recommendation is to keep your phone updated to the latest system.
I've had no issues with and iPhone4 and a 430N RHB...except for it taking ages to answer even after I hit accept...No improvement noticed with the latest radio and phone updates.

Good luck!
__________________
_____________________
2011 Overland 5.7L HEMI Dark Charcoal on Black, Adaptive Cruise, ORA II, MOPAR Roof Rails, Shark Fin Antenna

Previous JGCs:
2007 Overland 5.7L HEMI Green on Khaki
2004 Overland 4.7L H.O. Inferno Red on Black
2002 Laredo (with hamster on wheel) Steel Blue on Black
Reply With Quote
  #7  
Old 06-10-2011, 12:28 PM
Premium Member
My Jeep: 2011
 
Join Date: Feb 2011
Location: PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1356
TalPA is on a distinguished road
Re: UConnect problems with Samsung Galaxy

How do you update the 430 firmware?
__________________
Reply With Quote
  #8  
Old 06-10-2011, 02:20 PM
CherokeeGuy's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Los Angeles, CA
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1225
CherokeeGuy is on a distinguished road
Re: UConnect problems with Samsung Galaxy

Burn a CD....there's a thread all about it.
dckcentuar posted this link:
http://www.mediafire.com/?rjw4hyrcaay958k

I burned a CD, and it worked fine....took about 30minutes.
__________________
_____________________
2011 Overland 5.7L HEMI Dark Charcoal on Black, Adaptive Cruise, ORA II, MOPAR Roof Rails, Shark Fin Antenna

Previous JGCs:
2007 Overland 5.7L HEMI Green on Khaki
2004 Overland 4.7L H.O. Inferno Red on Black
2002 Laredo (with hamster on wheel) Steel Blue on Black
Reply With Quote
  #9  
Old 06-10-2011, 06:49 PM
Premium Member
My Jeep: 2011
 
Join Date: Feb 2011
Location: PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1356
TalPA is on a distinguished road
Re: UConnect problems with Samsung Galaxy

Update complete and now my Droid2 now finally works with the UConnect..???????????
__________________
Reply With Quote
  #10  
Old 06-10-2011, 07:34 PM
CherokeeGuy's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Los Angeles, CA
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1225
CherokeeGuy is on a distinguished road
Re: UConnect problems with Samsung Galaxy

Quote:
Originally Posted by TalPA View Post
Update complete and now my Droid2 now finally works with the UConnect..???????????
Sweet! Glad it worked
__________________
_____________________
2011 Overland 5.7L HEMI Dark Charcoal on Black, Adaptive Cruise, ORA II, MOPAR Roof Rails, Shark Fin Antenna

Previous JGCs:
2007 Overland 5.7L HEMI Green on Khaki
2004 Overland 4.7L H.O. Inferno Red on Black
2002 Laredo (with hamster on wheel) Steel Blue on Black
Reply With Quote
  #11  
Old 06-25-2013, 10:35 AM
cbrain's Avatar
New Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2013
Location: Chile, South America
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
cbrain is on a distinguished road
Re: UConnect problems with Samsung Galaxy

You could tell in more detail how to do the update

Thanks
__________________
Black Stallion
Reply With Quote
  #12  
Old 04-02-2014, 12:16 PM
New Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2014
Location: New Hampshire
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
johnitv is on a distinguished road
Re: UConnect problems with Samsung Galaxy

Quote:
Originally Posted by CherokeeGuy View Post
Burn a CD....there's a thread all about it.
dckcentuar posted this link:
RHB_E_23_4

I burned a CD, and it worked fine....took about 30minutes.

....

Do you think that this downloaded update might possible work on a 430RBZ U-Connect system (installed on my 2011 Durango)?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Uconnect Wi-fi Jpeyatt Audio, Video, Navigation & Electronic Modifications 8 01-16-2012 10:35 AM
Samsung Galaxy S Captivate (Android) and 730N RHR boldd Audio/Visual/Navigation 10 03-27-2011 02:14 PM
UConnect problems with HTC Droid Incredible tks2010 Trouble Shooting/Problems/Service 19 03-21-2011 12:47 PM
UConnect jerky Trouble Shooting/Problems/Service 3 11-09-2010 11:07 AM
In a galaxy far far away... jcollins1888 Other Rides 23 09-04-2009 10:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community