Uconnect Software version 14.05.3. Up to date? - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-15-2014, 07:32 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 386
Thanks: 44
Thanked 86 Times in 52 Posts
Rep Power: 581712
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by JacksonGrandCherokee2014 View Post
How. Do you update it yourself.. Can you post a video?
Once you upgrade to premium membership you can visit the Uconnect forum where you can find a wealth of information and resources regarding the radio software upgrade.

__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 05-15-2014, 07:32 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2014
Location: Clovis
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
JacksonGrandCherokee2014 is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by SnoFire View Post
I don't have a video but you can go the link below to download the latest software. The instructions should be in there.

http://www.jeepgarage.org/f219/uconn...ica-72231.html

Thanks!


Jax
2014 Jeep Grand Cherokee Limited (Granite Crystal Metallic)
- 20 inch Wheels
- 8.4 inch NAV
- Power Sunroof
- Door Sill Guards w/ "JGC" Logo
- Mopar Splash Guards w/ Jeep Logo (Logo On Rear Only)
- Mopar Bright Pedal Kit

Ordered on March 28, 2014...Trying to wait patiently
Reply With Quote
  #15  
Old 05-16-2014, 08:32 AM
DaMac78's Avatar
Member
 
Join Date: Nov 2013
Posts: 21
Thanks: 2
Thanked 3 Times in 3 Posts
Rep Power: 1128
DaMac78 is on a distinguished road
Uconnect Software version 14.05.3. Up to date?

We live in Switzerland and got a Jeep GC 2014 with build-date 04/2013

Nothing but problems from Day one concerning Uconnect, a strange tweeting sound from the high preasure Diesel-Pump at low speeds, a too loud Ventilation system on the passenger side, one dead key, a wining noise from the power steering, damp headlights..

They are working together with Jeep to resolve the tweeting from the pump. The other issues are also all being taken care of soon.

As for the Radio... We went through 3 different software versions and now have the latest one as stated above.
Most issues are now resolved, but the radio still reboots sometimes while driving and the equaliser also has a strange issue.
They ordered a new Radio and I hope the issues will be resolved - until the next software-version with new fixes and new flaws is released.
However, Version 14 is by far the best to date.

What made me write this answer though, was your mentioning of the unclean shifting..
Never had this problem before the latest updates. Now, after they patched all software-versions including a "fix" for the shifting behaviour, the car drives like someone who cannot drive stick!

The new Software causes the acceleration and shifting to react way too sensitively. The car leaps forward sometimes, even if only touching the accelerator slightly - this does not happen often though.
The main issue I have with this update, is how the Jeep feels while driving in low gear. Terrible shifting from 1st to 2nd gear, causing the car to jerk and my passengers heads are pushed forward then back - even while giving the acceleration allot of love.
Some people where complaining about the Jeep not accelerating and reacting fast enough when in eco-mode. So what! I liked the silky feel of its accereration in eco! Great for when stuck in traffic too! I never minded it, as I just switched to Sport-Mode when sharp speed was really needed. Now, it is just TERRIBLE to drive! Jerking and unclean shifting all ober the place.
Engineers told me they cannot "officially" downgrade to the older version and will be doing a full gear-calibration as stated in one of Jeep's bulletins as a Fix for bad gear-shifting and jerky driving..

If this procedure does not help, I will be opening a Ticket with Jeep to downgrade to the last version of software - or will be hoping for a quick fix to the current version!

So - whatever you do, DO NOT let them patch any software concerning gear shifting!

I will get back to you when I know more and after they performed the bulletin callibration procedures.


Hope for the best guys!

Sent from my iPhone using JeepGarage
Reply With Quote
  #16  
Old 05-16-2014, 08:49 AM
Paullee01's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: West Palm Beach, FL
Posts: 451
Thanks: 20
Thanked 59 Times in 46 Posts
Rep Power: 7084
Paullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond repute
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by xatez View Post
I was wondering about this as well. My car is scheduled to be delivered in the next couple of weeks. Am I safe to assume everything will be up to date since it was just built?
Just go to the Uconnect website. They have complete instructions on how to do the update. If you go this route I'd recommend you use a Safari browser. Didn't work for me with Chrome or IE.

https://rsur.extra.chrysler.com/rsur/Uconnect.do
__________________
Grand Cherokee Limited 3.6L, Tinted windows, Sill guards, Body molding, CXV running boards, WeatherTech window deflectors, Husky floor liners, Zeigler lifetime maxicare

Reply With Quote
  #17  
Old 05-16-2014, 09:36 AM
AquaForester's Avatar
Member
 
Join Date: May 2011
Posts: 732
Thanks: 2
Thanked 15 Times in 11 Posts
Rep Power: 7942
AquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond reputeAquaForester has a reputation beyond repute
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by Paullee01 View Post
Just go to the Uconnect website. They have complete instructions on how to do the update. If you go this route I'd recommend you use a Safari browser. Didn't work for me with Chrome or IE.

https://rsur.extra.chrysler.com/rsur/Uconnect.do
It will work in chrome but you have to click the shield icon in the upper right to allow unsafe scripts?
Reply With Quote
  #18  
Old 06-10-2014, 12:08 PM
New Member
 
Join Date: Jun 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
agron2027 is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

Guys. I just did the update to my UConnect to the latest version on my 2014 Jeep Grand Cherokee. Everything went well, except now every time I turn off my car, UConnect reset's my Balance/Fade to back. Does anyone else have the same problem? Should I re-install the update or should I do a factory reset and then re-install the update? Please help.
Reply With Quote
  #19  
Old 06-12-2014, 09:18 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2012
Posts: 143
Thanks: 22
Thanked 3 Times in 3 Posts
Rep Power: 1847
Celestinemusic is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

I had that problem several months ago after an update. If I remember correctly, it was sensitive to the way that you went in to the audio settings menu. Eventually, I got it to stick. It may have been that you need to go into the audio menu from the applications menu or something like that. Try the various ways to go into the audio settings; one way works and it sticks. It is likely a bug in the current version. Once it sticks, works fine. Maybe someone can jump in if they remember the exact menu sequence.


Sent from my iPhone using JeepGarage
Reply With Quote
  #20  
Old 06-13-2014, 10:06 AM
SnoFire's Avatar
The Negotiator
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 5,059
Thanks: 70
Thanked 169 Times in 132 Posts
Rep Power: 391030
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by agron2027 View Post
Guys. I just did the update to my UConnect to the latest version on my 2014 Jeep Grand Cherokee. Everything went well, except now every time I turn off my car, UConnect reset's my Balance/Fade to back. Does anyone else have the same problem? Should I re-install the update or should I do a factory reset and then re-install the update? Please help.
Mine did the same thing with the balance/fade. After changing it a few times, it finally stuck. You can try to re-install it again as it won't hurt anything.
__________________
1997 Jeep Grand Cherokee Laredo Silver I6 - Sold
2001 Jeep Grand Cherokee Laredo Black 4.0 I6- Sold
2014 Jeep Grand Cherokee Limited Max Steel V6 - SOLD

2016 GMC Sierra 1500 Iridium Tungsten - Current
Reply With Quote
  #21  
Old 06-13-2014, 11:32 AM
New Member
 
Join Date: Jun 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
agron2027 is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

I'm not sure how it happened, but if finally stuck. Maybe I went into the audio menu from a different applications menu and if work fine now. Thanks for the ideas. Hopefully it will not be a problem anymore.
Reply With Quote
  #22  
Old 06-13-2014, 12:59 PM
Shannon's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: May 2013
Location: Lakeville, MN
Posts: 1,585
Thanks: 234
Thanked 223 Times in 143 Posts
Rep Power: 11498
Shannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond repute
Re: Uconnect Software version 14.05.3. Up to date?

Ever since I updated, every time I use the USB port to play music, then go back to bluetooth, the Uconnect states that I have to turn on Pandora on my phone first - when in fact it is already on. Pandora will only work with USB. To fix the issue, I have to uninstall Pandora, then reinstall. It will then work with bluetooth, until I attach to USB again, then from that point on, Pandora again will not play over bluetooth.
__________________
SFU: : 2016 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater - REPLACED: 2014 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater, with 2000 coats of paint



Current Rides:
2016 Jeep Grand Cherokee Overland Ecodiesel
2015 Cherokee Latitude (wife's ride)
2008 20' Four Winns bow rider speed boat
Reply With Quote
  #23  
Old 06-24-2014, 03:23 AM
DaMac78's Avatar
Member
 
Join Date: Nov 2013
Posts: 21
Thanks: 2
Thanked 3 Times in 3 Posts
Rep Power: 1128
DaMac78 is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

Quote:
Originally Posted by agron2027 View Post
Guys. I just did the update to my UConnect to the latest version on my 2014 Jeep Grand Cherokee. Everything went well, except now every time I turn off my car, UConnect reset's my Balance/Fade to back. Does anyone else have the same problem? Should I re-install the update or should I do a factory reset and then re-install the update? Please help.

Hi there, I had a different issue. Tested the Ballance/Fade issue after I read your post - not a problem.
However; My Equalizer settings have a strange behaviour. When entering the Equalizer Menu for the first time after starting the car, the sliders are in the correct position, but as soon as I touch one of them, the music gets a little louder and more detailed. I am not sure, but it seems the Equalizer is set to FLAT until one of the sliders is touched. Can anybody here confirm this?


Sent from my iPhone using JeepGarage
Reply With Quote
  #24  
Old 06-24-2014, 03:33 AM
DaMac78's Avatar
Member
 
Join Date: Nov 2013
Posts: 21
Thanks: 2
Thanked 3 Times in 3 Posts
Rep Power: 1128
DaMac78 is on a distinguished road
Re: Uconnect Software version 14.05.3. Up to date?

Just got my GC back from service.
LATEST SOFTWARE VERSION INSTALLED: 14.22.13

The interface seems a little more snappy and you can also make changes to the Navigation while the car is in motion.
Yet to discover any bugs, will report back as soon as I know more.


Sent from my iPhone using JeepGarage
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Uconnect software version shipped with vehicle? bordridr Grand Cherokee - WK2 - 2 03-03-2014 07:35 PM
Current TH Order Date to Build Date Timing Desert Hiker 2014+ Cherokee-KL 30 02-21-2014 01:38 PM
RER Software update to version 2.4 Navy1 Audio/Visual/Navigation 25 02-20-2014 03:18 AM
What version of Application Software did your RHR 730N come with? Corp Cog Audio/Visual/Navigation 33 06-05-2013 03:15 PM
1. Software Update MyGIG RHR-RHW-RHP Units / Version 2.120 *sox* Audio, Video, Navigation & Electronic Modifications 136 11-27-2012 09:44 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.