Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 07-17-2013, 02:21 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,038
Thanks: 204
Thanked 145 Times in 118 Posts
Rep Power: 89238
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Unable to engage surround sound option on Uconnect 8.4

Quote:
Originally Posted by Willx View Post
There have been lots of releases and stuff I would never run!!
I know what you mean. I'd hate like hell to install some software and brick my Jeep!
__________________

__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #14  
Old 07-23-2013, 11:21 AM
Member
 
Join Date: Mar 2013
Posts: 52
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 551
satori is on a distinguished road
Re: Unable to engage surround sound option on Uconnect 8.4

Do people enjoy the surround sound effect?

Does the center channel speaker work while the surround sound is not engaged?
__________________

__________________
2014 Grand Cherokee Limited; LUX II, ORA II, NAV, Michelin LTX M/S 2s
Reply With Quote
  #15  
Old 07-23-2013, 08:15 PM
alva000's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Tucson, AZ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 416
alva000 is on a distinguished road
Re: Unable to engage surround sound option on Uconnect 8.4

Quote:
Originally Posted by satori View Post
Do people enjoy the surround sound effect?

Does the center channel speaker work while the surround sound is not engaged?

satori:

Can't really say that I've enjoyed the surround sound option. It has never worked on JGC 2014.
__________________
Reply With Quote
  #16  
Old 08-10-2013, 02:32 PM
alva000's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Tucson, AZ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 416
alva000 is on a distinguished road
Re: Unable to engage surround sound option on Uconnect 8.4

Willx:

Thanks for the update. Took my jeep to the dealership a couple of days ago and they were unsuccessful, they told me that the updated firmware would stop at 80% and would take a dump.

They later told me that they were going to order another software CD from Chrysler and re-try the upgrade on my Jeep. They also mentioned that if they're still unable to update the firmware that they would need to remove the entire unit (Radio) and send it to Chrysler for repair. In the mean time I would be able to drive my Jeep without a head unit. That seemed to be a little strange.

Oh, well. I decided to take the update you have provided and do the update myself. It worked , no need to deal with the pesky dealer!

Thanks again!
__________________
Reply With Quote
  #17  
Old 08-10-2013, 02:45 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,835
Thanks: 526
Thanked 816 Times in 458 Posts
Rep Power: 1926936
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
silly dealers.

BTW.... for future reference you cannot drive the car without the radio in place, working or not. They would have had to order a replacement.

Again... silly.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Quadra-lift: "easy entry" option not appearing on UConnect menu? overlands Trouble Shooting/Problems/Service 85 10-06-2013 08:11 PM
Surround Sound on 2014 Overland keeps going back to Off Buknoy Grand Cherokee - WK2 - 12 05-10-2013 02:54 PM
High Frequency Sound with iPhone/Uconnect bluetooth music playing bgmtnclmbr Trouble Shooting/Problems/Service 1 09-07-2011 10:08 PM
UConnect Option Displays on 430 Radio hammer1234 Audio/Visual/Navigation 3 07-19-2011 02:24 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community