Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-01-2013, 08:07 PM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
"Vehicle phone needs service"

Anyone seen this error on their '14 (or anything with the RA4?). Error came up saying the vehicle phone needs service and to contact the dealer, which I'll do sometime tomorrow if I have time since it's not breaking the vehicle.

Tried to reset the modem via the engineering menu, no such luck.
__________________

__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
  #2  
Old 04-02-2013, 12:25 AM
Member
 
Join Date: Mar 2011
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1204
nickm is on a distinguished road
Re: "Vehicle phone needs service"

I got the same message a couple of days ago but I have no idea what it's talking about. 2014 overland v6. Sales man said maybe because I haven't set up uconect yet.
__________________

__________________
Reply With Quote
  #3  
Old 04-02-2013, 08:08 AM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
Re: "Vehicle phone needs service"

I definitely have uconnect set up and it's been working for the last month. On the phone with uconnect support now to see if it's something that I can fix or they can do OTA, but I have a feeling a visit to the dealer is in order.
__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
  #4  
Old 04-02-2013, 12:58 PM
Member
 
Join Date: Mar 2011
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1204
nickm is on a distinguished road
Re: "Vehicle phone needs service"

Thanks keep us posted
__________________
Reply With Quote
  #5  
Old 04-02-2013, 06:49 PM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
Dropping it off at the dealer tomorrow. We'll see what they say.


Sent from my Nexus 10 using Tapatalk HD
__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
  #6  
Old 04-03-2013, 07:35 AM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
Dropped it off this AM. Service guy that took it in has no idea how uconnect works haha. Was convinced that its supposed to run off my cell phone instead of there being a data card in the car.

Sent from my Nexus 10 using Tapatalk HD
__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
  #7  
Old 04-03-2013, 07:40 AM
PMD G8's Avatar
Premium Member
 
Join Date: Nov 2010
Posts: 468
Thanks: 4
Thanked 7 Times in 6 Posts
Rep Power: 24385
PMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond repute
Re: "Vehicle phone needs service"

This message flashed up once yesterday after I picked the car up. However, this was before I had the uconnect fully setup.
__________________
Currently:
Work: 2006 Dodge Charger Hemi, Dark Blue
Ours: 2009 Chevy Suburban LTZ, White
Mine: 2009.5 Pontiac G8 GXP, Silver
Wifes: 2014 Summit V8 4x4, Bright White/Black(Delivered 4/2/2013)
Reply With Quote
  #8  
Old 04-03-2013, 08:15 AM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
Re: "Vehicle phone needs service"

Mine has been setup and working since Feb. I was getting the error every time I started the car since Monday and uconnect is dead - can't control it via my phone and none of the apps work. Little disturbing though that the service guys don't know how the system actually works. He was dead convinced that everything runs through the users cell phone and not the car phone, thus my phone is the issue.
__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
  #9  
Old 04-03-2013, 03:15 PM
gwnewman1's Avatar
Member
 
Join Date: Dec 2011
Posts: 189
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 7011
gwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond reputegwnewman1 has a reputation beyond repute
Re: "Vehicle phone needs service"

So far replacing a hub underneath the center console. They ran an update for uconnect and that fixed the actual phone error, but they're not seeing the signal strength like they should. Getting the Jeep back until parts get in, we'll see what happens.
__________________

__________________
2014 WK2 Limited Max Steel 3.6L.
ORA-I, Moonroof, Towing and 8.4" Uconnect RA4.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"press the uconnect phone button to answer." dsmith14 Audio/Visual/Navigation 16 11-08-2013 01:32 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 06:48 AM
Any way to disable "Phone call completed"? avalys Audio/Visual/Navigation 8 01-25-2013 06:33 PM
Bypassing "Please Select a Line" for Phone Calls Big Green Audio/Visual/Navigation 0 01-31-2012 07:57 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community