Vehicle Phone Requires Service Software Bug - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-11-2017, 04:27 PM
New Member
 
Join Date: Apr 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jcsf420 is on a distinguished road
Vehicle Phone Requires Service Software Bug

I've been dealing with this "software bug" since the 16.13.13 update. This bug was confirmed by UCONNECT on a tech support phone call. They have been promising a fix since May 2016. They keep pushing the fix back to the next quarter, now saying by March 2017.

Who else has this issue that was caused by the 16.13.13 update? You can tell if you have this issue if you receive the "Vehicle Phone Requires Service" screen, the clock loses times and the GPS loses your location. I have found that most dealers do not even know about this UCONNECT software bug.

This is very frustrating. Has anyone with this issue been able to downgrade to the previous version of the software with success? I don't know what else we can do, this is a real safety issue too since you can't connect to 911 in an emergency. I'd love to see a class action lawsuit but have no idea how many vehicles are involved.

Any ideas Folks?
Thanks
John

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-14-2017, 09:24 AM
Member
 
Join Date: Jul 2014
Posts: 56
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 967
karirick is on a distinguished road
Re: Vehicle Phone Requires Service Software Bug

Quote:
Originally Posted by jcsf420 View Post
I've been dealing with this "software bug" since the 16.13.13 update. This bug was confirmed by UCONNECT on a tech support phone call. They have been promising a fix since May 2016. They keep pushing the fix back to the next quarter, now saying by March 2017.

Who else has this issue that was caused by the 16.13.13 update? You can tell if you have this issue if you receive the "Vehicle Phone Requires Service" screen, the clock loses times and the GPS loses your location. I have found that most dealers do not even know about this UCONNECT software bug.

This is very frustrating. Has anyone with this issue been able to downgrade to the previous version of the software with success? I don't know what else we can do, this is a real safety issue too since you can't connect to 911 in an emergency. I'd love to see a class action lawsuit but have no idea how many vehicles are involved.

Any ideas Folks?
Thanks
John
Not a bug; you need a new radio. I think they are out of stock so throwing this out there until they can get new radios. Just a guess based on my wife's exact symptoms and radio replacement as only resolution. It took multiple trips to dealer and calls to FCA to get the radio. All good ever since and running newest software.
Reply With Quote
  #3  
Old 01-16-2017, 07:34 AM
New Member
 
Join Date: Apr 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jcsf420 is on a distinguished road
Re: Vehicle Phone Requires Service Software Bug

Quote:
Originally Posted by karirick View Post
Not a bug; you need a new radio. I think they are out of stock so throwing this out there until they can get new radios. Just a guess based on my wife's exact symptoms and radio replacement as only resolution. It took multiple trips to dealer and calls to FCA to get the radio. All good ever since and running newest software.
I'd like to think you are correct but you might have just got lucky with the replacement radio. UCONNECT will replace my radio if I want but they can't guarantee that the software bug won't effect the new unit too. They don't know, or won't tell me, why this "bug" only effects certain units. I may just have to try the new unit but really don't want the hassle of dealing with dealer Service. They just don't know about this issue and I know more than they do about it, and they look at you like you're nuts trying to explain to them what is going on. Thanks for the reply.

I'd like to hear if anyone else is in my situation waiting for a fix from UCONNECT.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:50 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.