Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-19-2011, 07:55 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Iowa
Posts: 136
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 1783
CIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond repute
Weird EVIC response

Two or three times now I have had my EVIC display go from fuel economy straight to tire pressure when I press the back arrow, instead of going back to the main menu. Has anyone experienced something similar to this while navigating the EVIC?
__________________

__________________
Reply With Quote
  #2  
Old 05-19-2011, 10:07 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Pottstown, PA
Posts: 226
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1640
Nouveau Redneck is on a distinguished road
Re: Weird EVIC response

I have not had that happen, but my first thought on reading your post is "Were any of the tire pressures low?". Perhaps it is programmed to take you to the tire pressure display if the pressure in one of the tires is below some particular threshold.
__________________

__________________
Sean in PA
2011 Jeep Grand Cherokee Overland
Stone White
5.7 Liter Hemi V-8
Adaptive Cruise & Blind Spot Monitoring
Reply With Quote
  #3  
Old 05-19-2011, 10:28 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Iowa
Posts: 136
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 1783
CIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond repute
Re: Weird EVIC response

I thought the same thing when it did that but all four tires were in the low 40 psi range.
__________________
Reply With Quote
  #4  
Old 05-19-2011, 11:58 AM
Member
 
Join Date: Feb 2011
Location: San Jose, CA
Posts: 228
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1646
JayB is on a distinguished road
Re: Weird EVIC response

low 40 psi range?
uhhh maybe you are running too MUCH pressure?

I know when I had wheels on my Jeep without TPMS my EVIC behaved in the manor you are describing. I think it is built into the system to show you the tire pressure if they are out of range. Have you got a chime or tire pressure warning light? I don't think it would go off it set too high? but not sure.
__________________
Reply With Quote
  #5  
Old 05-19-2011, 01:14 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Iowa
Posts: 136
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 1783
CIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond reputeCIEGOS has a reputation beyond repute
Re: Weird EVIC response

I have not received any chime or warning for the tire pressure. I am running with the 20" frontera's. Is seeing 40-41psi on a warmer day (80F) on the interstate too high?
__________________
Reply With Quote
  #6  
Old 05-23-2011, 10:01 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Mar 2011
Location: Madison, WI
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1485
Willir2 is on a distinguished road
Garage
Re: Weird EVIC response

Most recommend to have your tire PSI at 33 when cold. At most when driving 40-45. But some tires handle more. I would read on the tire wall what is recommended.
__________________
Reply With Quote
  #7  
Old 05-23-2011, 10:07 PM
bselman's Avatar
Premium Member
My Jeep: 2012 5.7L WK2
 
Join Date: Dec 2010
Location: New York
Posts: 64
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1533
bselman is on a distinguished road
Re: Weird EVIC response

20" fortera's recommend 36 COLD. I get into 40/41 (and an extreme 42) on warm days, 80 mph, long stretch's of the highways....
__________________

__________________
GONE - 2011 Jeep Grand Cherokee Limited | Mineral Grey/Black | 5.7L HEMI | 20" wheels and tires | 730N RHR | Sirius | 30% tint front windows
NOW - 2012 Jeep Grand Cherokee Overland | Mineral Grey/Saddle | 5.7L HEMI | 20" wheels and tires | 730N RHR | Sirius

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First WK used for emergency response????? Crestwood1001 Interior/Exterior/Visual 48 01-21-2012 01:32 PM
5.7 hemi throttle response spiros Trouble Shooting/Problems/Service 7 05-14-2011 10:10 PM
Throttle Response LiquidOxygen Engine Performance/Intakes/Exhausts 1 04-18-2011 11:06 AM
Throttle response. ILSMKU Grand Cherokee - WK2 - 5 09-29-2010 07:14 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.