Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-10-2011, 02:38 AM
New Member
My Jeep: 2011 3.6L WK2
 
Join Date: Nov 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Emilyrg is on a distinguished road
Unhappy Where to begin...

I purchased my 2011 jgc overland summit three months ago brand new with promises of essentially everything a car buyer could ask for. About a day after my purchase things took a turn. I have numerous problems that I can't find much on on these forums.

The radio is being replaced after countless freezes, auto dim problems, uconnect problems and the entire text messaging feature I didn't even know about until an hour ago.

I'm also experiencing problems with the tire pressure sensors. The first started when all four tires were the same psi and one would blink low. Then it went to three of the four, all the same psi, constantly on.

The oil change signal won't reset even by the dealer.

The recirculation button does nothing. You press it, the light blinks, then it goes off and the wretched smell remains the same.

The last three the dealer said wasn't the radio until I returned to the dealership. He brushed me aside with a different tune saying, every problem I've ever had was the radio, basically they really didn't look at it and to shut up because I'm getting a new radio. I'm ready to abandon ship for I feel the problems growing is inevitable.

I'm wondering if anyone else has experienced these problems. I know the uconnect has been touchy with some other owners.
__________________

__________________
Reply With Quote
  #2  
Old 11-10-2011, 03:29 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652899
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Where to begin...

The recirc function is likely simply due to the mode selection... try different mode settings then hitting the recirc button before you actually decide there is a problem. I might be wrong but I am pretty sure this is how its designed.

whenever I do an oil change on any newer vehicle that requires the key on, accelerator pedal to the floor, then completely off x 3 then key off (all within 10 seconds) I typically do it like 4 or 5 times. I think the 08-10 wk is the only chrysler vehicle I have seen that actually says "reset service minder" or similar in the evic when you successfully do it, all others you just have to hope you got it then start it up and see. I dont know why but the rams can be really difficult some times, it can take 5-8 tries sometimes to get a diesel minder to reset.

make sure the tire pressures are at spec listed in the door jamb... not according to the chincy gauge on the gas station air compressor either. I have an 11 grand at work right now the owner stated "filled tires, lamp is still on" and I went and ACTUALLY filled them to spec and magically the lamp went off. With the cold weather coming in tire pressure lamps are an epidemic, the cold lowers the pressure in the tires that were doing just fine during summer.

Radios fail, just like everything else... if you spent 120k on a loaded bmw 7 series there may come a day when it needs a new radio. Electronics are made here on earth where despite mans best efforts NOTHING is perfect. I am sorry for your frusterations, but its just a radio, it will get replaced and you will be up and running again in no time.

Just take a breath, its not the end of the world... reading your post there was nothing you mentioned that had me cringe. You will come through the other side satisfied, I promise (no comment if my fingers are crossed or not).
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 11-10-2011, 09:49 AM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3233
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Where to begin...

Most 730N media center problems derive from the current firmware. Supposedly a new version is being developed, if our dealer is to be believed, so perhaps that will resolve some of your problems.

On the other hand, there reportedly is a new TSB in the works to deal with rare untoward interaction among several functions, including Quadra-Lift, wipers and such. Again, waiting for upcoming TSBs might be the best course of action, even if it taxes your patience.

You might also try another dealer if you feel yours hasn't been fully helpful. Jeep dealers as a group are no prize, but here and there you'll find some pretty good ones.
__________________
2012 Cherry Overland V6, ADG
Reply With Quote
  #4  
Old 11-10-2011, 10:20 AM
New Member
My Jeep: 2011 3.6L WK2
 
Join Date: Nov 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Emilyrg is on a distinguished road
Re: Where to begin...

I appreciate the responses. However I think i should be more clear.

The tires are at 33 psi and when this first happened I attempted to add equal pressure to all of them. All four tires are at the same psi ranging between 35 and 30 psi but three of them are saying the psi is low, and it doesn't go off, it's been on for a week.

The radio had full functions that my model didnt have, text messaging, Sirius traffic link wouldn't work, and anytime I would connect my phone or iPod I would have to switch the audio source five to six times in order to get it to play. not to mention countless road trips with no hope of getting my radio to unfreeze, even after restarting the car.

The oil reset light... I know how to reset it. Initially the guy at the dealer sat with me and apologized that they forgot to turn it off and taught me how. Ive done this several times with no success.

The air recirc is potentially something I looked over and I will check the mode its on.

I would really like to know if someone has experienced the same problems or if you think the oil change signal, the tire pressure and potentiallythe recirculation button problem could be fixed by replacing ther adio.
__________________
Reply With Quote
  #5  
Old 11-10-2011, 01:34 PM
SW03ES's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Gaithersburg, MD
Posts: 1,724
Thanks: 14
Thanked 39 Times in 34 Posts
Rep Power: 1303238
SW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond reputeSW03ES has a reputation beyond repute
Re: Where to begin...

Quote:
Originally Posted by Emilyrg View Post
The tires are at 33 psi and when this first happened I attempted to add equal pressure to all of them. All four tires are at the same psi ranging between 35 and 30 psi but three of them are saying the psi is low, and it doesn't go off, it's been on for a week.
This may just be me being a Jeep layperson...

But on my Lexus you can set where you want the tire pressures to be, so if the tires are aired to 33...the light may come on...if the threshold is set to 35...say. There is a reset button under the dash that resets the monitors to I think 5PSI below whatever they are currently aired to.

Does the Jeep perhaps have the same functionality and yours is saying that 33PSI is below whatever threshold its set to?

Quote:
The radio had full functions that my model didnt have, text messaging, Sirius traffic link wouldn't work, and anytime I would connect my phone or iPod I would have to switch the audio source five to six times in order to get it to play. not to mention countless road trips with no hope of getting my radio to unfreeze, even after restarting the car.
Sounds like a firmware problem, I'm sure replacing the head unit will solve your problem.

Quote:
The oil reset light... I know how to reset it. Initially the guy at the dealer sat with me and apologized that they forgot to turn it off and taught me how. Ive done this several times with no success.
My guess is both of you are doing something wrong. I'd take it to another dealer.
__________________
~Steve~
2014 Jeep Grand Cherokee Overland V6 4X4. Maximum Steel w/ Vesuvio Jeep Brown/Indigo Blue. Advanced Tech Pkg.
2013 Lexus GS350 AWD, Liquid Platinum w/ Flaxen. Luxury & Cold Weather Pkg
Previous Jeep: 2011 Grand Cherokee Laredo X w/Nav, QT1 & Trailer Tow
Reply With Quote
  #6  
Old 11-10-2011, 06:06 PM
BigTicket13's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Oct 2011
Location: Macomb, MI
Posts: 437
Thanks: 0
Thanked 13 Times in 10 Posts
Rep Power: 9399
BigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond repute
Re: Where to begin...

Lemon Law you keep having this many problems with a new vehicle.
__________________
Reply With Quote
  #7  
Old 11-10-2011, 06:24 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: May 2011
Location: Colorado Springs, CO
Posts: 120
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1686
HammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond reputeHammFist has a reputation beyond repute
Re: Where to begin...

Scarily enough, my reading here leads me to believe it really could be the radio causing all of those problems.

How? In these trucks the radio is part of the CAN bus that all the vehicle sensors use to talk to the main computer that runs everything. With the incredible number of Overlands that are reporting electronic glitches, it is starting to look to me like the 730 radio may be the culprit.

I simply haven't seen these same reports from Laredo owners like me with the other radio (430N in my case) -- and I haven't had any problems at all.
__________________
Reply With Quote
  #8  
Old 11-10-2011, 06:35 PM
77Cherokee's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jun 2011
Location: NY State
Posts: 652
Thanks: 0
Thanked 21 Times in 19 Posts
Rep Power: 2071
77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute
Re: Where to begin...

The sticker on the door frame calls for 36 lbs. in each tire. Try raising the pressure to at least that much. It may still take a couple of days for the warning to disappear, according to the book.

I also think it is possible that the oil change reset is not being done correctly. Double-check the steps.

There are radio issues with quite a few 2011's. A new one may indeed be required to resolve your problems with it.
__________________
2012 Overland, Deep Cherry w/black/saddle interior, V6, ACC pkg.

My 77 Cherokee- Long gone but not forgotten
___
____________________________________
Reply With Quote
  #9  
Old 11-10-2011, 06:51 PM
JETLIFE's Avatar
This Ain't No Mixtape
My Jeep: 2005 5.7L WK
 
Join Date: May 2009
Location: Barrie, Ontario, Canada
Posts: 1,546
Thanks: 41
Thanked 13 Times in 11 Posts
Rep Power: 12242
JETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond repute
Re: Where to begin...

33 PSI seems to low to me also, I myself don't run stock wheels in summer or winter so i'm not sure what the factory specs are, But I run 40 PSI in my 22's and 45 PSI in my 17's with 32's ( both state 50 PSI cold )

I wouldn't be surprised if it was the radio causing the electrical problems like people have said, It does run on a CANBUS system along with the rest of the electronics in your Jeep.

Try to stay positive, You have warranty so it will all get worked out! Good luck!
__________________
2005 Jeep Grand Cherokee Limited 5.7L
PEL / Khaki-Black

22" x 9.5" Diablo G-Force Paint Matched Inserts / 17" x 9" Eagle 63 / Toyo Proxes 265/40/22 / BFG M/T 255/75/17 / SRT8 Rear Bumper / SRT8 Grille / SRT8 Black Leather Seats F+R / Magnaflow / 5" Tips / Mopar Lip / Mopar Running Boards / Weathertechs / Commander Shift Knob / K&N / Alpine Type R / Alpine PDX 4.100 / Debadge / Bilsteins / H&R 1.5" Down / Daystar 2" Up / Diablo Predator 93 PCM Tune - Performance TCM Tune / Morimoto Mini H1 Retrofit 6000k
Reply With Quote
  #10  
Old 11-18-2011, 12:17 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2011
Location: Phoenix, az
Posts: 181
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1295
Kevlars has a reputation beyond reputeKevlars has a reputation beyond repute
Re: Where to begin...

For your tire issue that does not sound normal. I air down when I go off roading and I get the alert...as soon as I air up it's gone and I am at 34 psi. You may want to check this thread.. TPMS Sensor Issue?
__________________
Jeep Grand Cherokee 2011
Overland Summit W/ORII
Hemi 5.7L
285 60 R18 Yokohama Geolander A/T -S
Mopar Rock Rails

[SIGPIC][/SIGPIC]
Reply With Quote
  #11  
Old 11-19-2011, 12:25 AM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3233
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Where to begin...

Quote:
Originally Posted by HammFist View Post
Scarily enough, my reading here leads me to believe it really could be the radio causing all of those problems.

How? In these trucks the radio is part of the CAN bus that all the vehicle sensors use to talk to the main computer that runs everything. With the incredible number of Overlands that are reporting electronic glitches, it is starting to look to me like the 730 radio may be the culprit.

I simply haven't seen these same reports from Laredo owners like me with the other radio (430N in my case) -- and I haven't had any problems at all.
Fully agree that dysfunctional stuff is happening that is more macro than any individual component, such as the media center. IMO, the sum of the parts is less than the whole.

Slightly OT, but I'm resetting the sat presets around twice a week, and nav settings almost as often. I've finally printed up an idiot list of settings so I can reenter them quickly, like Fred Flintstone.
__________________
2012 Cherry Overland V6, ADG
Reply With Quote
  #12  
Old 11-19-2011, 01:12 AM
Premium Member
 
Join Date: Nov 2010
Posts: 1,168
Thanks: 1
Thanked 21 Times in 21 Posts
Rep Power: 3029
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Where to begin...

The tire pressure for the 20" wheels is 36 psi. Once the low pressure warning comes on it will not reset unless you get them at or above 36.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Let the games begin, almost. dogface_313 Members Rides-Showoff 20 06-16-2011 08:46 PM
caveat emptor - let the flaming begin kgrencer Trouble Shooting/Problems/Service 81 02-10-2011 10:00 AM
Let the transformation begin... DARKGC Members Rides 17 07-20-2010 04:01 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community