Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-22-2013, 09:03 AM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
WK2 push to start/ keyless entry not working

Since the first day that I got my 2011 grand cherokee limited I have had to use the key to unlock the doors and manually start it by inserting the key where the push to start button goes. If the vehicle is locked and I grab the handle which should unlock the door nothing happens. If I put the push to start button back in and press brakes to n hold the button I get a "damaged key" message. Some details that might help is that the vehicle is from a salvage auction so high chances of battery disconnected for long period of time, they key does not show any signs of damage. Thanks ahead to anyone who can assist me in figuring this out
__________________

__________________
Reply With Quote
  #2  
Old 10-22-2013, 09:56 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,797
Thanks: 292
Thanked 288 Times in 255 Posts
Rep Power: 1801209
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: WK2 push to start/ keyless entry not working

Sounds like the fob might not be linked to the vehicle. It might be the one that came with the car, but who knows what was changed under the hood/dash?


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 10-22-2013, 10:05 AM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
Re: WK2 push to start/ keyless entry not working

Quote:
Originally Posted by bill_de View Post
Sounds like the fob might not be linked to the vehicle. It might be the one that came with the car, but who knows what was changed under the hood/dash?


---
The hood/dash were untouched. There was a rear impact on the vehicle. Maybe from a prolonged time of dead battery the key unsynced. Is there a pair sequence available to try myself or is this a take it to the stealership type of nonsense?
__________________
Reply With Quote
  #4  
Old 10-22-2013, 12:49 PM
plynn7's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2010
Location: Delaware County,PA
Posts: 353
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1871
plynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond repute
Re: WK2 push to start/ keyless entry not working

Does the key fob work at all, can you use the buttons on the fob to unlock the door? If not, maybe the battery in the fob is bad or the fob itself is bad.
__________________
2014 Deep Cherry Red Overland V6 Tech Package
Previous Jeeps:
11 GC Overland V6
08 GC Limited Hemi
04 GC Larado V6
Reply With Quote
  #5  
Old 10-22-2013, 01:44 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: AZ
Posts: 619
Thanks: 1
Thanked 7 Times in 5 Posts
Rep Power: 1762
eibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond repute
Re: WK2 push to start/ keyless entry not working

Try this thread and see if you can find the antenna connection...

My push to start button no longer starts my JGC after picking it up from the sound sh

They must not have re-attached it after the rear impact repair.
__________________
Reply With Quote
  #6  
Old 10-22-2013, 02:56 PM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
Re: WK2 push to start/ keyless entry not working

The fob works as it should , locks unlocks. Remote starts the vehicle. And ok will try it after work
__________________
Reply With Quote
  #7  
Old 10-22-2013, 04:57 PM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
Re: WK2 push to start/ keyless entry not working

Quote:
Originally Posted by eibyer View Post
Try this thread and see if you can find the antenna connection...

My push to start button no longer starts my JGC after picking it up from the sound sh

They must not have re-attached it after the rear impact repair.

I feel like this can most certainly be it. Will check tonight
__________________
Reply With Quote
  #8  
Old 10-24-2013, 04:42 PM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
Re: WK2 push to start/ keyless entry not working

Well the rear sensor is most definitely the culprit here I found the blue wire by itself not plugged into anything but the kicker is the sensor is MIA. Nowhere in the radius of the wire being able to reach are there any sensors. Nothing near the striker. Should it be where these 2 black squares are? Can anyone take a picture of theirs for me? I cannot find it in any diagrams on parts websites

__________________
Reply With Quote
  #9  
Old 10-24-2013, 04:57 PM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 615
Thanks: 1
Thanked 51 Times in 48 Posts
Rep Power: 34290
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: WK2 push to start/ keyless entry not working

Your symptoms relate exactly to an issue I had with ours when installing extra wiring to the tow bar.
I had removed the plastic trim and attempted to start the car, with the result damaged key message. Once i reinstalled the wiring the car started keyless again no worries.
This from memory as it was nearly 18 months ago now......
The antenna is clipped to the underside of the plastic surround across the tailgate, if you look on the underside there will be a receptacle for it. To remove the plastic trim you have to disconnect the antenna wiring. As I recall the antenna was about 1/2 inch square and about 3 inches long, black, with wires to a plug in connector.
If you are lucky, the antenna is still there and just needs to be reconnected. If not you'll need a tailgate TIPM antenna.
The vehicle did store a code relating to the fault as my dealer questioned me whether I had had a key issue at my next visit.
Hope it can easily be sorted.
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #10  
Old 10-24-2013, 05:10 PM
Premium Member
 
Join Date: Sep 2013
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 346
eugene3524 is on a distinguished road
Re: WK2 push to start/ keyless entry not working

Quote:
Originally Posted by John47 View Post
Your symptoms relate exactly to an issue I had with ours when installing extra wiring to the tow bar.
I had removed the plastic trim and attempted to start the car, with the result damaged key message. Once i reinstalled the wiring the car started keyless again no worries.
This from memory as it was nearly 18 months ago now......
The antenna is clipped to the underside of the plastic surround across the tailgate, if you look on the underside there will be a receptacle for it. To remove the plastic trim you have to disconnect the antenna wiring. As I recall the antenna was about 1/2 inch square and about 3 inches long, black, with wires to a plug in connector.
If you are lucky, the antenna is still there and just needs to be reconnected. If not you'll need a tailgate TIPM antenna.
The vehicle did store a code relating to the fault as my dealer questioned me whether I had had a key issue at my next visit.
Hope it can easily be sorted.
This is starting to make more sense now. The jeep arrived to me from auction with the rear panel that goes across the tailgate already removed. Which is where the sensor must have been attached to. So now I need the rear cover along with the sensor
__________________
Reply With Quote
  #11  
Old 10-25-2013, 10:05 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: AZ
Posts: 619
Thanks: 1
Thanked 7 Times in 5 Posts
Rep Power: 1762
eibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond repute
Re: WK2 push to start/ keyless entry not working

I also tried looking in the parts diagram but no luck, that thing is a maze.


Edit: I wonder if one of this is it?? http://tinyurl.com/o9nqo7j
__________________

__________________
Reply With Quote
Reply

Tags
wk2

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyless push button start? copley2596 Grand Cherokee - WK 23 06-08-2012 12:41 PM
Push to start(keyless n go) jeep4ss Trouble Shooting/Problems/Service 14 04-26-2012 02:06 PM
Keyless Entry & Push Button Start rsks9294 Grand Cherokee - WK2 - 10 09-20-2011 03:21 PM
remote keyless entry have stopped working ithinkfit914 Troubleshooting/Problems 9 01-09-2011 06:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community