Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-26-2014, 07:04 AM
pensfan414's Avatar
Premium Member
 
Join Date: Nov 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 456
pensfan414 is on a distinguished road
Yet another problem......

Started up the 14 GC this morning only to find that all my interior background lighting as well as my headlights were non-functional. I didn't have time to look into it further. My only thought is a fuse blown but anyone else have an idea of what this could be or experienced a similar issue? Thanks.
__________________

__________________
2000 Cherokee
2014 GC Overland
Reply With Quote
  #2  
Old 03-27-2014, 11:31 AM
Member
 
Join Date: Mar 2013
Posts: 238
Thanks: 0
Thanked 8 Times in 5 Posts
Rep Power: 926
Briant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond repute
Re: Yet another problem......

With the car off check the fuses, it could possibly be a fuse that needs pushed back in, a few owners have found there fuses have unseated themselves or were never seated fully.
__________________

__________________
Reply With Quote
  #3  
Old 03-28-2014, 08:42 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1244
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Yet another problem......

first.. try again before checking fuse.About 10 times now I have had to wait for them. Open the door.. dark.. get in.. dark.. close door.. dark.................... ding there they go.
Why on earth they are computerized I will never understand but... they are.

yet another random system screw up. I swear the person who designed this thing was a few fries short of a happy meal.
__________________
Reply With Quote
  #4  
Old 03-28-2014, 09:53 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Location: NJ
Posts: 389
Thanks: 1
Thanked 5 Times in 5 Posts
Rep Power: 817
Evolv0 is just really nice
Re: Yet another problem......

Quote:
Originally Posted by StaticFX View Post
yet another random system screw up. I swear the person who designed this thing was a few fries short of a happy meal.
LOL ..

But yes I would also double check every single fuse in and out of the car, then try again.
__________________
Engine- AFE Intake, Moe's 87mm TB, BT CatchCan.
Exhaust- Magnaflow 11385 Xpipe in the center and 2x Magnaflow 14814's in the rear.
Wheels- 20x9 SRT8 Reps, Hankook Ventus ST RH06.
SRT8 Brembo BBK + GoodRidge SS Brake Lines.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Grand Cherokee Tranny Issue 02GrandHO Troubleshooting/Problems 34 03-06-2013 03:15 PM
Yet another tire question tmclaug1 Suspension/Driveline/Brakes/Wheels/Tires 5 10-02-2011 08:27 PM
Yet Another HID Problem tman1423 Grand Cherokee - WK 15 01-23-2011 05:49 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community