'14 JGC bogging & engine light CAI - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Engine Performance/Intakes/Exhausts

Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-08-2015, 09:37 AM
calicoss's Avatar
Member
 
Join Date: Jul 2014
Posts: 9
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1078
calicoss is on a distinguished road
'14 JGC bogging & engine light CAI

Ok,

Got 21K on the odometer in the 3.6L JGC. Installed the K&N CAI at around 4K mile mark. Was smooth sailing up until engine light starting flashing at highway speeds at WOT (no other symptoms). Took it into service, they diagnosed it as misfire and replaced the head.

Driving the jeep without problems for a little and then highway driving got solid engine light at highway speed at WOT with now engine shutter. Tried to simulate the problem again with a service tech and of course nothing.

Now, when I take off in first gear the car is bogging/missing with no engine light. Am I wrong in thinking the K&N CAI has any involvement in this problem? Maybe MAF is dirty from the oil? I'll plug my scan reader into the car after work today. Then look at MAF and clean if necessary. Then it goes back to jeep on Monday for them to re-diagnose.

I'm thinking of just removing the K&N and seeing if it may be involved in any way. Have K&N on a '96 Impala SS & an IS250. The impala had throttle issues relating to dirty MAF but always got it up and working again. Just thinking screw the K&N on the jeep and go back to stock. Thoughts...

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-08-2015, 07:54 PM
JTS97Z28's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Plainfield, IL
Posts: 3,877
Thanks: 90
Thanked 629 Times in 459 Posts
Rep Power: 28889
JTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond repute
Re: '14 JGC bogging & engine light CAI

Why wouldn't you have put the stock air box back in during all these issues and dealer visits? That would have been the first thing I did just to eliminate something and the fact that you know the dealership is gonna raise hell because of it.
I say go back to stock regardless. It's not like it does anything anyway except make more noise.
__________________
2015 Jeep Grand Cherokee High Altitude, Bright White, V6, HK audio
Reply With Quote
  #3  
Old 10-08-2015, 08:38 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Sep 2015
Location: Charlotte NC
Posts: 55
Thanks: 9
Thanked 4 Times in 4 Posts
Rep Power: 693
NC WK2 is on a distinguished road
Re: '14 JGC bogging & engine light CAI

I had similar problems in a Mercedes with a K&N, the MAF sensor failed due to oil contamination. I removed the K&N and never had another problem. Haven't ever bought a K&N after that.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-09-2015, 06:50 AM
Lightninrod's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jan 2015
Location: Warner Robins Ga
Posts: 508
Thanks: 658
Thanked 58 Times in 48 Posts
Rep Power: 1646
Lightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond reputeLightninrod has a reputation beyond repute
Re: '14 JGC bogging & engine light CAI

I've used K&N filers in a lot of my vehicles over the years. Never had a problem with them. I decided to go 'dry' with my JGC V8. Placed a dry AFE filter in the stock filter box.

Dan
__________________
2013 Jeep Grand Cherokee Overland
5.7L V8, 2WD, Quadratec mats, Sprint Booster, Northstar AGM Battery, Volant CAI, Blastinbob's axleback exhaust, X-pipe, Shell 93 octane w/Nitrogen, Pennzoil Platinum 5W20, Uniden CB, and K40 magnet antenna
Build date: 9/4/12 Bought 01/27/15 with 47,200 miles
Reply With Quote
Reply

Tags
cai

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bogging while accelerating RandomActs13x Troubleshooting/Problems 4 09-16-2015 10:29 AM
Mopar cai vs k&n cai dom1220 Engine Performance/Intakes/Exhausts 2 10-21-2014 09:42 PM
Check engine light aftef CAI Tbirch Performance Modifications 2 08-17-2013 08:47 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:37 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.