Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Engine Performance/Intakes/Exhausts

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-25-2013, 10:47 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
Issues with your HEMI???

I was wondering if any one else has had any type of issues with their HEMI in their WK2. I have already had to replace my water pump and (the dealership told me) i had a collapsed lifter on one of my valves.

If you have had any issues please share.
__________________

__________________
Reply With Quote
  #2  
Old 04-25-2013, 12:26 PM
PB617's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Location: Boston, MA
Posts: 162
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 820
PB617 is on a distinguished road
Re: Issues with your HEMI???

What year is your WK2? how many miles?
__________________

__________________
2014 Jeep Grand Cherokee Limited | Granite | 4x4 | HEMI | LuxII | 20" Wheels | 5000k LED Fogs | 20% Tint

Reply With Quote
  #3  
Old 04-26-2013, 05:32 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
Re: Issues with your HEMI???

2011 GC...


It had between 25K and 35K on it when these issues popped up...

I am about to hit 48K here by the next tank of gas and have not had any other issues so far.
__________________
Reply With Quote
  #4  
Old 04-26-2013, 10:22 AM
The Evil Twin's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2013
Location: Gainesville, VA
Posts: 357
Thanks: 2
Thanked 13 Times in 11 Posts
Rep Power: 361168
The Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond reputeThe Evil Twin has a reputation beyond repute
Garage
Re: Issues with your HEMI???

Had a faulty fuel injector plug on cyl #2. Thats all the history shows.
__________________
#132-CCS Racing

2014 Sponsors: Amsoil, www.DC-MOTO.net, Manassas Honda Kawasaki Suzuki, www.MARRC.org
Amsoil 5w-20 synthetic meets Chrysler MS-6395 for my Jeep!
Reply With Quote
  #5  
Old 05-13-2013, 08:48 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
Re: Issues with your HEMI???

I was getting on the E-way this past weekend and my jeep stalled on me!!! I just rolled 48K mi.

I was talking with my brother in law about this. We have had high 60 low 70 degree weather for the past week or so and last couple days the weather had dropped down into the 40's. He thinks that the engine may have gotten a blast of cold air into the engine and the density of the cold air hit before the computer could make adjustments for Fuel to Air table thus stalling the motor. Is this a probable cause??? No engine codes were thrown either. (Had a full tank of gas too)
__________________
Reply With Quote
  #6  
Old 05-13-2013, 02:53 PM
webspoke's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Dec 2010
Location: Dallas
Posts: 179
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1594
webspoke is on a distinguished road
Re: Issues with your HEMI???

I had 48k miles on my 2011 Hemi with no engine issues, it just ran, in temps from the teens to well over 100. I never even changed plugs at 36k which was in the maintenance schedule. I think your issues are unusual. Current has 15k miles, no engine issues either.
__________________
2014 Ram 2500 4x4 Laramie - more torque to pull the toys
2013 Limited Hemi 4x4 white - Vision wheels with 285/60/18 Terra Grapplers - traded
2011 Overland Hemi 4x4 black/black - retired with QL problems at 46000 miles
Reply With Quote
  #7  
Old 05-13-2013, 02:59 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,303
Thanks: 329
Thanked 358 Times in 312 Posts
Rep Power: 1801820
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Issues with your HEMI???

Quote:
Originally Posted by MICHIWK2 View Post
I was getting on the E-way this past weekend and my jeep stalled on me!!! I just rolled 48K mi.

I was talking with my brother in law about this. We have had high 60 low 70 degree weather for the past week or so and last couple days the weather had dropped down into the 40's. He thinks that the engine may have gotten a blast of cold air into the engine and the density of the cold air hit before the computer could make adjustments for Fuel to Air table thus stalling the motor. Is this a probable cause??? No engine codes were thrown either. (Had a full tank of gas too)
No. If that were the case cars would be stalling all over the place.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #8  
Old 05-13-2013, 03:33 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
This is true... Just a blip in the computer?
__________________
Reply With Quote
  #9  
Old 05-15-2013, 10:21 AM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,602
Thanks: 28
Thanked 27 Times in 27 Posts
Rep Power: 102340
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: Issues with your HEMI???

I am at about 42K milage and I have noticed the last few thousand miles that my Hemi has gotten much more loud just before the transition from 4-8 cylinders(don't know the technical term) . It is really starting to get annoying.
__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #10  
Old 05-15-2013, 10:29 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
Re: Issues with your HEMI???

When it switches to Economy mode???I can not even tell a difference when it switches to 4 cyls. (based on sound) Where is your sound coming from? the engine? Trans?
__________________
Reply With Quote
  #11  
Old 05-15-2013, 10:30 AM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,602
Thanks: 28
Thanked 27 Times in 27 Posts
Rep Power: 102340
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: Issues with your HEMI???

When it switches from ECO to 8Cyl(hitting a slight incline on the freeway for example) I could never tell the difference for the first 30K miles either.
__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #12  
Old 05-15-2013, 10:58 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2013
Location: United States
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 635
MICHIWK2 is on a distinguished road
Garage
You have the srt8? It could just be that motor breaking in ;-)
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with my fathers 05 WK Hemi RYANSWJ Troubleshooting/Problems 2 04-12-2012 03:14 PM
Hemi issues, not running right help ! dssilvestri Troubleshooting/Problems 3 01-24-2012 11:36 PM
Hemi idle issues noquarter Grand Cherokee - WK 10 03-20-2011 11:22 AM
New issues... Hemi problems ech0sh4y Grand Cherokee - WK 3 03-15-2011 01:54 PM
2005 HEMI MDS Issues livefortheday2308 Grand Cherokee - WK 5 04-10-2010 07:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community