Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Suspension/Driveline/Brakes/Wheels/Tires

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-22-2011, 11:17 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1927
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
4WD System works again!

We took a short trip to the desert today to test the 4WD system after the Dealer had a go at fixing it. It works!!! No problems, so I am happy again.
Had it in High range Sand mode most of the time, but I did try low range and I think Marlin is correct; it works well in the sand. As long as you go easy on the throttle.
We nearly got stuck a couple of times, but the Jeep made it out without me having to do any digging.
Tire pressure was 17psi and also seems about right. I forgot to remove the front air dam, but the Jeep got rid of it all by itself as I had to get a little aggressive getting out of a hole.
Here are some pics. Most are just of the Jeep, but there are a couple of the other guy’s toys also. The last one is the Dubai skyline on the return drive back to the city.
Attached Images
File Type: jpg 22-01-2011 19-50-32.jpg (115.3 KB, 207 views)
File Type: jpg 22-01-2011 19-51-00.jpg (72.1 KB, 180 views)
File Type: jpg 22-01-2011 19-51-54.jpg (113.7 KB, 196 views)
File Type: jpg 22-01-2011 19-52-21.jpg (103.3 KB, 191 views)
File Type: jpg 22-01-2011 19-52-52.jpg (86.2 KB, 194 views)
File Type: jpg 22-01-2011 19-54-21.jpg (114.7 KB, 190 views)
File Type: jpg 22-01-2011 19-55-26.jpg (125.5 KB, 1232 views)
File Type: jpg 22-01-2011 19-56-40.jpg (141.2 KB, 180 views)
File Type: jpg 22-01-2011 19-57-26.jpg (129.3 KB, 209 views)
File Type: jpg 22-01-2011 19-58-24.jpg (70.4 KB, 199 views)
__________________

__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #2  
Old 01-22-2011, 11:22 AM
Nbtstatic's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2010
Location: Colorado Springs, CO
Posts: 388
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 14868
Nbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond repute
Re: 4WD System works again!

Man that is great news. Would you mind telling us what the fix was again in this thread?

The photos are amazing, I would love to spend a day out there with you.

NB
__________________

__________________
________________________
2011 Jeep Grand Cherokee
Overland 4x4 V6
Dark Charcoal Pearl
Dark Frost/Light Frost
730n
Photos

Reply With Quote
  #3  
Old 01-22-2011, 11:28 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1927
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
Re: 4WD System works again!

They say they did a software upgrade of the ABS systems that was released on 8th Jan 2011. I suspect it was the ESC sensitivity update that everyone knows about, but not sure.
Whatever they did, it seems to have worked. It did very well, but I would still prefer if I could completely disable the ESP/ESC. (Are you listening Jeep/Chrysler???). Maybe another software update in the future?
__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #4  
Old 01-22-2011, 11:34 AM
Nbtstatic's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2010
Location: Colorado Springs, CO
Posts: 388
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 14868
Nbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond reputeNbtstatic has a reputation beyond repute
Re: 4WD System works again!

That's odd, the one from Jan 8 just says "Some customers may prefer more sensitivity during ESC events. Reprogramming the ESC module will provide more sensitivity".

It's hard to connect the dots on how that wouldve helped your situation. Maybe there were a couple of other ESC bug fixes in there that ended up correcting your problem. Say the ESC system fighting with the 4wd system in sand driving, for example.

Either way, I'm glad they got you rolling!

NB
__________________
________________________
2011 Jeep Grand Cherokee
Overland 4x4 V6
Dark Charcoal Pearl
Dark Frost/Light Frost
730n
Photos

Reply With Quote
  #5  
Old 01-22-2011, 11:35 AM
Knightrider03m's Avatar
Everyday I'm shuffling
My Jeep: 2012 3.0L
 
Join Date: May 2009
Location: In the mud now
Posts: 6,128
Thanks: 13
Thanked 18 Times in 18 Posts
Rep Power: 323378
Knightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond repute
Send a message via AIM to Knightrider03m
Re: 4WD System works again!

I would love to tear up the desert in my KK. Seams like fun
__________________
-Marcus-
2012 Ford Escape XLT 3.0L V6 AWD White Suede
Current mods: 6000K HID low/hi beams; Passport 9500ix; Garmin NUVI50 5% Tint; Tinted Tails; Duel Exhaust; Debadge
Future mods: Lowing kit; Engine Tune; Black wheels; Monotone Paint Job
Reply With Quote
  #6  
Old 01-22-2011, 11:36 AM
MSCA's Avatar
Member
 
Join Date: Jul 2010
Posts: 713
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2256
MSCA is on a distinguished road
Re: 4WD System works again!

Quote:
Originally Posted by Dunecrawler View Post
...I forgot to remove the front air dam, but the Jeep got rid of it all by itself as I had to get a little aggressive getting out of a hole...
Did it get destroyed, or can you put it back on? And if it did get destroyed, did you price a new one?
__________________
Reply With Quote
  #7  
Old 01-22-2011, 12:02 PM
chibianh's Avatar
Premium Member


My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2010
Location: Colorado
Posts: 594
Thanks: 2
Thanked 6 Times in 5 Posts
Rep Power: 96498
chibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond repute
Send a message via AIM to chibianh
Re: 4WD System works again!

glad to hear it's fixed! This picture is badass! Do you have a hi rez one I can have?

__________________
2011 WK2 Overland 5.7 w/ Off-road Adventure II and other stuff
Reply With Quote
  #8  
Old 01-22-2011, 12:11 PM
pattyboy's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: middle village n.y.
Posts: 266
Thanks: 10
Thanked 1 Time in 1 Post
Rep Power: 1759
pattyboy is a glorious beacon of light
Re: 4WD System works again!

awesome...pix of the month next................got my vote...jotm feb.
__________________
Reply With Quote
  #9  
Old 01-22-2011, 12:53 PM
Technosavant's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2010
Location: STL, MO area
Posts: 1,282
Thanks: 0
Thanked 5 Times in 2 Posts
Rep Power: 2889
Technosavant has a reputation beyond reputeTechnosavant has a reputation beyond reputeTechnosavant has a reputation beyond reputeTechnosavant has a reputation beyond repute
Re: 4WD System works again!

Sweet. Nice pics, and I'm happy they came through for you. Have fun out in the sand.
__________________
Reply With Quote
  #10  
Old 01-22-2011, 01:15 PM
2011Laredo's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2011
Location: Bergen County, NJ
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1431
2011Laredo is on a distinguished road
Re: 4WD System works again!

great pics!
__________________
2014 - GC - Limited - Billet Silver
Reply With Quote
  #11  
Old 01-22-2011, 01:33 PM
Premium Member
 
Join Date: Sep 2010
Posts: 342
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1819
GlowingGhoul has much to be proud of
Re: 4WD System works again!

Quote:
Originally Posted by Dunecrawler View Post
They say they did a software upgrade of the ABS systems that was released on 8th Jan 2011. I suspect it was the ESC sensitivity update that everyone knows about, but not sure.
Whatever they did, it seems to have worked. It did very well, but I would still prefer if I could completely disable the ESP/ESC. (Are you listening Jeep/Chrysler???). Maybe another software update in the future?
I have it on good authority that the WK2's electronic control system is about to be thoroughly hacked through an add on controller...
__________________
Reply With Quote
  #12  
Old 01-22-2011, 09:27 PM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1927
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
Re: 4WD System works again!

Quote:
Originally Posted by MSCA View Post
Did it get destroyed, or can you put it back on? And if it did get destroyed, did you price a new one?
Nope. It was fine. I just popped it back after the drive without any problems. Only one of the clips was lost. The air dam directly in front of the passenger side wheel ripped out. It was at 90 degrees to the rest of the air dam! (Sorry I did not get any photos). Like I said no damage whatsoever. It is very flexible and tough. I was surprised as I thought it would be a gonner for sure.
__________________

__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
service 4wd system CatMan879 Troubleshooting/Problems Discussion 33 02-13-2014 06:46 PM
YJ 4WD issue sodeljeepster Wrangler-YJ, TJ & JK 1 10-11-2011 04:03 AM
Service 4WD System, rear wheel binding/brake stuck. RossC Grand Cherokee - WK 8 03-23-2011 04:16 PM
4wd vs 2wd rlflesh Grand Cherokee - WK2 - 6 01-10-2011 07:34 AM
Service 4WD System Message cain45 Grand Cherokee - WK 18 09-13-2010 05:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community