-8 last night, now suspension failure - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Suspension/Driveline/Brakes/Wheels/Tires

Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-18-2016, 09:50 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2015
Posts: 100
Thanks: 28
Thanked 20 Times in 11 Posts
Rep Power: 904
Jeepstare has disabled reputation
-8 last night, now suspension failure

I'm hoping the suspension is just frozen up. I have heated underground parking but last night parked outside, now I have a suspension failure message, it must just be frozen....the ride height looks normal, it didn't drop into aero mode on the highway, as I expected. Has anyone in colder climates experienced the same thing? Jeep is currently warming up underground, hopefully it resumes normal operation. I'm out of warranty so I assume it will be a pricey fix and must been taking to a dealership. Your feedback is welcome and I'll keep you posted....

Also installed KO2 275/55/20 on Friday been working great, no rubbing issues and looks sweet....

Thanks.

JS

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-18-2016, 10:30 AM
JTS97Z28's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Plainfield, IL
Posts: 3,877
Thanks: 90
Thanked 629 Times in 459 Posts
Rep Power: 28894
JTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond repute
Re: -8 last night, now suspension failure

Well first off move to a warmer climate. Don't subject yourself to that kind of ridiculousness ��

My car doesn't sit outside at night, but the last couple days here at work it sat outside for 8 hours in extreme cold and no suspension issues. Temp of about -2 and -20 windchill. Yeah my wife and I are already working on moving. f this.
__________________
2015 Jeep Grand Cherokee High Altitude, Bright White, V6, HK audio
Reply With Quote
  #3  
Old 01-18-2016, 11:11 AM
Member
 
Join Date: Mar 2011
Posts: 15
Thanks: 0
Thanked 7 Times in 3 Posts
Rep Power: 2320
AWD OWNZ U is on a distinguished road
Re: -8 last night, now suspension failure

Mine does the same thing when it's cold. I live in SoCal but last time I went to mountains it started having issues below 20F and stopped working completely below 0F or so. It worked fine once it warmed back up. Obnoxious, I shouldn't have bought one with an air suspension.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-18-2016, 11:25 AM
Jsboening's Avatar
Senior Member
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Nov 2014
Location: Rockford, MI
Posts: 1,166
Thanks: 195
Thanked 288 Times in 221 Posts
Rep Power: 2742
Jsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond reputeJsboening has a reputation beyond repute
Re: -8 last night, now suspension failure

I've heard a few guys on the Ran forum having problems with their air suspensions at low temps, I know they're Ram's, but they use the same system essentially. 5 here this morning and my Ram's suspension is working fine. I'd guess after it warms up it should be fine.


Sent from my iPhone using JeepGarage
Reply With Quote
  #5  
Old 01-18-2016, 03:39 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2015
Posts: 100
Thanks: 28
Thanked 20 Times in 11 Posts
Rep Power: 904
Jeepstare has disabled reputation
Re: -8 last night, now suspension failure

Confirming it's working again, that was scary. Did some research and found a tsb relating to software update for 2014 w air suspension operating in cold Temps. I also unplugged fuse f50 and put them back. I'm sure it was just thawing, that fixed the problem. Seeing how these repairs cost around 3500, I was pretty nervous. I hate having features not work and would have paid for a fix. Appreciate the input.... Might have to look into that tsb 08-082-13
Reply With Quote
  #6  
Old 01-18-2016, 10:20 PM
Premium Member
 
Join Date: Oct 2011
Location: Canada
Posts: 107
Thanks: 31
Thanked 2 Times in 1 Post
Rep Power: 2196
flaverdiere is on a distinguished road
Re: -8 last night, now suspension failure

Had the same problem, they changed the fuse.
Reply With Quote
  #7  
Old 01-19-2016, 02:09 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,125
Thanks: 74
Thanked 298 Times in 262 Posts
Rep Power: 46582
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: -8 last night, now suspension failure

Quote:
Originally Posted by Jeepstare View Post
Confirming it's working again, that was scary. Did some research and found a tsb relating to software update for 2014 w air suspension operating in cold Temps. I also unplugged fuse f50 and put them back. I'm sure it was just thawing, that fixed the problem. Seeing how these repairs cost around 3500, I was pretty nervous. I hate having features not work and would have paid for a fix. Appreciate the input.... Might have to look into that tsb 08-082-13
I had a software update done some time ago.
Since then the only time I've had issues is when the entire undercarriage is covered in heavily frozen ice, it refuses to go to a lower setting.
No issues with just cold [down to a tad below zero], but then I don't try to trigger aero mode until the transmission is a bit warm.
Reply With Quote
Reply

Tags
suspension

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saw this last night. NHWK05 Off Road Modifications 46 09-11-2009 04:10 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:03 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.