Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-01-2013, 01:29 PM
Member
 
Join Date: May 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
mikoz is on a distinguished road
'12 RHR bluetooth and general issues...

Hi,

I have the RHR unit in an Overland and I'm seeing the following issues. I checked the Uconnect site using my VIN and there are no updates for the unit.

Issues:

1. frequent connection failures with iPhone 4 and 4s when using bluetooth audio. "Connection Failed!"

2.for some stupid reason, uconnect connects to the bluetooth phone automatically just fine, but, it won't automatically connect to the bluetooth audio portion. Why is this? Why doesn't it just automatically connect bluetooth audio to the same phone that's connected for bluetooth hands-free? Why does it ask me to select the source. This seems silly.

3. odd things like when I get and accept a call and I am streaming bluetooth audio and then hang up, the radio will blast for about one second until it then re-connects to bluetooth audio. It's like it defaults to a different media source for a second.

4. overall flakiness. One time I locked the car, came back and unlocked it (but did not start it) and the radio turned itself back on.

5. Radio often gets confused about play versus paused versus stopped with BT audio. The display is frequently out of sync with the phone.

6. once in a while the audio speed is wrong, it appears as if uconnect is pressing fast forward. Sometimes it just stutters and breaks up only when it's first connected within the first 30 or so seconds.

None of these issues are specific to just one phone. I've tried 3.

Should I just take it to the dealer? Is it my unit only doing this? Why isn't there an update on the Unconnect site for this unit?
__________________

__________________
Reply With Quote
  #2  
Old 06-03-2013, 07:01 PM
Jim_in_PA's Avatar
Premium Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jul 2012
Location: SE PA (central Bucks County)
Posts: 1,965
Thanks: 292
Thanked 91 Times in 74 Posts
Rep Power: 5022
Jim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond repute
Garage
Re: '12 RHR bluetooth and general issues...

Quote:
Originally Posted by mikoz View Post
1. frequent connection failures with iPhone 4 and 4s when using bluetooth audio. "Connection Failed!"
Be sure you are on the most recent firmware...2.136 is the most current and there is a thread here that tells you how to download and install it. I get these failures much less often now...it happens because the Bluetooth hasn't connected yet before trying to play the media. The latest firmware has faster connection.
Quote:
2.for some stupid reason, uconnect connects to the bluetooth phone automatically just fine, but, it won't automatically connect to the bluetooth audio portion. Why is this? Why doesn't it just automatically connect bluetooth audio to the same phone that's connected for bluetooth hands-free? Why does it ask me to select the source. This seems silly.
This feature is not supported. You must manually engage the bluetooth audio device because there might be multiple devices registered and it can only connect to one at a time. Inconvenient, yes. But nature of the beast.
Quote:
3. odd things like when I get and accept a call and I am streaming bluetooth audio and then hang up, the radio will blast for about one second until it then re-connects to bluetooth audio. It's like it defaults to a different media source for a second.
Same answer as #1....be sure you're on the most current firmware.

Quote:
4. overall flakiness. One time I locked the car, came back and unlocked it (but did not start it) and the radio turned itself back on.
Same answer as #1
Quote:
5. Radio often gets confused about play versus paused versus stopped with BT audio. The display is frequently out of sync with the phone.
I still see this even with 2.136 installed
Quote:
6. once in a while the audio speed is wrong, it appears as if uconnect is pressing fast forward. Sometimes it just stutters and breaks up only when it's first connected within the first 30 or so seconds.
I have not experienced that one...sometimes, when manually connecting to my iPhone, I get sound, then a pause in audio and then sound that stays there. This is less frequent with 2.136, but it happened once today as I was driving to DC.
Quote:
None of these issues are specific to just one phone. I've tried 3.

Should I just take it to the dealer? Is it my unit only doing this? Why isn't there an update on the Unconnect site for this unit?
Your dealer will not have 2.136...they only have 2.126 in their most recent update unless something has changed recently. See SOX thread here for downloading and installing 2.136.
__________________

__________________
2012 Grand Cherokee Overland Summit - Winter Chill with New Saddle interior. 5.7L HEMI V8 - Nitto NT421Q "shoes"



Day-job...Telecom Technical Sales
Avocations...Woodworking, Equestrian, Food
Reply With Quote
  #3  
Old 06-03-2013, 07:12 PM
Member
 
Join Date: May 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
mikoz is on a distinguished road
Re: '12 RHR bluetooth and general issues...

Quote:
Originally Posted by Jim_in_PA View Post
Be sure you are on the most recent firmware...2.136 is the most current and there is a thread here that tells you how to download and install it. I get these failures much less often now...it happens because the Bluetooth hasn't connected yet before trying to play the media. The latest firmware has faster connection.


This feature is not supported. You must manually engage the bluetooth audio device because there might be multiple devices registered and it can only connect to one at a time. Inconvenient, yes. But nature of the beast.


Same answer as #1....be sure you're on the most current firmware.

Same answer as #1

I still see this even with 2.136 installed

I have not experienced that one...sometimes, when manually connecting to my iPhone, I get sound, then a pause in audio and then sound that stays there. This is less frequent with 2.136, but it happened once today as I was driving to DC.


Your dealer will not have 2.136...they only have 2.126 in their most recent update unless something has changed recently. See SOX thread here for downloading and installing 2.136.
Thanks. Ill try 2.136. You mentioned a post describing this, can you point me to the post describing it? Thanks.
__________________
Reply With Quote
  #4  
Old 06-04-2013, 04:34 PM
Member
 
Join Date: May 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
mikoz is on a distinguished road
Re: '12 RHR bluetooth and general issues...

Hi,

Dealer said the radio unit (u-connect) was bad. They are ordering a replacement (I am constantly amazed at how car dealers for american cars never have a single part in stock, every single thing has to be ordered... I don't understand how this is a good system, but, oh well).

I found and downloaded the 2.136 version ISO and burned it.
Once I get the car back, I will install that new rev if there are still some lingering problems. OR, would you always recommend to install it regardless since it improves the usability even with a unit that is deemed to be working ok by Chrysler?
__________________
Reply With Quote
  #5  
Old 06-05-2013, 06:16 PM
Member
 
Join Date: May 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
mikoz is on a distinguished road
Re: '12 RHR bluetooth and general issues...

Got the car back, dealer installed a new unit and 2.137. So it would appear that there *IS* a newer version than the one that's on the SOX site.

So far, so good. Tried a few pairings and a few off/on bluetooth cycles and it's holding up.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth Streaming Issues? LeCheese Audio/Visual/Navigation 6 03-22-2013 01:38 PM
Bluetooth issues NJeepOverland11 Audio/Visual/Navigation 3 03-09-2013 08:37 AM
RHR Bluetooth streaming question. ben824 Audio/Visual/Navigation 2 03-06-2013 02:08 PM
Bluetooth Issues jamesdomagalski Audio/Visual/Navigation 9 11-15-2012 08:28 PM
Bluetooth Phone Compatability with RHR 730N Barb107 Audio/Visual/Navigation 9 04-07-2012 10:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.