2 issues. Not sure if they're connected. - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-21-2014, 08:19 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2014
Location: New Jersey
Posts: 65
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 861
biggee72 is on a distinguished road
2 issues. Not sure if they're connected.

So I just purchased a 2014 Laredo E CPO from a dealer. I know the ultimate answer is go to a dealer and have it looked at. I just started a new job and am traveling and just don't have time for that now. So I'll get into it briefly and hopefully you guys can help.

1. When I program my sirius stations in. The next day they are not there anymore and it defaults to random programmed channels. I've got the small radio, I forget what it's called RA2 I think?

2. I have a fan ticking sound in the dash. It's there whether or not the HVAC system is on or off. When I shut the car off I can hear it slow to a stop so I know it's something spinning. I can't find anyone else w/ this issue.

My thought it that the two issues could be part of a malfunctioning radio. Any help is GREATLY appreciated.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-22-2014, 04:28 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2014
Location: New Jersey
Posts: 65
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 861
biggee72 is on a distinguished road
Re: 2 issues. Not sure if they're connected.

Damn 93 views and not a single idea? This is driving me crazy..
Reply With Quote
  #3  
Old 11-22-2014, 05:06 PM
AAAA's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 3,493
Thanks: 203
Thanked 164 Times in 144 Posts
Rep Power: 1545134
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 2 issues. Not sure if they're connected.

I don't think they are connected. I could guess about #2, but that would not be helpful! Hopefully you are under warranty.
__________________
Overland: Nokian WR G3 SUV tires, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat. Successor to trouble-free 2011 Limited.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #4  
Old 11-22-2014, 05:49 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2014
Location: Gilbert, AZ
Posts: 174
Thanks: 74
Thanked 32 Times in 24 Posts
Rep Power: 4410
JGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond reputeJGCDieselPowered has a reputation beyond repute
Re: 2 issues. Not sure if they're connected.

I might be able to help with #1. The key fob is programmed to the seat setting (1 or 2) and you should try changing your presets, then try saving the seat setting. I figured this out when I used my wife's key ( I am the primary driver) and when I got in, it went to her seat setting and all her radio presets. Once I hit #1 everything went back to normal. Let me know if that works.
Reply With Quote
  #5  
Old 11-22-2014, 06:32 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2014
Location: New Jersey
Posts: 65
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 861
biggee72 is on a distinguished road
Re: 2 issues. Not sure if they're connected.

That's a good call and makes sense but I don't have memory seating. It's power but no memory.
Reply With Quote
  #6  
Old 11-23-2014, 01:55 AM
1stJeepGC's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: NYC Area
Posts: 1,549
Thanks: 222
Thanked 186 Times in 163 Posts
Rep Power: 27219
1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute
Re: 2 issues. Not sure if they're connected.

Quote:
Originally Posted by biggee72 View Post

1. When I program my sirius stations in. The next day they are not there anymore and it defaults to random programmed channels. I've got the small radio, I forget what it's called RA2 I think?


My thought it that the two issues could be part of a malfunctioning radio. Any help is GREATLY appreciated.
Greetings,

Within the same day that you reset the stations, do you shut off the JGC and startup again with the same program stations?

I am not sure where the Sirius Erasable Program tuner memory (EPROM) is located. It could be a software function or an actuarial hardware chip. This is what the problem could be.

As member AAAA indicated, if it is still under warranty bring in. Their were some TSB's for the RA2 radio and you will have check with them if you VIN is in that group.

Best for now.
__________________
Laredo X, Trail Rated, QTii, Sele-Terrian, Quadra Lift, Off-Road Adventure Package ii, Nokian Rotiva AT, Tow, AFE CAI, DiabloSport inTune 1000-DCX, Custom Sound System ( HAT speakers, JLAudio , Pioneer , JBL MS-8 & RF 3.sixty.3 -- see the writeup link below for more details)

http://www.jeepgarage.org/f155/2011-...ver-79121.html
Reply With Quote
  #7  
Old 11-23-2014, 07:54 AM
Traveler0980's Avatar
Premium Member
My Jeep: 2015 3.2L KL
 
Join Date: Jul 2014
Location: Jabez, KY
Posts: 143
Thanks: 16
Thanked 23 Times in 20 Posts
Rep Power: 1064
Traveler0980 is on a distinguished road
Re: 2 issues. Not sure if they're connected.

I had a similar problem with my 2011 GC, had the big radio. It would change the FM channels on me. Took two visits to the. Dealer but they ended up changing the entire radio out. Worker great after that.
__________________
Traveler

2015 Cherokee Limited
Cashmere with Indigo/Brown
V-6 w/ADII
Towing, Luxury & Technology groups
Uconnect 8.4 AN with Sirius and Nav and upgraded speakers.
Reply With Quote
  #8  
Old 11-23-2014, 08:27 AM
MDBones's Avatar
OVERLAND HIGH ALTITUDE
My Jeep: 2016 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 3,592
Thanks: 630
Thanked 613 Times in 503 Posts
Rep Power: 10617
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: 2 issues. Not sure if they're connected.

You could check out this TSB...

http://wk2jeeps.com/tsb/tsb_wk2_0801314b.pdf
__________________
http://www.jeepgarage.org/members/54562-albums357-picture4289.png
Reply With Quote
  #9  
Old 11-26-2014, 08:35 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2014
Location: New Jersey
Posts: 65
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 861
biggee72 is on a distinguished road
Re: 2 issues. Not sure if they're connected.

Quote:
Originally Posted by MDBones View Post
You could check out this TSB...

http://wk2jeeps.com/tsb/tsb_wk2_0801314b.pdf

Awesome, thanks. One issue has been resolved. The clicking noise seems to have been a pine needle. I changed the cabin filter which had a couple in it and the noise went away. I'll try the software update next.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
17" WK rims on 2011 WK2 Laredo - will they they fit? Gerrrr Suspension/Driveline/Brakes/Wheels/Tires 0 09-02-2012 03:32 AM
Broke Something Connected To My Airconditioning Ypahihi Troubleshooting/Problems 21 01-24-2012 10:58 AM
Drod X Not Connected Brewster Audio/Visual/Navigation 6 01-13-2012 07:50 PM
Device control for USB connected Droid X Skier95746 Audio/Visual/Navigation 5 09-15-2011 01:57 PM
Just updated iPhone now won't play when connected RyanN Trouble Shooting/Problems/Service 8 08-04-2011 10:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.