Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-16-2013, 03:44 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10575
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
2011 RHB: black NAV screen?

After working flawlessly for two years, the NAV screen in my 2011 RHB now comes up black (see pic below.) All other screens are normal and the radio works. I pulled the M12 fuse for several minutes to reboot the head unit (and observed that the radio rebooted) but the NAV screen is still black.

Anything else to try before I take it to the dealer?
Attached Images
File Type: jpg NavScreen.jpg (109.5 KB, 14 views)
File Type: jpg VersionScreen.jpg (153.4 KB, 22 views)
__________________

__________________
Reply With Quote
  #2  
Old 11-16-2013, 05:49 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,850
Thanks: 86
Thanked 74 Times in 61 Posts
Rep Power: 570900
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
Re: 2011 RHB: black NAV screen?

remove the radiofuse and then look.

why you have this old Software, why you have never update?
__________________

__________________
All Uconnect Software

www.mydrive.ch

username: mygig@soxag
Password: gasolio

Reply With Quote
  #3  
Old 11-17-2013, 07:00 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10575
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

Quote:
Originally Posted by *sox* View Post
remove the radiofuse and then look.
Yes, I did that. The details are in my post.

Quote:
Originally Posted by *sox* View Post
why you have this old Software, why you have never update?
This is the older RHB from the 2011 model year. It's running the latest available software.
__________________
Reply With Quote
  #4  
Old 11-18-2013, 07:38 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 711
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1165
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

You are on a very old version... RHB is up to 33...Sox knows his stuff

New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
__________________
Reply With Quote
  #5  
Old 11-18-2013, 06:50 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10575
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

Quote:
Originally Posted by StaticFX View Post
You are on a very old version... RHB is up to 33...Sox knows his stuff

New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
The TSR for that software update says it's for MY2012 only. My Overland is MY2011. I wouldn't want to load an incompatible ISO and brick my radio.

Yesterday, after five days of blank screen, the NAV started working again. I have no idea why.
__________________
Reply With Quote
  #6  
Old 11-18-2013, 07:04 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,850
Thanks: 86
Thanked 74 Times in 61 Posts
Rep Power: 570900
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
no issue for update, this unit are all the same, you can / musst updateting

go first with 33.23, then you can go with the last 50.00


.....with apple parts on tour
__________________
All Uconnect Software

www.mydrive.ch

username: mygig@soxag
Password: gasolio

Reply With Quote
  #7  
Old 11-19-2013, 12:28 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10575
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

Quote:
Originally Posted by *sox* View Post
no issue for update, this unit are all the same, you can / musst updateting

go first with 33.23, then you can go with the last 50.00
Thank you.

Quote:
Originally Posted by *sox* View Post
.....with apple parts on tour
I don't understand this sentence. Would you kindly rephrase?
__________________
Reply With Quote
  #8  
Old 11-19-2013, 04:38 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,850
Thanks: 86
Thanked 74 Times in 61 Posts
Rep Power: 570900
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
Re: 2011 RHB: black NAV screen?

lol, this are my sig. on my ipad with tapatalk app
__________________
All Uconnect Software

www.mydrive.ch

username: mygig@soxag
Password: gasolio

Reply With Quote
  #9  
Old 11-21-2013, 04:23 PM
Justal13's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2011
Location: Hudson, WI
Posts: 372
Thanks: 0
Thanked 17 Times in 15 Posts
Rep Power: 1931
Justal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond reputeJustal13 has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

My dealer installed 55.00 on my 2012 GC a few weeks ago and it scrambled the radio. Luckily I had my disk with 33.23 in the glovebox. It took 3 trys, but we got the screens back to looking "normal". Neither fixed my u-Connect issues, so I have unpaired my phone so I can at lease use it while I am driving (otherwise, u-Connect would work - not work - work and drop my calls constantly). I REALLY hate the new Garmin GPS Black and White and shades of Grey screen graphics, very difficult to read. I much preferred the original multi-colored graphs.

The dealer told me then entered a Star Case, but I hold out little to no hope that my u-Connect will ever get fixed. Or that Chrysler will ever send out any real updates for the 430RHB radio (Gracenotes, etc). And every time I check on GPS updates, the Navtec site says "backordered" for the past 3 months. Wow, how tough is it to make some disks with software on them....Nevermind, I sometimes forget, this is Chrysler after all....
__________________
Reply With Quote
  #10  
Old 11-22-2013, 10:55 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: Rivergrove, OR
Posts: 576
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10575
Andrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond reputeAndrew Klossner has a reputation beyond repute
Re: 2011 RHB: black NAV screen?

Thanks Justal13. I too have phone connect issues: sometimes the phone and head unit connect, sometimes they don't, with no rhyme or reason. For the first two years it worked solidly. It could be my phone, of course.
__________________

__________________
Reply With Quote
Reply

Tags
2011

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does 2014 nav map display more street names on the screen than the 2011 GC nav map? Sudin36 Audio/Visual/Navigation 3 05-01-2013 09:41 PM
430N (RHB) gives me a blank, then white SCREEN OF DEATH!...nothing works! THEPRFCT10 Audio/Visual/Navigation 5 06-07-2011 09:53 AM
RHB NAV Updates norterer Audio/Visual/Navigation 0 04-17-2011 12:10 PM
430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works! THEPRFCT10 Audio/Visual/Navigation 6 03-22-2011 11:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community