Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-26-2013, 08:22 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
2014 UConnect phone pairing issues?

Have any of y'all had problems with reconnecting your phone via Bluetooth once you've already paired it? I'm having to pair again each time I get in. When I click on the device in my phone to try to connect it gives me a message to "make sure Bluetooth device (UConnect) is on and in range". It's really annoying. I have an iPhone 5 and the iOS is up to date. Also I have a Laredo with a 5-inch screen. It pairs perfectly fine but the system never remembers it for some reason. Any advice?
__________________

__________________
Reply With Quote
  #2  
Old 03-28-2013, 02:04 PM
cmontel727's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Newton NJ
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 503
cmontel727 is on a distinguished road
Re: 2014 UConnect phone pairing issues?

I'm having the exact same problem with my 2014. I have an appointment with the dealer to check it out. BTW I have this same problem with any brand phone, not just apple.

I will post updates.

Good Luck
__________________

__________________
Reply With Quote
  #3  
Old 03-28-2013, 02:19 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
Re: 2014 UConnect phone pairing issues?

I hope the dealer can figure it out. Definitely let me know if they do! I was planning to call the UConnect number tonight to see if they could find a solution. Have you tried that? I will let you know if I get any help from them too.
__________________
Reply With Quote
  #4  
Old 03-28-2013, 02:29 PM
UplandGuide's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jan 2013
Location: Adirondacks of NY
Posts: 28
Thanks: 0
Thanked 5 Times in 2 Posts
Rep Power: 584
UplandGuide is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Yeah, I have the problem with my RAZR. Another owner of a 2014 brought his to a dealership and they kept it overnight informing him the next day that Chrysler is aware of the software problem and is working on it.....no timeframe for fix.

This is BS. You purchase a $40,000 plus Jeep and it has a problem (software problem Chrysler is working on - is this rocket science?) connecting devices via the Uconnect? My RAZR works in my VW, works in my F150 and worked in my 2012 Jeep GC.
__________________
Reply With Quote
  #5  
Old 03-28-2013, 03:10 PM
cmontel727's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Newton NJ
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 503
cmontel727 is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Quote:
Originally Posted by Amylee View Post
I hope the dealer can figure it out. Definitely let me know if they do! I was planning to call the UConnect number tonight to see if they could find a solution. Have you tried that? I will let you know if I get any help from them too.
No I have not contacted UConnect! I look forward to your results!
__________________
Reply With Quote
  #6  
Old 03-28-2013, 08:07 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Quote:
Originally Posted by UplandGuide View Post
Yeah, I have the problem with my RAZR. Another owner of a 2014 brought his to a dealership and they kept it overnight informing him the next day that Chrysler is aware of the software problem and is working on it.....no timeframe for fix.

This is BS. You purchase a $40,000 plus Jeep and it has a problem (software problem Chrysler is working on - is this rocket science?) connecting devices via the Uconnect? My RAZR works in my VW, works in my F150 and worked in my 2012 Jeep GC.

Ugh that is so sucky! Is it all of them you think, or just some of the 2014s that have this problem? I will let you all know what I find out from the UConnect people. I called tonight but they were closed already so I will have to try again tomorrow. Hopefully they will at least have a timeframe for a fix or something. If its not all of them I want a new one that works!!!
__________________
Reply With Quote
  #7  
Old 03-28-2013, 08:50 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,518
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49504
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: 2014 UConnect phone pairing issues?

My old RAZR connects ok. Now if I shut the RAZR off then turn it back on without turning off the ignition, it doesn't reconnect. Is that what everyone means?

I also noticed that in the 2012 Overland I had, it showed the battery strength meter. In the 2014 Summit, it doesn't show the battery meter. Seems like they are going backwards. Or are they trying to give me a hint to get a new phone?
__________________
2014 Summit 4X4, V8
Reply With Quote
  #8  
Old 03-29-2013, 06:09 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
Re: 2014 UConnect phone pairing issues?

The UConnect people weren't much help. basically they told me to contact the dealership. They said it might be a software compatibility problem because I have iOS 6.1.3 and only iOS 6.1 is listed as having been tested for compatibility. If it wasn't compatible wouldn't it not pair? Also, they have iOS 6.0 listed as compatible but not the other versions (6.0.1, 6.0.2, etc). Cmontel227 let me know what your dealership says. I am going to make an appt too.
__________________
Reply With Quote
  #9  
Old 03-29-2013, 06:14 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Quote:
Originally Posted by BobsWK2 View Post
My old RAZR connects ok. Now if I shut the RAZR off then turn it back on without turning off the ignition, it doesn't reconnect. Is that what everyone means?

I also noticed that in the 2012 Overland I had, it showed the battery strength meter. In the 2014 Summit, it doesn't show the battery meter. Seems like they are going backwards. Or are they trying to give me a hint to get a new phone?

I am talking about every time I get in the car after turning the ignition off I can't reconnect. I have to go through the whole pairing process every time I get in the car if I want to use my phone through Bluetooth.

I even saved the phone as a favorite but the unconnected system doesn't remember it. "UConnect" remains on my phone as a Bluetooth device option, but when I touch it to try to reconnect I get a message that says "make sure UConnect is turned on and in range", even though I am sitting in my car and it is on.
__________________
Reply With Quote
  #10  
Old 03-29-2013, 07:04 PM
cmontel727's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2013
Location: Newton NJ
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 503
cmontel727 is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Quote:
Originally Posted by Amylee View Post
The UConnect people weren't much help. basically they told me to contact the dealership. They said it might be a software compatibility problem because I have iOS 6.1.3 and only iOS 6.1 is listed as having been tested for compatibility. If it wasn't compatible wouldn't it not pair? Also, they have iOS 6.0 listed as compatible but not the other versions (6.0.1, 6.0.2, etc). Cmontel227 let me know what your dealership says. I am going to make an appt too.
Just returned home from the dealer...no good news to report. They are saying it is a software issue, between uconnect and my iphone4. They also tried two different 2014's GC's in the lot and the same thing happened.

The tech feels this rules out a problem with the radio unit, and make it a software compatibility issue. The tech was able to reproduce the problem with other phones as well. So this is not unique to just the iPhone. The tech asked to me to try a phone from another service provider. Everybody at the dealership including myself all have Verizon wireless. He wants to rule out a compatibility issue with Verizon. My sister uses t- mobile will see her this weekend and see if that makes any difference.

The service manager plans to reach out to Chrysler to see if they have any insight into this problem as well. I will post updates as I get them!
__________________
Reply With Quote
  #11  
Old 03-29-2013, 08:37 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2011
Posts: 159
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1707
jerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond repute
Re: 2014 UConnect phone pairing issues?

Bluetooth is a standard and all Bluetooth devices should meet the same basic standard for hands free phone operation. If there is a problem it is with Uconnect, not the phones. I know there can be some issues with contact lists, etc. but ANY Bluetooth hands free device and phone should be able to pair automatically after the first time and receive and make hands free calls. It's not a Apple problem, it's not a Android problem, it's not a Verizon problem, it is a Uconnect problem. The Bluetooth in my '11 JGC and in my wife's '10 Chevy Equinox is working fine with her iPhone 5 and the latest IOS update she got a few days ago and also with my Droid Razr with the latest Jelly Bean update I got last Tuesday. If your phone ain't connecting it's Uconnect. And this whole issue with Uconnect and all of the problems with the 8.4AN radio people are having is probably going to keep me from picking up the '14 we ordered and which went to shipping this week. There is NO excuse in today's world to have issues with a damned radio maintaining settings, rebooting, and generally doing weird crap and a Bluetooth that won't talk to a frigging phone. This is simply amateur hour in the electronics department. A nice big screen is worthless if it don't frigging work. I'll order another one in 6 or 8 months when they get their crap together. The Jeep folks should have all of their engineers and programmers locked in a room and being flogged as we speak.
__________________
Reply With Quote
  #12  
Old 03-29-2013, 11:33 PM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
Amylee is on a distinguished road
Re: 2014 UConnect phone pairing issues?

Yeah this is bullshit. I am going to report to my dealer. I would have waited too if I'd known this was a problem. For all the money you spend to have a simple Bluetooth problem....no way. If it is a software update that is needed, good news is that the UConnect person I spoke with today says they are rolling out updates constantly to keep up with phones, but if it is all phones I don't know what that means...certainly not good I would think.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth phone / Uconnect Polomaan Audio/Visual/Navigation 14 02-27-2014 08:25 AM
Phone now drops out after pairing with uConnect hammer1234 Audio/Visual/Navigation 5 03-21-2012 05:45 AM
Can't Answer Phone Through UConnect! bmrisko Audio/Visual/Navigation 1 12-27-2011 07:22 PM
Uconnect Phone Glitch Hollywood Audio/Visual/Navigation 11 11-25-2011 02:34 PM
How to download cell phone book to Uconnect phone billybronco1 Audio/Visual/Navigation 6 02-16-2011 10:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community