Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-20-2013, 11:16 AM
Member
 
Join Date: Aug 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 776
Mininuke is on a distinguished road
430N RHB noise issue

I own a 2013 Grand Cherokee with a Media Center 430n (RHB). I am experiencing a problem with the radio. When I play music through Bluetooth streaming or connected through a USB cable (both ports, on the radio and the center console) I can clearly hear a hiss or noise emanating from the speakers. The symptoms disappear if I play music from the hard drive or Satellite radio.

Furthermore, even if nothing is connected to the radio (Bluetooth or USB) when I select the "AUX" function the noise is there.

I suspect it is a firmware issue. I mentioned this problem to the service technicians but they told me to wait for an update. That was months ago.

I mostly play music from my iPhone 5 or through USB drives so the noise issue is something that I have to live with until I find a solution.

My previous car was a 2012 Jeep Wrangler Unlimited with the Media Center 730. I did not experience the problem with that system.

Do you have any suggestions or solution to my problem?

Can you tell me what my options are?

Can you also tell me what the specifications for the 430n are? I would like to know the frequency response (i.e. 20hz-20khz) as well as the power output in watts, RMS/MAX. I have not been able to find this information on any of the available literature both online (forums, Google) and user manual.

Thank you,

JP
__________________

__________________
Reply With Quote
  #2  
Old 03-20-2013, 11:38 AM
Member
 
Join Date: Aug 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 776
Mininuke is on a distinguished road
Re: 430N RHB noise issue

^^^Bump^^^

Does anyone here has the same issue?
__________________

__________________
Reply With Quote
  #3  
Old 06-23-2013, 04:54 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Apr 2013
Location: South Jersey
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 539
Koka is on a distinguished road
Hey did you ever figure anything out with this? My buddy is having similar issues.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will this 430N RHB work for me? xJoshxx Audio/Visual/Navigation 0 10-28-2012 07:01 PM
430N (RHB) USB Issue AudioHead Audio/Visual/Navigation 2 12-05-2011 12:10 PM
430n rhb updates? huff6 Audio/Visual/Navigation 4 06-03-2011 10:30 PM
For those with 430N/RHB problems out there... THEPRFCT10 Audio/Visual/Navigation 1 03-22-2011 10:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community