6 Speaker upgrade awful sound Please Help - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-25-2015, 11:43 PM
Member
 
Join Date: Jun 2015
Posts: 10
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 543
mrcadies is on a distinguished road
6 Speaker upgrade awful sound Please Help

Have a 2015 with 8.4an. Swapped stock speakers with kicker upgrades except for the door tweeters up front, had the kickers in but opted for alpine silk domes because the kickers were too harsh for my tastes. Had a local shop hook up an Alpine KTP-445U for $100. It seems like it's working well for like 5 minutes of playback (ipod through usb) then it gets low, sounds stock again almost. I have the bass set 2 notches below full and it's barely better than the stock, it's cleaner, but only very very slightly louder. I'm also getting clipping at around 21. I tuned my gains, both front and rear to half between 0 position and line 1, any higher I have distortion. The install guy said I needed something with a highpass input and I had the wrong amp, after the fact, and recommended a dsp or a fosgate 4 channel that he could do for me for another $300.

I just wanted a bit more and if I do a new amp or dsp all together I'll be almost $800 into this. Is this really my only option or does anyone here have any suggestions or thoughts. Thanks in advance.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-26-2015, 07:08 AM
Keysplayr's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Posts: 115
Thanks: 6
Thanked 18 Times in 16 Posts
Rep Power: 791
Keysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond reputeKeysplayr has a reputation beyond repute
Garage
Re: 6 Speaker upgrade awful sound Please Help

I have a 2015 Laredo and it came with the 5" RA2. I was so unhappy with the stock six speaker system that I kept the volume off most of the time and only turned it up when my kids wanted some music. It was really bad. The power was poor, it would cut out at around 20, start falling off (that system protection effect) and the highs were non existant.

Now I don't know the difference between the 5" RA2 and the 8.4" RA4 when it comes to the built in amps or if there are any external amps with the RA4 six speaker system, but I'll tell you what I did to my system that made my friend with the 9 Speaker overland Alpine system jealous.

What I've done.
Alpine KTP 445U 45x4 power pack amp.
Kenwood KFC-6985PS 6x9's for the front doors.
Kenwood KFC-1665S 6 1/2 for the rear doors.
Kenwood KFC ST01 tweeters for the upper front doors.

The Alpine KTP445U has two different line inputs. You can use pre-amp input or speaker level input. The instructions say that if you are using speaker level input, which means that you are using the actual wires that go to your speakers from the the back of your radio, right into your amp. If you do this, the gain has to be turned down to about the 9 o'clock position or less otherwise the signlal will be too hot and the amp will clip or fade out using internal protection.
This might be what you are experiencing with your amp seeming to work at first then fades.
Also, if you are using speaker level inputs, you do not need to run an accessory turn on wire to make the amp turn on and off. It uses the speaker level voltage to turn itself on and off.

So, check the gain. If you are using speaker level inputs from your RA4, turn the gain down to the 8 or 9 o'clock position and try that out.

I cannot speak for the speakers you chose to use, but I can tell you that my friend, when he first sat in my Jeep and heard the results of what I did with the above mentioned products, he just looked at me in awe and he was truly amazed. HUGE power and bass over the stock system. Massive gain in clarity and highs. The front door 6x9's I purchased are 4-way. The provide FULL range sound and just pump out highs clearly and smoothly. The KFC ST01 tweeters I used at the top front doors are just amazing. Now I have the abilty of turning down all the treble and mids instead of maxxing out treble and mids in the EQ and still not having enough.

Anyways, I am not always the best at explaining things because my mind races far faster than my mouth or fingers, and if you have any questions let me know and I'll see if I can provide any answers.

-Ant

P.S.

I have also added a sub and sub amp to my system. I purchased the Sub enclosure for a 2012 JGC off of ebay. Modded it so it would fit a 10" Kicker Subwoofer instead of 8". Used a SoundStream Picasso Nano Class D amp to run it.

Keep in mind that I really didn't need to do this. The door speakers and tweeters were astounding all on there own with great bass. I just wanted more bass in the back to round out the sound.
__________________
-Anthony
'15 Laredo Custom
Reply With Quote
The Following User Says Thank You to Keysplayr For This Useful Post:
  #3  
Old 02-29-2016, 12:02 PM
Member
 
Join Date: Jul 2015
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 519
JPAlt2015 is on a distinguished road
Re: 6 Speaker upgrade awful sound Please Help

Quote:
Originally Posted by Keysplayr View Post
I have a 2015 Laredo and it came with the 5" RA2. I was so unhappy with the stock six speaker system that I kept the volume off most of the time and only turned it up when my kids wanted some music. It was really bad. The power was poor, it would cut out at around 20, start falling off (that system protection effect) and the highs were non existant.

Now I don't know the difference between the 5" RA2 and the 8.4" RA4 when it comes to the built in amps or if there are any external amps with the RA4 six speaker system, but I'll tell you what I did to my system that made my friend with the 9 Speaker overland Alpine system jealous.

What I've done.
Alpine KTP 445U 45x4 power pack amp.
Kenwood KFC-6985PS 6x9's for the front doors.
Kenwood KFC-1665S 6 1/2 for the rear doors.
Kenwood KFC ST01 tweeters for the upper front doors.

The Alpine KTP445U has two different line inputs. You can use pre-amp input or speaker level input. The instructions say that if you are using speaker level input, which means that you are using the actual wires that go to your speakers from the the back of your radio, right into your amp. If you do this, the gain has to be turned down to about the 9 o'clock position or less otherwise the signlal will be too hot and the amp will clip or fade out using internal protection.
This might be what you are experiencing with your amp seeming to work at first then fades.
Also, if you are using speaker level inputs, you do not need to run an accessory turn on wire to make the amp turn on and off. It uses the speaker level voltage to turn itself on and off.

So, check the gain. If you are using speaker level inputs from your RA4, turn the gain down to the 8 or 9 o'clock position and try that out.

I cannot speak for the speakers you chose to use, but I can tell you that my friend, when he first sat in my Jeep and heard the results of what I did with the above mentioned products, he just looked at me in awe and he was truly amazed. HUGE power and bass over the stock system. Massive gain in clarity and highs. The front door 6x9's I purchased are 4-way. The provide FULL range sound and just pump out highs clearly and smoothly. The KFC ST01 tweeters I used at the top front doors are just amazing. Now I have the abilty of turning down all the treble and mids instead of maxxing out treble and mids in the EQ and still not having enough.

Anyways, I am not always the best at explaining things because my mind races far faster than my mouth or fingers, and if you have any questions let me know and I'll see if I can provide any answers.

-Ant

P.S.

I have also added a sub and sub amp to my system. I purchased the Sub enclosure for a 2012 JGC off of ebay. Modded it so it would fit a 10" Kicker Subwoofer instead of 8". Used a SoundStream Picasso Nano Class D amp to run it.

Keep in mind that I really didn't need to do this. The door speakers and tweeters were astounding all on there own with great bass. I just wanted more bass in the back to round out the sound.

Hoping you can respond to this... got pretty much same setup as you, but with the base 8.4 system. got the KTP and when I went to install the directions (to me) I need to run speaker wire to the 4 speakers?

- I thought this was just splice into factory Jeep harness and match the wires up and your good to go? am I missing something? appreciate any help as I am just trying to add the amp to the base factory system
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Awful sound from wheel well dmb4040 Trouble Shooting/Problems/Service 11 08-29-2016 10:22 AM
Alpine 9 speaker system Speaker Only Upgrade results Jeep_addicted Audio/Visual/Navigation 69 11-27-2015 07:52 PM
Base 6 speaker front door speaker upgrade question mrcadies Audio/Visual/Navigation 5 09-14-2015 01:38 AM
05 grand Cherokee 5.7 himi has awful whine sound when I first start mrbyrne Troubleshooting/Problems 5 11-24-2013 11:06 PM
Patriot/Compass Premium Sound Speaker Upgrade NHPATRIOT Tech Tips DIY/How To 0 04-11-2013 05:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.