Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-07-2013, 10:48 PM
Avusblue's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Saint Paul, Minn., USA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 402
Avusblue is on a distinguished road
A glitch I've not seen discussed: UConnect clock runs slow...

Hi everyone, been a lurker for a while (and a premium member) but never posted till now. I've been following the evolution of our UConnect operating system and experienced some of the "usual" problems. Accordingly, the dealer had to replace my 8.4A radio once and has updated the software as well -- I'm on 13.19.0 now. I love my 2014 Grand Cherokee overall (it's a Hemi V8 Limited AWD, built in April '13 and purchased in June) but it has an irritating intermittent issue I've not seen discussed.

My clock runs slow!

I wear an accurate wrist watch (Casio G-Shock that recieves a synch from the USNavy central Atomic clock every night) so it is always spot-on. Therefore, I notice when other clocks are inaccurate. When I get in the Jeep, sometimes the clock will be two minutes slow, sometimes 4 minutes, sometimes it'll be correct. I reset the clock almost every time I drive the Jeep, because otherwise, this daily inaccuracy will accumulate to a material error. Usually I set the time a couple minutes fast, thinking that when it loses a couple minutes over the course of the day, it'll be correct.

It never runs fast, only slow. Not always, but probably 4 out of 5 days. Am I the only one experiencing this? Any ideas? Suggestions? The dealer says they can't reproduce the issue, and frankly, how could they?

Thanks in advance for any experts help or advice.

Cheers,

Dave in Saint Paul.
Attached Images
File Type: jpg image.jpg (325.9 KB, 11 views)
__________________

__________________
Reply With Quote
  #2  
Old 09-07-2013, 10:55 PM
Avusblue's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Saint Paul, Minn., USA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 402
Avusblue is on a distinguished road
Re: A glitch I've not seen discussed: UConnect clock runs slow...

Another question. I should clarify... I have the 8.4A radio that is "nav ready," but does not have the nav module activated. I have given thought to purchasing the nav activation. Has anyone here done so? And / or, can anyone tell me if I do make the upgrade, do I then gain the GPS-synch'd clock?

Thanks again.
__________________

__________________
Reply With Quote
  #3  
Old 09-07-2013, 11:12 PM
Senior Member
 
Join Date: Jul 2010
Location: Troy OHIO
Posts: 1,001
Thanks: 36
Thanked 33 Times in 25 Posts
Rep Power: 72402
Srt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond reputeSrt8_hmi has a reputation beyond repute
Re: A glitch I've not seen discussed: UConnect clock runs slow...

If you wanted a fast clock you should have bought the SRT... I've never noticed any discrepancies with mine. I'll keep an eye on it.
__________________
My Mopar YouTube channel

2008 SRT8 ,2011 X, 2014 Overland, 2012 SRT8 ,2014 Durango RT
2014 SRT-current
Reply With Quote
  #4  
Old 09-08-2013, 07:37 AM
Tarponbeach's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Sep 2013
Location: Maryland
Posts: 118
Thanks: 8
Thanked 7 Times in 6 Posts
Rep Power: 434
Tarponbeach is on a distinguished road
Re: A glitch I've not seen discussed: UConnect clock runs slow...

I was told by the dealer that if NAV is active, the system syncs time with the GPS satellites. My Nav is active, and the clock in my GC is dead on.
__________________
2014 GC Limited
Max Steel/Black
Reply With Quote
  #5  
Old 09-09-2013, 08:11 AM
Avusblue's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Saint Paul, Minn., USA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 402
Avusblue is on a distinguished road
Re: A glitch I've not seen discussed: UConnect clock runs slow...

Quote:
Originally Posted by Tarponbeach View Post
I was told by the dealer that if NAV is active, the system syncs time with the GPS satellites. My Nav is active, and the clock in my GC is dead on.
Tarponbeach: thanks for the comment. Can you confirm that your radio is the 8.4A, and that you activated the Nav as part of (or subsequent to) vehicle purchase? Versus having the 8.4AN radio that already has nav built-in.

I know that the 8.4A "activated" nav has fewer bells and whistles than the 8.4AN version, and I'd like to confirm that for $595, the GPS clock feature is indeed included with "activation".

Thanks.
__________________
Reply With Quote
  #6  
Old 09-09-2013, 08:23 AM
Tarponbeach's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Sep 2013
Location: Maryland
Posts: 118
Thanks: 8
Thanked 7 Times in 6 Posts
Rep Power: 434
Tarponbeach is on a distinguished road
Re: A glitch I've not seen discussed: UConnect clock runs slow...

Quote:
Originally Posted by Avusblue View Post
Tarponbeach: thanks for the comment. Can you confirm that your radio is the 8.4A, and that you activated the Nav as part of (or subsequent to) vehicle purchase? Versus having the 8.4AN radio that already has nav built-in.

I know that the 8.4A "activated" nav has fewer bells and whistles than the 8.4AN version, and I'd like to confirm that for $595, the GPS clock feature is indeed included with "activation".

Thanks.
Yes, it was listed on the window sticker as a $595 "option". I'd really like to meet the rocket scientist at Jeep who comes up with all of these different configurations, based on trim level.

Correction, the window sticker in my owners packet was for another vehicle. The dealer must have mixed it up with my GC. My radio is the 8.4AN, not the 8.4A. Sorry for the error.
__________________
2014 GC Limited
Max Steel/Black
Reply With Quote
  #7  
Old 09-10-2013, 10:01 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 784
Thanks: 0
Thanked 32 Times in 25 Posts
Rep Power: 3294
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: A glitch I've not seen discussed: UConnect clock runs slow...

Quote:
Originally Posted by Avusblue View Post

Can you confirm that your radio is the 8.4A, and that you activated the Nav as part of (or subsequent to) vehicle purchase? Versus having the 8.4AN radio that already has nav built-in.

I know that the 8.4A "activated" nav has fewer bells and whistles than the 8.4AN version, and I'd like to confirm that for $595, the GPS clock feature is indeed included with "activation".
I have the "8.4A" radio (not the 8.4AN), I had my NAV activated later on (free from the dealership...long story), and yes I synced the clock with the NAV...and the radio clock has been dead on since.

__________________
2014 Granite GC Overland 4x4 3.6L / Mud Flaps / Pedal Set / Lighted Door Sills / Slush Mats & Cargo Mat / H11 Phillips Fog Light Bulbs / Skid Plates (Front & Middle Only) / Tinted Front Door Windows (35%) / Airaid CAI / Ionic Running Boards / Build Date: 12/13 / 8.4AN v14.05.3
Reply With Quote
  #8  
Old 11-12-2013, 11:52 PM
Member
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 366
eatmorepizza is on a distinguished road
I have the same issue. No nav. It's so annoying!!!! Chrysler can't get the clock to work right
__________________
Reply With Quote
  #9  
Old 11-13-2013, 01:52 AM
Premium Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jun 2013
Location: San Diego, Ca
Posts: 637
Thanks: 0
Thanked 15 Times in 15 Posts
Rep Power: 22324
YjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond reputeYjagetaJeep has a reputation beyond repute
That is unbelievable. ..I've received quartz watches with gas fill-ups that kept PERFECT time
__________________
Reply With Quote
  #10  
Old 11-13-2013, 08:45 AM
Premium Member
 
Join Date: Jul 2013
Posts: 480
Thanks: 0
Thanked 20 Times in 15 Posts
Rep Power: 17634
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: A glitch I've not seen discussed: UConnect clock runs slow...

I believe the latest uConnect update 13.38.52 references "Clock Enhancements" in its release notes - might address the issue for those without Nav.
__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #11  
Old 11-13-2013, 08:47 AM
Member
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 366
eatmorepizza is on a distinguished road
Sometimes it's worst. In the beginning it would lag behind 1min/day now its 2-4/day. I'm using auto start more now and I couldn't help to think it might be that, but sounds totally nuts.
__________________
Reply With Quote
  #12  
Old 11-13-2013, 08:48 AM
Member
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 366
eatmorepizza is on a distinguished road
Quote:
Originally Posted by TurboRush View Post
I believe the latest uConnect update 13.38.52 references "Clock Enhancements" in its release notes - might address the issue for those without Nav.
Thank you! I will look into that
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Uconnect Glitch? plynn7 Trouble Shooting/Problems/Service 40 01-25-2014 10:47 AM
Uconnect Phone Glitch Hollywood Audio/Visual/Navigation 11 11-25-2011 02:34 PM
2012 runs 13.81 06HemiLtd Grand Cherokee SRT - WK2 199 09-17-2011 02:08 AM
Blinker Stalk Glitch... question about swapping for new antsjeep Grand Cherokee - WK 5 08-04-2011 06:22 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community