Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-21-2011, 03:41 AM
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Coffs Harbour Aust.
Posts: 159
Thanks: 10
Thanked 1 Time in 1 Post
Rep Power: 1323
jefferson.oz has a reputation beyond reputejefferson.oz has a reputation beyond repute
Amp to be replaced...

Here I am cars only 2 weeks old, (sept' build though) go in for the free 1000km check over and they tell me there's a bulliton to replace the amp, sounds fine to me, think its a 430 no nav, anyway, anybody know why? seems odd since I haven't complained, hope it won't be a step backwoods....
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
have you replaced your waterpump??? spiker01 Troubleshooting/Problems Discussion 13 05-11-2013 11:56 AM
Replaced Cabin Filter mon_21 Troubleshooting/Problems 38 02-15-2013 01:20 AM
4.7L Catalytic Converter replaced jjs4348 Engine Performance/Intake/Exhaust 21 10-20-2011 02:36 AM
730n - needs replaced Fortilais Audio/Visual/Navigation 16 10-20-2010 10:51 AM
Jeeps gone and has been replaced by a vdub Grandcherokee51 Other Rides 15 07-11-2010 08:25 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community