Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 12-31-2010, 04:42 AM
tvguy710's Avatar
Premium Member
 
Join Date: Dec 2010
Location: New Jersey
Posts: 103
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1462
tvguy710 is on a distinguished road
Garage
Re: Anybody installed lock pick on 2011?....

Hey guys I am new to jeepgarage. Loving the website, wish I knew about it before. I currently own a lockpick(V.2) bought in 2008 for my 2008 Jeep JC. it works great and easy to install. My lease is up in a couple of months and was just wondering if this lock pick will work on the 2011 JC.

Thank you
__________________

__________________
Reply With Quote
  #38  
Old 12-31-2010, 09:37 AM
jonesark's Avatar
Premium Member
 
Join Date: Sep 2010
Location: The South
Posts: 593
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2051
jonesark is on a distinguished road
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by FUGIECAT View Post
Hello all. I am new to this forum, but I wanted to share my experiences with everyone regarding the video in motion modules. I have a 2010 GC SRT8 with an RER radio. I have personally installed both the Coastal Tech Lockpick (v2 & v3) and the Nav-Tv All Gig modules. I have experienced problems (along with others) with each of these modules. The Lockpicks had issues which locked up the radio and All Gig module had caused the instrument cluster lights to flash intermittently. After doing all of the research on several forums, I have seen these issues from alot of members as well. Nav-Tv has just released a new version of the All Gig module called an Allgig XG FT. I currently have this installed and the instrument cluster problem has been corrected. The new hardware platform and software seems to be stable. I have tested the software for the RBZ radio and the REN radio as well. Everything seems to be working great. I will post an update to this thread if anything changes, but so far so good. This information is is from my personal experience. I am not trying to knock anyones product. I am just trying to provide others with the information that is factual.
I've been reading reviews on them for months now and haven't really heard of any problems. Everyone on here seems happy with them.
__________________

__________________
2011 Jeep Grand Cherokee
Overland 4x4 Hemi
Stone White, Saddle, ACC Package
Ordered Sep 21st 2010
VIN assigned Oct 25th 2010
D1 Dec 10th 2010
Estimated Delivery Jan 7th 2011
Delivered Jan 12th 2011
Reply With Quote
  #39  
Old 12-31-2010, 09:53 AM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 118
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 1507
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Re: Anybody installed lock pick on 2011?....

One thing,we have a customer with what I think is a lockpick installed,he won't admit it but anyways,RHB radio and now the speed on the nav is always "0".He claims it worked,which I know is true.He shows up and now he has the VES lit up on the screen,which his Jeep does not have,and a rats nest of wiring behind the radio.
Which leads me to this,it looks like on the Garmin nav,the vehicle speed is not from the gps,but seems to be a bussed message to the radio.I keep meaning to run one on the lift and see what speed the nav shows just to confirm.
__________________
Reply With Quote
  #40  
Old 12-31-2010, 10:02 AM
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Indianapolis
Posts: 275
Thanks: 0
Thanked 7 Times in 4 Posts
Rep Power: 1742
IndyBob has a spectacular aura about
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by xj31 View Post
One thing,we have a customer with what I think is a lockpick installed,he won't admit it but anyways,RHB radio and now the speed on the nav is always "0".He claims it worked,which I know is true.He shows up and now he has the VES lit up on the screen,which his Jeep does not have,and a rats nest of wiring behind the radio.
Which leads me to this,it looks like on the Garmin nav,the vehicle speed is not from the gps,but seems to be a bussed message to the radio.I keep meaning to run one on the lift and see what speed the nav shows just to confirm.
I have LockPick v3 installed and it does make the Nav speed read zero and also my VES is lit up. The LockPick causes this in my case.
__________________
Reply With Quote
  #41  
Old 12-31-2010, 02:26 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Dec 2010
Location: Columbia, MO
Posts: 265
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1624
mrpositraction is on a distinguished road
Send a message via AIM to mrpositraction
Re: Anybody installed lock pick on 2011?....

I just ordered the NAV-TV for the mygig. Will have it Wednesday of next week. I was told by coastaltech that the Lockpic "was not on the approved list of vehicles (2011 Jeep Grand Cherokee), but clearly, the V3 seems to be working.
__________________
2011 Jeep Grand Cherokee Overland, 5.7L Hemi, 730N, Offroad Package II
Quote:
Originally Posted by jpsmith View Post
No need for decaf. The is the internet. When people challenge you, you have to fly way the hell off the handle. If you don't, you're doing the internet wrong.
Reply With Quote
  #42  
Old 12-31-2010, 03:51 PM
jonesark's Avatar
Premium Member
 
Join Date: Sep 2010
Location: The South
Posts: 593
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2051
jonesark is on a distinguished road
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by IndyBob View Post
I have LockPick v3 installed and it does make the Nav speed read zero and also my VES is lit up. The LockPick causes this in my case.
What is VES and where does this light up at? The lockpick doesn't cause any damage to the electronics does it?
__________________
2011 Jeep Grand Cherokee
Overland 4x4 Hemi
Stone White, Saddle, ACC Package
Ordered Sep 21st 2010
VIN assigned Oct 25th 2010
D1 Dec 10th 2010
Estimated Delivery Jan 7th 2011
Delivered Jan 12th 2011
Reply With Quote
  #43  
Old 12-31-2010, 04:06 PM
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Indianapolis
Posts: 275
Thanks: 0
Thanked 7 Times in 4 Posts
Rep Power: 1742
IndyBob has a spectacular aura about
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by jonesark View Post
What is VES and where does this light up at? The lockpick doesn't cause any damage to the electronics does it?
VES is the rear entertainment system which I do not have. It just lights up that option but it doesn't do anything. I have had mine installed for 2 weeks now and no problems. If for some reason I did have a radio problem I would remove the LockPick before I took it in.
__________________
Reply With Quote
  #44  
Old 12-31-2010, 04:52 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Aug 2010
Location: Virginia
Posts: 417
Thanks: 3
Thanked 4 Times in 4 Posts
Rep Power: 1923
Radside has a reputation beyond reputeRadside has a reputation beyond repute
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by mrpositraction View Post
I just ordered the NAV-TV for the mygig. Will have it Wednesday of next week. I was told by coastaltech that the Lockpic "was not on the approved list of vehicles (2011 Jeep Grand Cherokee), but clearly, the V3 seems to be working.
I have the lockpick in mine as well with no issues.
__________________
2011 Black Berry Laredo X
Chrome Running Boards
Chrome Fog Bezel
Shark Fin Antennal
MyGig 430N
20" SRT REPS (9"wide)
Good Year Fortera 265 50R/20
Reply With Quote
  #45  
Old 01-05-2011, 07:22 AM
Premium Member
 
Join Date: Jan 2011
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1373
StrangeBrew is on a distinguished road
Re: Anybody installed lock pick on 2011?....

Sounds great. I'll definitely purchase a Lockpick.
__________________
Reply With Quote
  #46  
Old 01-25-2012, 10:43 AM
New Member
 
Join Date: Jan 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
RoadiJeff is on a distinguished road
Re: Anybody installed lock pick on 2011?....

Hi. I thought I'd share my experience with my Lockpick. I stumbled on this thread while Google searching to see if anyone else has had the same problem that has cost me over $1,500 because of my Lockpick device.

I have one of the original Lockpicks in my '07 Sebring. (yes, I know this is a Jeep forum but Chrysler vehicles share much of the same technology). For over 3 years everything was okay with it. Last week I started getting several check engine faults. The car still ran okay but things were getting worse as more faults popped up. I figured I should drive it to the dealer and have them diagnose the problem(s) before I had to have it towed in.

The service techs were initially stumped. Their diagnostic equipment was giving them conflicting fault codes. Calls back and forth to Chrysler headquarters in Detroit (I live in the St. Louis area) offered suggestions but most of the problems still were not resolved. They did find that the two front door modules were bad. After they were replaced some of the faults cleared but others remained.

One evening shift tech guru, who the service adviser says is one of their best, stayed on it for several days and probably 30 hours worth of diagnostic. I was told he only was paid for about 1/2 of that time and the rest he did for free. Apparently, once he gets into something he is determined to fix it, whether he is on the clock or not.

Anyway, after they had my car for 6 days one of the techs noticed that I had an aftermarket backup camera installed. They looked behind the MyGig and discovered the Lockpick module. After they disconnected the Lockpick wiring harness and reconnected the MyGig back up straight to the factory wire harness the faults went away.

I don't know if the camera caused the problem, the Lockpick or what. I purchased everything from them so it was all their products. I do know that it caused several of the car's modules to partially fail and throw various fault codes throughout the system that indicated emissions problems, etc., that weren't really faulted.

This experience cost me $1,523 in many hours of diagnostic time, parts, modules and labor. I will not be replacing my Lockpick with another one. I just wanted to share my story with anyone who may be considering buying one. Perhaps they've improved their units since 2008. I will not be finding out.

Feel free to email me if you'd like. I don't visit the Jeep forums very often, although my wife is taking about getting a Wrangler later this fall. Maybe I'll be a regular here then.
__________________
Reply With Quote
  #47  
Old 01-25-2012, 04:57 PM
rockrash's Avatar
Member
My Jeep: 2005 4.0L LJ
 
Join Date: Nov 2011
Location: NJ
Posts: 396
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 1446
rockrash is on a distinguished road
Re: Anybody installed lock pick on 2011?....

Quote:
Originally Posted by RoadiJeff View Post
Hi. I thought I'd share my experience with my Lockpick. I stumbled on this thread while Google searching to see if anyone else has had the same problem that has cost me over $1,500 because of my Lockpick device.

I have one of the original Lockpicks in my '07 Sebring. (yes, I know this is a Jeep forum but Chrysler vehicles share much of the same technology). For over 3 years everything was okay with it. Last week I started getting several check engine faults. The car still ran okay but things were getting worse as more faults popped up. I figured I should drive it to the dealer and have them diagnose the problem(s) before I had to have it towed in.

The service techs were initially stumped. Their diagnostic equipment was giving them conflicting fault codes. Calls back and forth to Chrysler headquarters in Detroit (I live in the St. Louis area) offered suggestions but most of the problems still were not resolved. They did find that the two front door modules were bad. After they were replaced some of the faults cleared but others remained.

One evening shift tech guru, who the service adviser says is one of their best, stayed on it for several days and probably 30 hours worth of diagnostic. I was told he only was paid for about 1/2 of that time and the rest he did for free. Apparently, once he gets into something he is determined to fix it, whether he is on the clock or not.

Anyway, after they had my car for 6 days one of the techs noticed that I had an aftermarket backup camera installed. They looked behind the MyGig and discovered the Lockpick module. After they disconnected the Lockpick wiring harness and reconnected the MyGig back up straight to the factory wire harness the faults went away.

I don't know if the camera caused the problem, the Lockpick or what. I purchased everything from them so it was all their products. I do know that it caused several of the car's modules to partially fail and throw various fault codes throughout the system that indicated emissions problems, etc., that weren't really faulted.

This experience cost me $1,523 in many hours of diagnostic time, parts, modules and labor. I will not be replacing my Lockpick with another one. I just wanted to share my story with anyone who may be considering buying one. Perhaps they've improved their units since 2008. I will not be finding out.

Feel free to email me if you'd like. I don't visit the Jeep forums very often, although my wife is taking about getting a Wrangler later this fall. Maybe I'll be a regular here then.
Thanks for the warning it's not worth the trouble if their having glitches.
Thanks again that's why i love this forum.
__________________
Reply With Quote
  #48  
Old 01-25-2012, 05:05 PM
SixZeroFour's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2011
Location: Vancouver BC
Posts: 542
Thanks: 11
Thanked 38 Times in 25 Posts
Rep Power: 54357
SixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond repute
Re: Anybody installed lock pick on 2011?....

There have been multiple updates to the lockpick since 2008 so most of these issues have probably been addressed, but thanks for the heads up either way. Sounds like coastaltech's support is also very hit and miss.

FWIW I spoke to TVANDNAV2GO and they are releasing a new version compatible with the 2011+ in mid feb - think I may wait to see what they have to offer.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone purchased & installed MYGIG in a 2011? brogan2424 Audio/Visual/Navigation 32 01-04-2011 01:36 PM
My Gig Lock Pick V2 or V.3 White WK Swagga Audio, Video, Navigation & Electronic Modifications 1 09-29-2010 08:09 PM
2011 is "Top Safety Pick" LJS8510 Grand Cherokee - WK2 - 8 06-04-2010 06:30 AM
gorilla lock set Motteler621 Visual Modifications 0 03-06-2010 09:10 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community