Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-01-2013, 10:11 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mikati is on a distinguished road
GC '14 Laredo RA2 iPhone bluetooth problems

Hello all

After combing through the forum, i'm posting a new thread here as I believe this problem is specific to certain configurations. I have a brand new (not even a week old) 2014 GC Laredo with the RA2 audio unit, 5inch screen and own an iPhone 5 with the latest 6.1.4 iOS version. My uconnect SW version is 13.12.1 which seems is the latest version.

Pairing was a cinch when I first hopped in, but since then it's been alternating between finding the phone and connecting and not. It doesn't matter if I remove the pairing and re-pair, un-check syncing of the address book, etc, it is just not reliably connecting. This feature is critical to me since I am in the car a lot and need to be able to take calls. I never had any issue with the cars I've driven recently with this iOS version on my phone, so I am so surprised that I am running into this problem!

Does anyone else have the same problem with a similar setup and have any workarounds/solutions/advice??

If some of the above is repetitive of other posts, I apologize in advance but again I was trying to get specific.

Thank you all
__________________

__________________
Reply With Quote
  #2  
Old 07-10-2013, 11:43 AM
New Member
 
Join Date: Feb 2013
Location: Ottawa, Canada
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
basement has a reputation beyond reputebasement has a reputation beyond reputebasement has a reputation beyond repute
Re: GC '14 Laredo RA2 iPhone bluetooth problems

I have the RA2, though with an iphone 4 (latest SW). I don't know what Uconnect version I have. I took delivery in May.

I have found that the Bluetooth pairing is not very consistent. It's never immediate. Without touching it, it would usually pair within a minute though there was an occasion where I was sure it had not paired in 5 minutes. As a point of comparison, my wife's Mercedes on the other hand pairs instantly and has never failed. She had paired her phone once 3 years ago. I monitor the Jeep every now and then but so far I can probably say it will pair, though not always instantly.

Hope this helps
__________________

__________________
Reply With Quote
  #3  
Old 07-11-2013, 01:35 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 691
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1118
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: GC '14 Laredo RA2 iPhone bluetooth problems

i was digging around looking for other info (about texting with the 8.4an) and found a huge thread about this. It seems its a known issue with the RA2 and uconnect is working on it.

As far as the time to "connect" its still slow (my 11 laredo was slow too) they need to fix that!
__________________
Reply With Quote
  #4  
Old 07-11-2013, 02:37 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mikati is on a distinguished road
Re: GC '14 Laredo RA2 iPhone bluetooth problems

I've noticed i've had better luck waiting for the software to load completely before putting the car in drive, but it's still not consistent/random. if it doesn't connect within the first 20-30 seconds, that means it definitely wont that drive. really sucks
__________________
Reply With Quote
  #5  
Old 07-20-2013, 10:30 PM
New Member
 
Join Date: Jul 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Fly Guy is on a distinguished road
Re: GC '14 Laredo RA2 iPhone bluetooth problems

I recently purchased a 2014 gc limited. I have an samsung s3 that is sinced via bluetooth. I can make phone calls, listen to music, books on tape etc. But about every10 minutes it disconnects then has to reconnect. With music it is slightly anoying. With a book, it is a major pain 'cause I have to start the program over each time. Jeep, please fix!!! I have a 2012 ford F350, and have never had an issue, a 2012 honda oddessey no issues there either. I love the display, and the overall package of the Grand Cherokee, but this is driving me nuts!
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not connect Bluetooth, iOS 6 iPhone 5 issue? DanD2124 Audio, Video, Navigation & Electronic Modifications 5 02-02-2013 12:00 PM
First post - iphone 5 / audio problems davidg22 Audio/Visual/Navigation 1 01-08-2013 04:09 PM
iPhone 4S iOS5.1 & bluetooth issues? cmiller Audio/Visual/Navigation 3 04-08-2012 01:22 PM
Iphone 3gs and uconnect problems rammunitiondb9 Troubleshooting/Problems 9 11-02-2011 07:20 PM
High Frequency Sound with iPhone/Uconnect bluetooth music playing bgmtnclmbr Trouble Shooting/Problems/Service 1 09-07-2011 10:08 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community