Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-05-2014, 05:29 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
I think my UConnect is bricked.. any suggestion welcomed

I did the 14.22 upgrade on my 14" GC Summit yesterday without issue and then drove the car about an hour. When i was pulling it into the garage, i noticed that the backup camera wouldnt come on as I reversed to adjust angle of approach, but i figured a cold start would straighten things out, so I shut off the car and went in for the evening.

This morning I started up the car and it gave me an error message saying that an error occurred and that if it persisted after an ignition cycle I should contact the dealer. I turned on and off the car (and waited 30 seconds between) about 4 times and just decided to take off... so a 40 minute drive to work in silence ensued.

This evening when I was leaving work, a message came up to insert a USB with software upgrade if I had one (which I did bc I left the USB stick in the car from yesterday). It recognized the stick when I inserted it the screen dissolved to white as it typically does when upgrading so I thought I might be saved... but alas, i was wrong.

It got caught on a cycle where a message displayed saying to insert USB software update and then would dissolve to white, screen off, and then come back with the same message 2 minutes later. Rinse and repeat.

So i need guidance here - i do have an appt scheduled for Thursday, but I have to drop my car 25 minutes away, so would rather resolve myself if i can. I'm clearing and reloading the USB stick with 14.22 and trying again and if that doesnt work was going to pull the battery and go for a hard reset. is this the right approach? Should I do anything different? Any caveats with pulling the battery?

Your insight is appreciated!
__________________

__________________
Reply With Quote
  #2  
Old 08-05-2014, 05:33 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,175
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801663
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: I think my UConnect is bricked.. any suggestion welcomed

I would download the update again and extract it onto a different, blank usb. Try again.

If that doesn't work, try reinstalling the prior version.


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 08-06-2014, 01:00 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

Quote:
Originally Posted by bill_de View Post
I would download the update again and extract it onto a different, blank usb. Try again.

If that doesn't work, try reinstalling the prior version.


---
Tried that last night with no luck... still prompting me for USB software update as if i never inserted the drive - which i have. Tonight ill disconnect the battery. if that doesnt work, it goes to dealer for pre-scheduled apppointment.
__________________
Reply With Quote
  #4  
Old 08-07-2014, 09:36 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: NC
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 511
SleepyWeasel is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

Bill, do you think doing the hard reset/factory reset would help?
__________________
Be Polite. Be Professional. But have a plan to kill everyone you meet.
Reply With Quote
  #5  
Old 08-07-2014, 07:31 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

Ok,sat night I reformatted my usb stick to FAT32 and reloaded the ios file. This morning when I started up to head to the dealer, uconnect prompted me to insert the usb stick and it successfully reloaded the OS. I recycled the ignition about a dozen times and decided that I was stable enough to skip the dealer so headed I to work. Lunch time I took her out and the system worked flawlessly.

After work on start up I was confronted again with a blank screen and repeated prompts to install the update via usb, so it's to the dealer next week. I think I'll need a swap out. I'm traveling all week so they'll have time to diagnose and hopefully replace as necessary.

... So I got that goin for me


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #6  
Old 08-07-2014, 09:27 PM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 434
Thanks: 15
Thanked 27 Times in 23 Posts
Rep Power: 1541
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: I think my UConnect is bricked.. any suggestion welcomed

I'd try loading the software one more time, and assuming it functions properly thereafter then immediately do a hard reset.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.5!!
Reply With Quote
  #7  
Old 08-08-2014, 07:47 AM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

Quote:
Originally Posted by Northland View Post
I'd try loading the software one more time, and assuming it functions properly thereafter then immediately do a hard reset.
Do you mean via the engineering menu or via battery pull?

The system was again functional this morning (or so i thought). At least I was able to listen to the radio on my way to work, but it would not go into the engineering menu when I tried the Temp up/down button combo, so I couldnt get in to do a reset. When I turned off the car at work and restarted, i was back to square one. "Please insert USB software update" or something to that matter. I'll try again to either install the software or hope it boots and is stable enough to try immediately to do a hard reset.
__________________
Reply With Quote
  #8  
Old 08-08-2014, 10:25 AM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 434
Thanks: 15
Thanked 27 Times in 23 Posts
Rep Power: 1541
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: I think my UConnect is bricked.. any suggestion welcomed

I meant via the engineering menu, but given your situation if that doesn't work I'd pull the neg terminal off the battery and let it sit 15-20 minutes also. If neither of those work, get it to the dealership and let them sort it out - hopefully they'll just install a new unit.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.5!!
Reply With Quote
  #9  
Old 08-08-2014, 10:51 AM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

Quote:
Originally Posted by Northland View Post
I meant via the engineering menu, but given your situation if that doesn't work I'd pull the neg terminal off the battery and let it sit 15-20 minutes also. If neither of those work, get it to the dealership and let them sort it out - hopefully they'll just install a new unit.
ok, will do. Living without UConnect this week has been a real PITA. No stereo and no backup camera....I know, we should all have the fortune of having such problems, but infotainment systems should be bullet-proof.
__________________
Reply With Quote
  #10  
Old 08-10-2014, 10:24 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

UPDATE: I brought my GC into the dealer Saturday and they diagnosed the vehicle by the time I got to the service desk (they had valet the vehicle and ran the codes immediately). Essentially, I need a new control module - i forget the exact name for it. The codes they read off indicated that it was indeed a hardware issue, so I've left the car at the dealer while I travel this week.

The software they were using (really slick interface on an iPad) not only showed all of the vehicle details including what firmware versions I have for anything in the car that can be flashed, but also showed them a list of all available TSBs my car is eligible for and they simply checked off everything on the list that would bring me up to date... I'm sure many of you guys have already seen it, but I was blown away at the comprehensiveness of the system. Full history, including service dates, locations and purchase date / dealer. Very cool!
__________________
Reply With Quote
  #11  
Old 08-15-2014, 10:43 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 246
srs148 is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

One week later - just got my GC back from the dealer this evening. Entirely new UConnect system. Timing of the 14.25 update and the system crapping out was apparently purely coincidental. Hopefully, this is the last time we're out of commission this long. I was lucky that I had another car to drive and was also out of town on business part of the week so didnt need it, but man was it nice to be driving her again after driving my Ford Edge since last Saturday... a world of difference between the two vehicles.
__________________
Reply With Quote
  #12  
Old 08-19-2014, 07:16 AM
Premium Member
 
Join Date: Jul 2013
Posts: 16
Thanks: 6
Thanked 0 Times in 0 Posts
Rep Power: 462
ncuskey is on a distinguished road
Re: I think my UConnect is bricked.. any suggestion welcomed

I also had the same "purely coincidental" failure on the latest software upgrade. Dealership is replacing the entire head unit after multiple install attempts/failures. Hopefully getting the Jeep back this evening.


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Said good-bye to Amber and welcomed more Black SRTILL8 Interior/Exterior Visual 41 01-18-2012 06:06 AM
Welcomed another Mopar product to the family... XXX007 Other Rides 10 07-31-2011 10:11 PM
4.7 Mods Suggestion - Performance 2007GC Performance Modifications 71 03-19-2011 12:22 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community