Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 05-03-2014, 03:30 AM
mrkonow's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2010
Posts: 103
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1582
mrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond repute
Re: Installation of OEM Camera in 2014 Laredo

Talking about the Jeep logo.... I noticed my original emblem is chrome, and the new tail gate with camera emblem isn't chrome. Its a weird grey color.

I'm going to ask the dealer if it is possible to swap the emblems.
__________________

__________________
Reply With Quote
  #26  
Old 05-03-2014, 06:27 AM
BlckWK2's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2014
Location: Metro Detroit
Posts: 185
Thanks: 2
Thanked 8 Times in 8 Posts
Rep Power: 597
BlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond reputeBlckWK2 has a reputation beyond repute
Garage
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by MOFSTEEL View Post
I will separate those pieces and add the black frame w/camera to my Billet Silver Altitude tailgate bar. Lastly to the dealer to activate.

Pictures to come.
Will be awaiting the results! Excited to know. Also get some pics of it working on screen if you can.
__________________

__________________
Reply With Quote
  #27  
Old 05-03-2014, 02:35 PM
MOFSTEEL's Avatar
Krypton Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Chicago Burbs
Posts: 240
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 14995
MOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond repute
Garage
Re: Installation of OEM Camera in 2014 Laredo

Here is the tail light brow separated into two pieces.



Here is a shot of the tabs and epoxy used to keep the two parts together.


__________________
Reply With Quote
  #28  
Old 05-05-2014, 10:05 AM
Member
 
Join Date: Aug 2013
Posts: 86
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 416
DanPorges is on a distinguished road
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by mrkonow View Post
Today I installed the OEM camera. To my surprise, the harness in my Laredo is different and it has all wires in it. I still need to take it to the dealer and add the sales code.


So I ordered a cable from Lassen but it seems that I won't need it.

I'll post an update after the dealer adds the code.


Sent from my iPhone using JeepGarage
I spoke with my dealer about this after I finished. They asked why I didnt just have them install the kit that is now available.....???? I am starting to think that some of the changes mid year to the Laredo included putting the same wiring harness in all models so that dealers could offer this as a plug in accessory, much to what Mrkonow has found. This also may explain why when I first went to order the parts it was like 4 or 5 different pieces and then I was told those were no longer available and it was replaced by a single part number which was all inclusive.

There have been a few other changes to the Laredo mid year, like the elimination of the 18" wheel and 8.4" screen option package, so who knows what Chrysler is really thinking these days.
__________________
Reply With Quote
  #29  
Old 05-06-2014, 03:37 AM
mrkonow's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2010
Posts: 103
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1582
mrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond repute
Re: Installation of OEM Camera in 2014 Laredo

So I have some updates, I still haven't taken it to the dealer to have it flashed.

Today I removed my radio looking for the camera wires and didn't find any. So It seems that I have the wiring at lift gate and it ends somewhere in the chassis. I'll need more time to see if I can trace those wires.

Now Id like to look at the kit.

Dan could you please post this kit part number?


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #30  
Old 05-07-2014, 09:45 AM
MOFSTEEL's Avatar
Krypton Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Chicago Burbs
Posts: 240
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 14995
MOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond repute
Garage
Re: Installation of OEM Camera in 2014 Laredo

Installed the camera last night and headed to the dealer this morning so they can download the option for Parkview Backup Camera.

Unfortunately all I get when I put it in reverse is a blue screen.
Looks like there's a piece of the puzzle still missing.

Next step is to pull the radio and see if there are any connections for the camera that may not be plugged in or are just not included with the harness. I find it hard to believe the option exists in the RA3 but there's no way to retrofit.
__________________
Reply With Quote
  #31  
Old 05-08-2014, 10:24 AM
Premium Member
 
Join Date: Apr 2014
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 139
jaw4322 is a jewel in the rough
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by MOFSTEEL View Post
Installed the camera last night and headed to the dealer this morning so they can download the option for Parkview Backup Camera.

Unfortunately all I get when I put it in reverse is a blue screen.
Looks like there's a piece of the puzzle still missing.

Next step is to pull the radio and see if there are any connections for the camera that may not be plugged in or are just not included with the harness. I find it hard to believe the option exists in the RA3 but there's no way to retrofit.
Mofsteel, did you find any more out?
__________________
Reply With Quote
  #32  
Old 05-08-2014, 07:12 PM
Member
 
Join Date: Oct 2010
Posts: 68
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1450
VANT4GE is on a distinguished road
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by DanPorges View Post
This also may explain why when I first went to order the parts it was like 4 or 5 different pieces and then I was told those were no longer available and it was replaced by a single part number which was all inclusive.
Do you know this single part number?
__________________
Reply With Quote
  #33  
Old 05-09-2014, 09:17 AM
MOFSTEEL's Avatar
Krypton Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Chicago Burbs
Posts: 240
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 14995
MOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond repute
Garage
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by jaw4322 View Post
Mofsteel, did you find any more out?
I haven't had time to pull the radio and doubt ill have time this weekend.
__________________
Reply With Quote
  #34  
Old 05-10-2014, 07:26 AM
mrkonow's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2010
Posts: 103
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1582
mrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond repute
Re: Installation of OEM Camera in 2014 Laredo

I think you are 90% done.

Most likely, we will need to add the 3 pins from the back of the radio with the harness all the way back of the car, to the top connector that goes to the lift gate. This wire will carry the video.

The next step is to find if the pink/yellow wire at the camera's connector is actually getting +12v when ACC is on. If no power already present, we would need to run an ACC 12v lead to it. I was thinking to tap into the trunk's cigarette lighter socket, that is after i tested and find out that it isn't 12v constant.
Then we find out about the ground wire.

Also, MOFSTEEL, how much force applied to separate the 2 parts "epoxied" on the camera bar and how did you approach to start separating? And then, what did you use to glue them back together?
__________________
Reply With Quote
  #35  
Old 05-11-2014, 01:31 PM
MOFSTEEL's Avatar
Krypton Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2014
Location: Chicago Burbs
Posts: 240
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 14995
MOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond reputeMOFSTEEL has a reputation beyond repute
Garage
Re: Installation of OEM Camera in 2014 Laredo

Quote:
Originally Posted by mrkonow View Post
I think you are 90% done.

Most likely, we will need to add the 3 pins from the back of the radio with the harness all the way back of the car, to the top connector that goes to the lift gate. This wire will carry the video.

The next step is to find if the pink/yellow wire at the camera's connector is actually getting +12v when ACC is on. If no power already present, we would need to run an ACC 12v lead to it. I was thinking to tap into the trunk's cigarette lighter socket, that is after i tested and find out that it isn't 12v constant.
Then we find out about the ground wire.

Also, MOFSTEEL, how much force applied to separate the 2 parts "epoxied" on the camera bar and how did you approach to start separating? And then, what did you use to glue them back together?
Start with a tab on one side and work your way across. When your three tabs in you'll need to use a little force to spread the two pieces apart before getting to next tab.

I used 3M emblem and plastic adhesive that I picked up at Autozone. Together with the tabs it made a bond as strong or stronger than OEM.

As far as completing the connection I may wait for your write up. I don't want to start shooting in the dark with electrical components.
__________________
Reply With Quote
  #36  
Old 05-11-2014, 04:54 PM
mrkonow's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2010
Posts: 103
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1582
mrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond reputemrkonow has a reputation beyond repute
Re: Installation of OEM Camera in 2014 Laredo

Thanks. I might do this separation and run the wires to the back of the radio tomorrow. I stopped working on this due to a new project.


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back Up camera installation problem Tony-562 Audio/Visual/Navigation 2 01-21-2014 11:29 AM
2014 Laredo Aftermarket rearview Camera Install 2014 JGC Audio, Video, Navigation & Electronic Modifications 0 01-14-2014 09:50 AM
Possible to Add RearView Camera to 2014 Laredo E? asdad123 Grand Cherokee - WK2 - 35 01-08-2014 07:23 AM
OEM Fog Light Installation question beto4632 Interior/Exterior/Visual 3 10-10-2012 01:22 PM
Backup camera installation and mounting gc4x4 Grand Cherokee - WK 5 05-19-2010 08:19 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community