Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-10-2013, 07:23 PM
Member
My Jeep: 2012 WK2
 
Join Date: Oct 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 303
Markoolero is on a distinguished road
Installed Camera and Back Up sensors but lost UConnect

All,

I have a Grand Cherokee Laredo 4x4 and I wanted to install the Back Up Camera and Sensors in it. Since I don't have the display, the only option I had was to install the rear view mirror that has the monitor in it.

I am not very good with electronics, so I had the Jeep dealership install them (I figured who better to do that that the dealer itself). When I picked it up, there were a few issues with my car. First the push start button didn't work, which they replaced and then it was back to working.

But the biggest pain was that I ended up losing my Uconnect capability. I took the car back about three times for them to try to fix it, and after many hours they ended up telling me that when you install the back up camera and sensors, then you can't use Uconnect anymore. That you either have one or another.

To me this doesn't make much sense, as if you look at the advertised mirror it specifies that if you don't have UConnect in your car, then by adding the mirror you will be adding that capability too.

Anyway, the people at the dealer have been useless about this, so I was wondering if anyone in here has any experience with this or knows any way to fix it.

I would appreciate any help with this.

Thanks!

Mark
__________________

__________________
Reply With Quote
  #2  
Old 10-10-2013, 08:06 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: AZ
Posts: 625
Thanks: 1
Thanked 9 Times in 6 Posts
Rep Power: 1788
eibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond repute
Doesn't sound right, if they knew that in the beginning, they should have disclosed that before the world was done. Why would they even try to fix it if they already knew ahead of time that it's one or the other.
__________________

__________________
Reply With Quote
  #3  
Old 10-10-2013, 08:17 PM
Member
My Jeep: 2012 WK2
 
Join Date: Oct 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 303
Markoolero is on a distinguished road
Re: Installed Camera and Back Up sensors but lost UConnect

Well, apparently they didn't know at the beginning. That's why I had to take it back three times. They ended up talking to someone from Mopar parts I believe and they were the ones that told them that. They said they were looking for a way to fix it, but it's been over 3 months since this and have not heard anything, and I got tired of calling them every week to ask for updates.
__________________
Reply With Quote
  #4  
Old 10-11-2013, 02:06 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Nov 2011
Posts: 336
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1498
Tybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond reputeTybalt39 has a reputation beyond repute
Re: Installed Camera and Back Up sensors but lost UConnect

IIRC, the mic for the UConnect is in the mirror. Are they telling you the mirror with monitor doesn't have the mic built-in? Do you have a link to the mirror they installed, so others can check the specs?
__________________
2012 Overland V6
Deep Cherry Red w/Saddle & Black
OEM Crossbars
Thule Criterium Bike Rack
Reply With Quote
  #5  
Old 10-13-2013, 12:10 AM
Member
My Jeep: 2012 WK2
 
Join Date: Oct 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 303
Markoolero is on a distinguished road
Re: Installed Camera and Back Up sensors but lost UConnect

Rear View Camera System (Includes Monitor) - 82212544 | Mopar
__________________
Reply With Quote
  #6  
Old 10-22-2013, 09:01 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 301
judal98 is on a distinguished road
Re: Installed Camera and Back Up sensors but lost UConnect

Man, sorry to read this, thanks for posting, definitely could have happened to me.

Did you go back to the old mirror? Just curious.

Thanks again
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear parking sensors/camera billyp Trouble Shooting/Problems/Service 22 12-13-2012 01:15 AM
Defective Back-up Sensors? armoredsaint Trouble Shooting/Problems/Service 1 06-21-2012 06:48 PM
Trailer Back-up Camera boldd Audio/Visual/Navigation 3 05-28-2012 01:30 PM
Lost UConnect 7upstang Audio/Visual/Navigation 4 06-26-2011 09:24 AM
Adding back-up sensors? LTrainGC Audio, Video, Navigation & Electronic Modifications 14 12-31-2009 11:51 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community