Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 03-31-2014, 02:14 PM
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: Strongbadia
Posts: 203
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 552
Hayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond repute
Re: JGC Software version 14.05.3

To follow-up on my earlier post, the camera shuttering is worse now than before.

Also, it boots much slower. The screen comes up and takes a while for the XM station info to load . The presets take a few seconds longer. The temperature (inside and outside) show up next. The compass direction can take up to 20-30 seconds to populate. This used to be almost instantaneous with start-up.

Followed the TSB instructions exactly. With engine on. Put the Bus to sleep for at least 20 minutes then started back up and put asleep again for 20 minutes.

New level sucks in my car. Other than the camera issue everything was running fine - now it is not.

Could I have installed something incorrectly or am I missing something?
__________________

__________________
Reply With Quote
  #26  
Old 03-31-2014, 02:21 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 736
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1254
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: JGC Software version 14.05.3

Ok, i checked this.. it doesnt/shouldnt pair until you get in and hit the button. Mine doesnt... I got in and the radio showed JEEP (after it running for 10 minutes) screen loaded, then I saw my phone pair.
__________________

__________________
Reply With Quote
  #27  
Old 03-31-2014, 02:30 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 953
Thanks: 10
Thanked 63 Times in 59 Posts
Rep Power: 1677
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Re: JGC Software version 14.05.3

Quote:
Originally Posted by Hayseed_wk2 View Post
...Put the Bus to sleep for at least 20 minutes then started back up and put asleep again for 20 minutes....Could I have installed something incorrectly or am I missing something?
Doubt this matters but what have you got to lose...don't wait 20 mins, just do as the TSB says, let bus shut down then cycle again. The 20 min cycle you are inserting may be breaking some firmware final confirmation loop in it's brain during the final phase of update. Afterall, it is a required step per TSB for the double bus sleep so this timing may very well matter.

Let us know.
__________________
Reply With Quote
  #28  
Old 03-31-2014, 03:22 PM
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: Strongbadia
Posts: 203
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 552
Hayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond repute
Re: JGC Software version 14.05.3

I installed and did just that (turn off to sleep and then went back in to the finish). Had the issues.

So I re installed and that is when I did the 20min nap. Same results (or I should say no change).
__________________
Reply With Quote
  #29  
Old 03-31-2014, 03:25 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 953
Thanks: 10
Thanked 63 Times in 59 Posts
Rep Power: 1677
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Re: JGC Software version 14.05.3

Quote:
Originally Posted by Hayseed_wk2 View Post
I installed and did just that (turn off to sleep and then went back in to the finish). Had the issues.

So I re installed and that is when I did the 20min nap. Same results (or I should say no change).
Bummer
__________________
Reply With Quote
  #30  
Old 03-31-2014, 09:46 PM
Member
 
Join Date: Mar 2013
Posts: 238
Thanks: 0
Thanked 8 Times in 5 Posts
Rep Power: 935
Briant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond repute
Re: JGC Software version 14.05.3

Did the update - Backup camera has slight jitters after first starting and Shuffle still doesn't work though it worked with the original factory FW.

I did the update following TSB. Then I waited an hour, issues persisted, did a factory reset waited a couple hours and reapplied the update but still have the same issues a day later.
__________________
Reply With Quote
  #31  
Old 04-01-2014, 07:04 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 736
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1254
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: JGC Software version 14.05.3

I only followed one rule...

Got in
shut door
wait for OFF light on start button to go off
Insert USB
Press start button twice (to RUN)
turned off HVAC
waited....
pressed YES for update.
got out and went inside.
Came back out 10 mintues later and it was done.
Turned it off.. pulled usb
Thats it
__________________
Reply With Quote
  #32  
Old 04-01-2014, 08:26 AM
Member
 
Join Date: Feb 2013
Posts: 65
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 679
kirk1233 is on a distinguished road
Re: JGC Software version 14.05.3

That sucks. That issue was fixed for me with the new update... (Camera Jitter)

Quote:
Originally Posted by Hayseed_wk2 View Post
I installed and did just that (turn off to sleep and then went back in to the finish). Had the issues.

So I re installed and that is when I did the 20min nap. Same results (or I should say no change).
__________________
Reply With Quote
  #33  
Old 04-01-2014, 08:39 AM
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: Strongbadia
Posts: 203
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 552
Hayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond repute
Re: JGC Software version 14.05.3

I installed it the two different ways as I described. I know it has taken the update because I can see changes in things. I have noticed that my XM channels have changed their logos - some went to a generic SXM logo.

I did not install it the way StaticFX stated. Would that really make a difference?

Would this have had any change to the transmission or the way it drives? It does seem to drive smoother now.
__________________
Reply With Quote
  #34  
Old 04-01-2014, 11:23 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 953
Thanks: 10
Thanked 63 Times in 59 Posts
Rep Power: 1677
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Re: JGC Software version 14.05.3

Quote:
Originally Posted by StaticFX View Post
I only followed one rule...

Got in
shut door
wait for OFF light on start button to go off
Insert USB
Press start button twice (to RUN)
turned off HVAC
waited....
pressed YES for update.
got out and went inside.
Came back out 10 mintues later and it was done.
Turned it off.. pulled usb
Thats it
It appears either directions work (Uconnect engine not runnning, TSB running) but your steps above fit neither and when dealing with software updating steps can and do matter so I would suggest trying again following TSB or Uconnect to the letter. I made my notes below IN CAPS. In reality though it may not end up mattering since the update is only supposed to offer "Nav display enhancements" over 13.48.3 which doesn't cover your pairing issue. Heck, this update made my Shuffle issue worse. I am thinking of reverting back.

Got in
shut door
wait for OFF light on start button to go off
Insert USB
Press start button twice (to RUN)
turned off HVAC (NOT A STEP BUT SHOULDN'T MATTER)
waited....
pressed YES for update.
got out and went inside. (NOT A STEP AND SINCE THE OPEN/CLOSE OF DOORS IS IMPORTANT AT END I WOULD SUGGEST STAYING IN WITH DOOR CLOSED AND JUST WATCHING
Came back out 10 mintues later and it was done.
Turned it off.. pulled usb (BOTH DIRECTIONS SPECIFICALLY STATE TO PULL USB FIRST THEN TURN OFF, OPEN/CLOSE DOOR LET BUS SLEEP, TURN BACK ON, OPEN/CLOSE DOOR LET BUS SLEEP....YOU ARE NOW DONE
Thats it

I am pretty sure my first two notes are meaningless but quite positive how you ended is an issue. What have you got to lose? Hope it corrects your pairing issue but not real hopeful.
__________________
Reply With Quote
  #35  
Old 04-01-2014, 11:29 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 953
Thanks: 10
Thanked 63 Times in 59 Posts
Rep Power: 1677
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Re: JGC Software version 14.05.3

Quote:
Originally Posted by Hayseed_wk2 View Post
...I did not install it the way StaticFX stated. Would that really make a difference?
So you probably followed the TSB or Uconnect steps? Problem is it appears even if the update takes it may not fix anything and actually may cause some problems....Software

Quote:
Originally Posted by Hayseed_wk2 View Post
..Would this have had any change to the transmission or the way it drives? It does seem to drive smoother now.
Uconnect software if for the radio/nav/multimedia control head's computer. Tranny has it's own computer and separate TSB's for re-flashes so no this update would have no effect on tranny behavior.
__________________
Reply With Quote
  #36  
Old 04-01-2014, 12:30 PM
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: Strongbadia
Posts: 203
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 552
Hayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond reputeHayseed_wk2 has a reputation beyond repute
Re: JGC Software version 14.05.3

Thanks 14HS. I followed the TSB directions exactly. Did it twice - the only difference was the amount of time I let the car sleep.

The update took a step backwards on some of the features.

If I wanted to go back to the previous version, how do I revert back?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RER Software update to version 2.4 Navy1 Audio/Visual/Navigation 25 02-20-2014 03:18 AM
NEW software application version MyGIG RHR-RHP-RHW / 2.169 *sox* Audio/Visual/Navigation 311 11-15-2013 01:05 PM
What version of Application Software did your RHR 730N come with? Corp Cog Audio/Visual/Navigation 33 06-05-2013 02:15 PM
Software Update MyGIG RHR-RHW-RHP Units / Version 2.126 dabl Audio, Video, Navigation & Electronic Modifications 11 12-30-2012 09:40 PM
1. Software Update MyGIG RHR-RHW-RHP Units / Version 2.120 *sox* Audio, Video, Navigation & Electronic Modifications 136 11-27-2012 09:44 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.