Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #121  
Old 02-09-2013, 08:08 PM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

My radio is bricked. I installed the radio update just fine. Installing the nav update is what bricked it. I followed the directions and did just exactly as mentioned. The nav update says you can turn the Jeep off and the update would start where it left off once the Jeep was started again. Wrong. I turned the Jeep off and left the Accy on since the update was about 4/5 finished. We went to leave this afternoon and the display is now stuck on the Jeep startup screen with the logo and Uconnect logo beneath it. Not sure what to do now. The radio is not responsive to key presses but it sounds like something is running like a hard drive. Not sure what to do.

Any ideas?
__________________

__________________
Reply With Quote
  #122  
Old 02-09-2013, 08:15 PM
Milous's Avatar
Senior Member


 
Join Date: Nov 2009
Location: Nottsure, Wair
Posts: 6,452
Thanks: 33
Thanked 2,172 Times in 929 Posts
Rep Power: 2392447
Milous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond repute
Re: Just got my free 2013 Map and software updates 2.126

Try pulling the M12 fuse (underhood) for a minute or two... http://www.wk2jeeps.com/misc/Fuses_2011_2013_wk.pdf
__________________

__________________
Reply With Quote
  #123  
Old 02-09-2013, 08:49 PM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

Quote:
Originally Posted by Milous View Post
Try pulling the M12 fuse (underhood) for a minute or two... http://www.wk2jeeps.com/misc/Fuses_2011_2013_wk.pdf
Is this basically what the dealership would do? Also what should I expect to happen once I pull it. Will the radio be working again so I will have to do the nav update again? I dont want to mess anything up since its still under warranty.
__________________
Reply With Quote
  #124  
Old 02-09-2013, 09:55 PM
Member
 
Join Date: May 2012
Posts: 582
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 15598
DirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond repute
Re: Just got my free 2013 Map and software updates 2.126

If you have the push button start in, pop that out and cycle the car on and off with the key.

I had to interrupt my install several times and got a bit worried that I had bricked it. But after a couple more cycles with the key, the update continued and completed with no problem.
__________________
2012 Stone White Overland Hemi ~ Altitude grill and brow ~ SRT8 reps ~ Falken Rocky Mountain ATS ~ Mopar pedals ~ SRT8 side lettering ~ 20% tint all around ~ Volant CAI ~ HF Tune
Reply With Quote
  #125  
Old 02-10-2013, 12:49 AM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

Quote:
Originally Posted by DirtyDuc83 View Post
If you have the push button start in, pop that out and cycle the car on and off with the key.

I had to interrupt my install several times and got a bit worried that I had bricked it. But after a couple more cycles with the key, the update continued and completed with no problem.
Yes, I have the push button start in right now. When doing this did the radio go back to the install progress screen after you cycled it with the key in the ignition? Im guessing you had the Jeep screen just like I do now... ?
__________________
Reply With Quote
  #126  
Old 02-10-2013, 01:18 AM
Member
 
Join Date: May 2012
Posts: 582
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 15598
DirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond repute
Re: Just got my free 2013 Map and software updates 2.126

Quote:
Originally Posted by ARK27 View Post
Yes, I have the push button start in right now. When doing this did the radio go back to the install progress screen after you cycled it with the key in the ignition? Im guessing you had the Jeep screen just like I do now... ?
Yes, that is correct. I cycled through acc, on etc...and after a few tries it would resume. I actually interrupted it a few times and it did continue each time.
__________________
2012 Stone White Overland Hemi ~ Altitude grill and brow ~ SRT8 reps ~ Falken Rocky Mountain ATS ~ Mopar pedals ~ SRT8 side lettering ~ 20% tint all around ~ Volant CAI ~ HF Tune
Reply With Quote
  #127  
Old 02-10-2013, 10:19 AM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

I took the start button out and started it with the fob in the ignition. The radio came up and said the update is resuming with the progress bars but they were empty. I turned the key the rest of the way to start the car and the radio then went to the regular radio screen and said Navigation being activated... Thats where it is now. No radio working however. Im going to check it again here in a minute.
__________________
Reply With Quote
  #128  
Old 02-10-2013, 10:34 AM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

It stayed on the radio and then nav screen and said nav was updating. I turned it off and back on and now it's updating itself again. Though it appears to be starting over from zero as the total update progress bar is empty again. Yesterday it was 4/5 of the way through.
__________________
Reply With Quote
  #129  
Old 02-10-2013, 10:57 AM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

Progress seems to be moving much faster now. It's almost 75% complete. I'm hoping it will finish soon as the wife wants to see LeMis in 45 minutes. Ugh.. :-(
__________________
Reply With Quote
  #130  
Old 02-10-2013, 02:41 PM
Member
 
Join Date: Feb 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
ARK27 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

It appears to have worked. Thanks for the advice as you saved me a trip to the dealership!
__________________
Reply With Quote
  #131  
Old 02-10-2013, 04:11 PM
Member
 
Join Date: May 2012
Posts: 582
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 15598
DirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond reputeDirtyDuc83 has a reputation beyond repute
Re: Just got my free 2013 Map and software updates 2.126

Quote:
Originally Posted by ARK27 View Post
It appears to have worked. Thanks for the advice as you saved me a trip to the dealership!
You bet, glad to have been able to help.
__________________
2012 Stone White Overland Hemi ~ Altitude grill and brow ~ SRT8 reps ~ Falken Rocky Mountain ATS ~ Mopar pedals ~ SRT8 side lettering ~ 20% tint all around ~ Volant CAI ~ HF Tune
Reply With Quote
  #132  
Old 06-04-2013, 06:57 PM
New Member
 
Join Date: Jun 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mark55 is on a distinguished road
Re: Just got my free 2013 Map and software updates 2.126

I have noted that many people are having trouble with the address book clearing itself on the 730N RHR Stereo used in many Dodge/Jeep vehicles. I have had mine back to the shop twice with no positive results and generated a email directly to Dodge. Their response was pathetic, didn't care and said it wasn't their problem, albeit on a $47,000 vehicle. Does anyone know the fix or is it time for a class action?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New MyGIG Software Application RHR-RHW-RHP 2.126 *sox* Audio/Visual/Navigation 79 05-15-2014 02:31 AM
Software Update MyGIG RHR-RHW-RHP Units / Version 2.126 dabl Audio, Video, Navigation & Electronic Modifications 11 12-30-2012 09:40 PM
430 RHB Map Updates Mashie Audio/Visual/Navigation 10 06-05-2012 03:24 PM
730RHR Map Updates?? How To? Dougcjohn Audio/Visual/Navigation 19 05-18-2011 12:37 AM
730RHR Map Updates?? How To? Dougcjohn Audio/Video/Navigation/Alarms 19 05-18-2011 12:37 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community