Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 04-12-2013, 04:04 PM
subbie09's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Posts: 590
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 3513
subbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond repute
Interesting. Either I have a bad ground or bad RCA cables. Good thing I'm installing a stealthbox soon to check it all once it's apart.
__________________

__________________
Reply With Quote
  #38  
Old 04-12-2013, 08:33 PM
Member
 
Join Date: Jun 2012
Posts: 97
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 937
leks66 is on a distinguished road
Quote:
Originally Posted by subbie09 View Post
Interesting. Either I have a bad ground or bad RCA cables. Good thing I'm installing a stealthbox soon to check it all once it's apart.
Just gone done playing around with it for a bit. My amp has a 2 ch, 4 ch, and 6 ch switch. When its on 2 ch I get a full signal. 4 and 6 sounds very bright and no mid range, very weird. After the adjustments I was able to turn the gains up on the amp and now yes I do have white noise. I'm thinking this Lc7i isn't all that its cracked up to be. Never used a LOC before, always swapped out headunits to get clear outputs. I think that's what I'll be saving up for next....
__________________

__________________
Reply With Quote
  #39  
Old 04-12-2013, 10:16 PM
subbie09's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Posts: 590
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 3513
subbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond repute
Same as me. The white noise isn't bad, at low volume. The volume I listen to music at cant even tell its there, just a nice crisp sound. But yes, in the future a headunit will happen, something than can be wired to the stock amp to support the rear surrounds and dash speaker, but something with outputs to the PDX v9 for the aftermarkets.
__________________
Reply With Quote
  #40  
Old 04-12-2013, 10:18 PM
subbie09's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Posts: 590
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 3513
subbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond repute
I might play with the gains of the lc7i when I get a chance and see if that helps.
__________________
Reply With Quote
  #41  
Old 04-14-2013, 02:05 PM
Premium Member
 
Join Date: Jun 2010
Posts: 132
Thanks: 0
Thanked 8 Times in 7 Posts
Rep Power: 2393
voyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond reputevoyagerx has a reputation beyond repute
I have the 3sixty.3 and also have a hissing noise only heard when the audio isn't loud. Easiest way to hear it is to put a cable in the 3.5mm Aux jack on the head unit with nothing on the other end. The hiss doesn't get any louder regardless of the volume being on 1 or 20, but it's always there, it just gets drowned out by the music. I did use the AUX jack directly on the 3sixty.3 to see if the hiss was still there and if I had a grounding issue, but it wasn't. My guess is that the factory Amp is putting out the hiss at the high impedance the LOC/processors work at.

Sent from my HTC One X using Tapatalk 2
__________________
Reply With Quote
  #42  
Old 04-14-2013, 06:20 PM
Member
 
Join Date: Jun 2012
Posts: 97
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 937
leks66 is on a distinguished road
Quote:
Originally Posted by voyagerx View Post
I have the 3sixty.3 and also have a hissing noise only heard when the audio isn't loud. Easiest way to hear it is to put a cable in the 3.5mm Aux jack on the head unit with nothing on the other end. The hiss doesn't get any louder regardless of the volume being on 1 or 20, but it's always there, it just gets drowned out by the music. I did use the AUX jack directly on the 3sixty.3 to see if the hiss was still there and if I had a grounding issue, but it wasn't. My guess is that the factory Amp is putting out the hiss at the high impedance the LOC/processors work at.

Sent from my HTC One X using Tapatalk 2
Exactly what mine sounds like right now. Spent some time tuning everything and the speakers sound good. I just hate the white noise. Was trying not to but I will be swapping out the head unit soon. Anybody wanna buy a like new Lc7i?....
__________________
Reply With Quote
  #43  
Old 04-14-2013, 08:13 PM
subbie09's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Posts: 590
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 3513
subbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond repute
Eh don't do it yet. The white noise is only at really low volume. How often do you listen to music at the really low volume?
__________________
Reply With Quote
  #44  
Old 04-15-2013, 01:19 AM
Member
 
Join Date: Jun 2012
Posts: 97
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 937
leks66 is on a distinguished road
Quote:
Originally Posted by subbie09 View Post
Eh don't do it yet. The white noise is only at really low volume. How often do you listen to music at the really low volume?
The problem is I need to keep my amp gains way down to keep the noise from bothering me, also depletes the whole purpose of me installing an amp and speakers. It also make me wonder how much cleaner my setup would sound with proper signals. I went this far no sense stop now. LoL
__________________
Reply With Quote
  #45  
Old 04-15-2013, 07:28 AM
subbie09's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Posts: 590
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 3513
subbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond reputesubbie09 has a reputation beyond repute
Re: Just ordered

Quote:
Originally Posted by leks66 View Post
The problem is I need to keep my amp gains way down to keep the noise from bothering me, also depletes the whole purpose of me installing an amp and speakers. It also make me wonder how much cleaner my setup would sound with proper signals. I went this far no sense stop now. LoL
Bwhahaha. Well if you do upgrade the headunit, please post pictures, and supplies( IE adapters) needed to connect to steering wheel and stock amp in the WK2 as I will be doing this also in the near future. But first I need the stealthbox. lol
__________________
Reply With Quote
  #46  
Old 04-15-2013, 11:08 AM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Nov 2012
Location: Long Island, NY
Posts: 40
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2386
Raj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond reputeRaj06MT has a reputation beyond repute
Re: Just ordered

Quote:
Originally Posted by subbie09 View Post
Bwhahaha. Well if you do upgrade the headunit, please post pictures, and supplies( IE adapters) needed to connect to steering wheel and stock amp in the WK2 as I will be doing this also in the near future. But first I need the stealthbox. lol
For a list of adapters which I used, please see my posts in the following thread:

Jeep backup camera w/aftermarket headunit?
__________________
Reply With Quote
  #47  
Old 04-15-2013, 05:05 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,372
Thanks: 97
Thanked 28 Times in 26 Posts
Rep Power: 11243
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Just ordered

Guys, for adapters and all that, check out my thread: Spring A/V upgrade project
__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
  #48  
Old 04-15-2013, 09:54 PM
Member
 
Join Date: Jan 2013
Posts: 164
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 791
Jrunr is on a distinguished road
Re: Just ordered

Does everyone have the hiss problem when hooking up a LC7i and Amp?
__________________

__________________
2014 Jeep Grand Cherokee Overland
3.6L V6 Brilliant Black with Black Interior
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just Ordered chance Grand Cherokee - WK 8 08-19-2011 04:22 PM
just ordered it jdcollins86 Off Road Modifications 20 03-21-2011 11:57 PM
Ordered!!!! ibleedoil Grand Cherokee - WK2 - 18 03-04-2011 02:13 PM
Just ordered ! ! ! yukon Grand Cherokee - WK2 - 32 09-22-2010 10:48 AM
I ordered! JoeSchmoe007 Grand Cherokee - WK2 - 27 09-21-2010 01:18 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community