Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-09-2013, 10:33 AM
Member
 
Join Date: Apr 2013
Posts: 72
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 756
nj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond repute
my newest issue - NAV screen goes white

So this weekend I took a drive up to Binghamton and as I was approaching my exit, the screen turned white, the audio prompts were still working...but nothing on the screen. I also noticed that my bluetooth connection was still connected to my phone but an incoming call would not work properly, the call would connect but the audio would not transfer to the uconnect.

I have 13.19.0

__________________

__________________
Reply With Quote
  #2  
Old 10-09-2013, 10:35 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,171
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801657
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: my newest issue - NAV screen goes white

I clicked on video and got;

"If the owner of this video has granted you access, please log in."


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 10-09-2013, 10:38 AM
Member
 
Join Date: Apr 2013
Posts: 72
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 756
nj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond repute
Re: my newest issue - NAV screen goes white

try now, had to change the setting...
__________________
Reply With Quote
  #4  
Old 10-09-2013, 10:43 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,171
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801657
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: my newest issue - NAV screen goes white

Video works.

Sorry I can't give you any advice on the screen.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #5  
Old 10-09-2013, 11:04 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 719
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1198
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: my newest issue - NAV screen goes white

try updating to the newest 13.38.52?
__________________
Reply With Quote
  #6  
Old 10-09-2013, 11:07 AM
Member
 
Join Date: Apr 2013
Posts: 72
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 756
nj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond reputenj newb has a reputation beyond repute
Re: my newest issue - NAV screen goes white

with my next oil change.

was just curious if anyone else encountered this awesome easter egg...where the screen goes blank as it is guiding you off of a highway. Also blinding you while doing it as it turns as bright as possible.

Quote:
Originally Posted by StaticFX View Post
try updating to the newest 13.38.52?
__________________
Reply With Quote
  #7  
Old 10-09-2013, 01:50 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 719
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1198
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: my newest issue - NAV screen goes white

Quote:
Originally Posted by nj newb View Post
with my next oil change.

was just curious if anyone else encountered this awesome easter egg...where the screen goes blank as it is guiding you off of a highway. Also blinding you while doing it as it turns as bright as possible.

i think this needs to be pushed up the line. if your screen is blanking out, my guess is you have a bad unit and need it replaced. You can do the update yourself, its easy and only takes like 20 minutes. then if it still happens, your dealer can talk to chrysler about a new one
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why No TILT Function on NAV Screen?! Snipe315 Audio/Visual/Navigation 1 05-28-2013 05:01 PM
Does 2014 nav map display more street names on the screen than the 2011 GC nav map? Sudin36 Audio/Visual/Navigation 3 05-01-2013 09:41 PM
New Nav Screen Dotcom Grand Cherokee SRT - WK2 1 12-23-2012 09:17 AM
How to clean nav screen dtraf Detailing 9 10-31-2011 01:19 PM
Nav screen does not power on johnm524 Grand Cherokee - WK 11 10-26-2010 09:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community