Navigation is Buggy After Update - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-01-2016, 10:15 PM
Member
My Jeep: 2016 3.6L WK2
 
Join Date: May 2016
Posts: 88
Thanks: 47
Thanked 15 Times in 12 Posts
Rep Power: 297
el_vago32 is on a distinguished road
Question Navigation is Buggy After Update

Hello guys. I've noticed that ever since I updated my UConnect system some navigation functions are kinda buggy. For example, when I use Send'n Go I do get the notification on the display that a new address has been received, and if I want to start navigating. I click on YES, but it does nothing. Another problem is that I use VR to get directions to HOME (which address, I triple checked, is stored on my system). The navigation system is then fired up but it asks me to enter my Home address; again, even though the address is saved. It used to work flawlessly before. In fact, I used to say "take me home" and it worked, now the only phrase that seems to work is "give me directions to home" or something along those lines.

Has any of you experienced something similar? Is there a quick fix for this? I'm thinking there may be a "factory reset" sort of thing for the navigation system. Perhaps re-flashing the update fixes this?

Thanks in advance for your help.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-02-2016, 02:41 AM
Member
 
Join Date: Nov 2013
Posts: 70
Thanks: 0
Thanked 11 Times in 4 Posts
Rep Power: 11651
mwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond reputemwiseman has a reputation beyond repute
Re: Navigation is Buggy After Update

Yes, not just navigation. Radio and Media are totally flakey.
Reply With Quote
  #3  
Old 06-02-2016, 03:48 PM
Member
My Jeep: 2016 3.6L WK2
 
Join Date: May 2016
Posts: 88
Thanks: 47
Thanked 15 Times in 12 Posts
Rep Power: 297
el_vago32 is on a distinguished road
Re: Navigation is Buggy After Update

Well, I decided to re-flash it today and everything seems to be working fine now. I'll report back if it breaks again.
Reply With Quote
Reply

Tags
update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
uConnect 15.26.1 is buggy; I want to downgrade. Roadkill Audio/Visual/Navigation 256 11-26-2016 12:24 AM
Oil life algorithm still buggy Roadkill 2014+ Jeep Grand Cherokee Ecodiesel 3.0 7 01-19-2015 09:33 PM
The Buggy :: 2012 Jeep Grand Cherokee SRT8 Challenger15 Member Garage Discussions 0 01-04-2013 08:48 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.