Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-03-2011, 09:49 PM
Member
 
Join Date: Apr 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1211
CowTown is on a distinguished road
Question Need Help with IPOD-What Am I Missing?

I recently got my WK2 Limited with the 730N media system. I'm having trouble with IPOD playback. I do not have the center console IPOD interface connector as some earlier WK2 versions did. I have the 2nd USB port in the upper arm rest compartment, as well as the USB and Aux. Jack ports on the unit. I figured with the center console connector now gone I could get playback via one of the USB ports, but it's not working that way. My dealer says it should work with the cord that came with the IPOD for charging but when it's playing and plugged in, it's not being recognized.

I am trying to access it via the touch screen AUX tab. In this tab is the DEVICES button, which only shows my Blackberry connection as active, nothing for the USB. I also saw in the CD manual that IPOD playback may not supported by USB and the "IPOD CONNECTOR" must be used, but it does not go into any detail about that.

I'm sure I'm missing something really simple here so if you can tell me how to approach and fix this would appreciate it. Want to avoid a service call so soon and probably not needed. Thanks.
__________________

__________________
Reply With Quote
  #2  
Old 08-03-2011, 10:30 PM
Sammzway's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Mar 2011
Location: BayShore NY
Posts: 179
Thanks: 6
Thanked 3 Times in 1 Post
Rep Power: 1398
Sammzway is on a distinguished road
Re: Need Help with IPOD-What Am I Missing?

Perhaps you're missing the IPOD itself? Just kidding. Someone will help you out.
__________________

__________________
2012 Volkswagen CC Lux - Night blue (my daily)
2011 JGC WK2 - Blackberry Pearl (wife's daily)
Reply With Quote
  #3  
Old 08-04-2011, 05:52 AM
ColdCase's Avatar
Senior Member
 
Join Date: Apr 2011
Posts: 1,445
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 26410
ColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond reputeColdCase has a reputation beyond repute
Re: Need Help with IPOD-What Am I Missing?

I have the same radio, and it works somewhat. There is much disussion in the audio/visual forum above.

There seems to be more issues when both a phone and iPOD are being used.

With my iPOD touch or Nano, I select the play list I want to listen to and start play before connecting it to the center armrest USB port. The iPOD will beep. It takes anywhere from one to 60 seconds for the radio to reconize the iPOD. Then it will start playing automatically or, if not, you go to the AUX device screen and select it. If the iPOD is not listed there, then there is a connection problem somewhere.... which iPod are you trying to connect?

The radio never seems to remember that you were listening to the iPOD, so after returning to the car and starting up, you will typically have to go to the devices screen to re-select it (you may have to wait 30 seconds for the iPOD to show up). Without a phone it seems to work much more smoothly.

Just one of many quirks of the 730N radio. For the money, you would think they would have it better sorted out.

The uconnect module is built in to the newer 730N, so you only get the center armrest USB port.
__________________
Reply With Quote
  #4  
Old 08-04-2011, 08:18 AM
Member
 
Join Date: Mar 2011
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1259
olamaca is on a distinguished road
Re: Need Help with IPOD-What Am I Missing?

This problem is similar to why some people have problem pairing their iPhone or other smartphone with bluetooth. I.e. not all iPod generation works with uconnect or the radio. In addition, even if someone's iPod works and you have the same iPod model, it doesn't mean your iPod's software version is the same. Remember you have car not a computer. You can't just upgrade your car's software to match your iPod. Even if you do bring it to your dealer to complain, 9 out of 10 times they will tell you the car is fine and the problem is your device.

I have the 1st generation iPod, an iTouch, a 3G iPhone and an iPhone 4 and the iTouch doesn't work.

BTW, I agree with the comment regarding uconnect not remembering that when you were listening to an iPod device before you turned off your car. However, I've driven a BMW and Audi, and they both have many quirky things that would drive you mad if you let it. Just saying that these two brands are head and shoulders above Chrysler and Jeep and expectations for them to produce better and you would think logical design would be better but you'd be surprised.
__________________
Reply With Quote
  #5  
Old 08-05-2011, 11:57 AM
Member
 
Join Date: Apr 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1211
CowTown is on a distinguished road
Cool Re: Need Help with IPOD-What Am I Missing?

Thanks for the feedbacks. Learned a couple things along the way. Even though you may have two USB ports, one in the armrest and one on the 430/730 itself, only the armrest port can be used for IPOD playback. The media center USB is only for flashdrives. Seems like the USBs should be interchangable but it looks like not. One thing that came up is my IPOD software may not be compatible with my 730, so was suggested I log into Apple and update. I haven't tried this yet but it may help if you're having similar problems with an older device.

Long and short of it, I just skipped the IPOD route and copied my Mp3s to a flashdrive, stuck it in the 730 USB and copied them onto the HDD. It was quick, worked just fine, and serves the same purpose as trying to use an IPOD. May be the better and less frustrating way to go.
__________________
Reply With Quote
  #6  
Old 08-06-2011, 02:02 PM
Technosavant's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2010
Location: STL, MO area
Posts: 1,282
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 2829
Technosavant has a reputation beyond reputeTechnosavant has a reputation beyond reputeTechnosavant has a reputation beyond reputeTechnosavant has a reputation beyond repute
Re: Need Help with IPOD-What Am I Missing?

Quote:
Originally Posted by CowTown View Post
Long and short of it, I just skipped the IPOD route and copied my Mp3s to a flashdrive, stuck it in the 730 USB and copied them onto the HDD. It was quick, worked just fine, and serves the same purpose as trying to use an IPOD. May be the better and less frustrating way to go.
IMO, it works, but it isn't better. The playlist handling on the internal HDD is horrible (at least with the RER, guessing it didn't change with the RHR). It works best with smaller playlists... if you're prone to 200 song playlists on your iPod, loading that onto the internal drive is painful, and God help you if you want to add songs to it; you get to recopy the entire thing.

Generally, I view the internal HD as a useful backup to an actual MP3 player. If I had to do without the iPod, I could make it work, but it's troublesome.

IMO, Apple needs to do a better job with testing their software updates and the vehicle manufacturers need to do a better job of keeping things updated. If the vehicle manufacturers don't plan to do that, I'd just as soon they keep it nice and easy to swap out the OEM unit with an aftermarket unit; at least those makers understand that they need to keep customers happy.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Am I missing something? 7upstang Grand Cherokee - WK2 - 2 03-02-2011 02:18 PM
Am I missing something? PMD G8 Grand Cherokee - WK2 - 2 01-30-2011 04:44 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community