Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-29-2014, 04:34 PM
mxmumtuna's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Location: Ashburn, VA
Posts: 25
Thanks: 5
Thanked 2 Times in 2 Posts
Rep Power: 179
mxmumtuna is on a distinguished road
No audio from radio on drivers side

Strange problem that seemed to happen out of nowhere on my 2014 Summit with HK audio.. I turned up the volume of the radio and it was only playing out of the passenger side speakers. I checked the balance and it's set correctly. When I adjust the balance to full to drivers side, no sound at all other than bass from the rear sub. Nav audio plays out of the driver side front speaker as expected, but no radio sources.

Any thoughts? Seems very strange.
__________________

__________________
2014 Summit | EcoDiesel | Deep Auburn Pearl/GC Brown
Reply With Quote
  #2  
Old 03-29-2014, 06:38 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,046
Thanks: 206
Thanked 145 Times in 118 Posts
Rep Power: 89260
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: No audio from radio on drivers side

My guess would be a loose wire from the amp. Take it to the dealer.
__________________

__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
The Following User Says Thank You to jacko15 For This Useful Post:
  #3  
Old 03-29-2014, 07:03 PM
mxmumtuna's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Location: Ashburn, VA
Posts: 25
Thanks: 5
Thanked 2 Times in 2 Posts
Rep Power: 179
mxmumtuna is on a distinguished road
Re: No audio from radio on drivers side

I thought that too. Where is the amp?
__________________
2014 Summit | EcoDiesel | Deep Auburn Pearl/GC Brown
Reply With Quote
  #4  
Old 03-29-2014, 09:41 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,046
Thanks: 206
Thanked 145 Times in 118 Posts
Rep Power: 89260
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: No audio from radio on drivers side

Behind the left quarter trim panel.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
The Following User Says Thank You to jacko15 For This Useful Post:
  #5  
Old 04-01-2014, 01:01 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2011
Location: Olathe, KS
Posts: 920
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 3534
kkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond repute
Re: No audio from radio on drivers side

I'm guessing left side of amp is toast. Either way, you are under warranty.
__________________
2011 Laredo X in White Gold: QT1, V6, Tow Package, Sunroof, Mopar Step Bars/Slush Mats, 20% Tint, Airaid Intake.
Reply With Quote
  #6  
Old 04-01-2014, 01:09 PM
mxmumtuna's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Location: Ashburn, VA
Posts: 25
Thanks: 5
Thanked 2 Times in 2 Posts
Rep Power: 179
mxmumtuna is on a distinguished road
Re: No audio from radio on drivers side

so here's an odd one.. I found the amp last night (thanks jacko15), no loose connections and fiddling with it didn't bring the driver side audio back. Today while driving around with my wife, audio all the sudden came back on the driver side. We'll see if it lasts. Hopefully this isn't an intermittent problem, or else it may be hard to get the dealer to do anything about it.
__________________

__________________
2014 Summit | EcoDiesel | Deep Auburn Pearl/GC Brown
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold air drivers side, warm air passenger side canis Grand Cherokee - WK 3 05-31-2011 09:30 AM
Side View Mirror - Drivers Side DaMitsuMan Troubleshooting/Problems 7 05-30-2010 03:09 PM
Problem with Front Drivers Side Brakes Robert Palmer Troubleshooting/Problems Discussion 11 08-10-2009 06:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community