Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-26-2012, 08:37 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2012
Location: Severna Park MD
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 739
JonF is on a distinguished road
No sound from radio

For the second time in 1000 miles I started my 2012 Laredo and had no sound from my radio. It is am fm single cd with sirius. Dont have the option code because im at work right now. I can turn it on and off and change stations but there is no sound and no response from the steering wheel volume control or the radio knob. Anyone know the cure for this? I work 6-7 days a week so gettting to the dealer is a hassle and i want to make sure it is fixed right the first time.
__________________

__________________
Reply With Quote
  #2  
Old 08-26-2012, 08:40 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Apr 2011
Location: Ottawa, Ontario
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 72544
bdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond reputebdesmp has a reputation beyond repute
Re: No sound from radio

You might have to go to Sirius on-line and force a reboot/re-initialize for your unit. That happened to me once and that's what I had to do.
__________________

__________________
Reply With Quote
  #3  
Old 08-26-2012, 02:26 PM
Member
 
Join Date: Aug 2012
Posts: 39
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 727
MattE is on a distinguished road
Re: No sound from radio

I had a Pioneer Nav unit do this with the Sirius. I played around with everything. Thinking back, I went in to the "game alert" section and hit something in there and for some reason it re-booted / started working again. I hope this helps....but it may not. My Pioneer did the no sound thing twice.
__________________
Reply With Quote
  #4  
Old 08-26-2012, 08:38 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2012
Location: Severna Park MD
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 739
JonF is on a distinguished road
Re: No sound from radio

It was working normally when I left work. I shut off and restarted the vehicle 3 times on the way to work and it made no difference. Just like the first time it happened. The last time I stopped and went into a convenience store and when I restarted it after sitting about 5 minutes it was working again.

I'm wondering if its a radio problem or maybe some other computer problem, like something is not "waking up" when I start the vehicle.

I'll try rebooting tomorrow after work. It was storming when I got home today.
__________________
Reply With Quote
  #5  
Old 08-27-2012, 09:26 PM
plynn7's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2010
Location: Delaware County,PA
Posts: 353
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1868
plynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond repute
Re: No sound from radio

I had this same problem in 08 JGC. It would happen every few weeks, where I would start the Jeep and no sound, I would have to shut down the Jeep and wait a several minutes for the system to reset and then the sound would come back. I took in and the dealer applied a software update and fixed the issue, didn't happen again for the following two years I owned it. This was on a RER radio.
__________________
2014 Deep Cherry Red Overland V6 Tech Package
Previous Jeeps:
11 GC Overland V6
08 GC Limited Hemi
04 GC Larado V6
Reply With Quote
  #6  
Old 09-06-2012, 12:00 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2012
Location: Severna Park MD
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 739
JonF is on a distinguished road
Re: No sound from radio

I went to the dealer today. Of course the radio was working. They said the jeep had the latest software and there was no info stored for any faults. They could not duplicate it. I went to leave and there was no sound so they took it in. He said the problem is in the radio and ordered one. I'm guessing this will be a repaired unit... kind of sucks since the jeep is only a month old. But since then I have no sound and I have run some errands and stopped for several minutes and restarted it a few times. Still no sound. Normally the sound would come back after sitting a bit then restarting. I just logged into sirius and sent a "refresh" signal. I'm going to go back out and see if there's any change. I'm going camping this weekend and it would be nice to have a radio on the 2 1/2 hour drive.
__________________
Reply With Quote
  #7  
Old 09-07-2012, 01:38 PM
Member
 
Join Date: Jul 2012
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 751
doberman is on a distinguished road
Re: No sound from radio

I had a similar issue.

My '11 satellite radio randomly stopped having audio. I could see who the artist and song was, but no sound...

Tried having Sirius re-send the activation signal, no dice.

Tried having the dealer re-set the stereo, no dice.

Dealer ended up replacing the whole thing under warranty.
__________________
Reply With Quote
  #8  
Old 09-20-2012, 09:02 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2012
Location: Severna Park MD
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 739
JonF is on a distinguished road
Re: No sound from radio

Its been 2 weeks since I went to the dealer. They said it would take 7-10 working days for my radio to come in. Today was day 10 and I had not heard from them so I called. The radio was never ordered because they either had the wrong ESN or did not have it. But the day I went to the dealer I tried to set up a Sirius account to try a reboot but had to call them because they had all my info wrong at Sirius from the selling dealer. Its been 2 weeks now with a brand new vehicle and no radio. Now it's going to be another week or so. Bull*%#^! What ever happened to doing a good job?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 din radio replace REJ radio Silvano Audio, Video, Navigation & Electronic Modifications 1 04-14-2012 03:05 AM
Rhb radio 430n without sat radio?? GTREVINOWK2 Audio/Visual/Navigation 6 02-19-2012 05:30 PM
2008 WK REQ Radio Issues - No Sound at times scottmarion Troubleshooting/Problems 6 04-08-2010 03:26 PM
adding satellite radio and ipod/aux to RAQ radio fasteddy001 Audio, Video, Navigation & Electronic Modifications 3 02-20-2010 02:43 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community