Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-06-2013, 03:48 PM
Member
 
Join Date: Jan 2010
Location: Nyack NY
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1766
NebularMan is on a distinguished road
Samsung Galaxy S4 Uconnect

I just bought a 2011 JGCL and have hooked my phone to uconnect and am only able to get phone commands working. Dooes anyone have the S4 steaming audio working?
__________________

Reply With Quote
  #2  
Old 08-06-2013, 03:53 PM
bumpinjeep's Avatar
Member
 
Join Date: Jul 2013
Posts: 152
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 624
bumpinjeep is on a distinguished road
Re: Samsung Galaxy S4 Uconnect

Yes, granted I have a 2014 but I do have my S4 and it works flawlessly. What exactly are you trying to do and have you synced your phone to your car via blutooth? Once you sync the phone with the Jeep, you should be good to go.
__________________

__________________
2014 Grand Cherokee LTD
1997 Grand Cherokee Laredo - Lifted, ARB'd, Mud Terrains, ETC
2007 Nissan 350Z - Volks TAs, coilovers, carbon fiber kitted, yada yada yada
Reply With Quote
  #3  
Old 08-08-2013, 09:07 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 236
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 1029
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by bumpinjeep View Post
Yes, granted I have a 2014 but I do have my S4 and it works flawlessly. What exactly are you trying to do and have you synced your phone to your car via blutooth? Once you sync the phone with the Jeep, you should be good to go.
My S4 in my 14 also works. If I use remote and start car remotely and the radio is left on a Sirrius station, once I enter the car and the S4 having already been paired switches my RA4 radio to media .
Launch Yelp also works on VR but very poor choices. I was hoping to use it to save my destinations addresses to NAV and save some time. BTW the S4 also downloaded the lock, Unlock, horn, start, Cancel app from moparownerconnect.com
__________________
Reply With Quote
  #4  
Old 08-08-2013, 09:30 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1245
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

no.. the streaming was terrible in my 2011 (iPhone 4s) it would play, but at double speed and skipping. And USB was no better. Your best bet is to just load up the HD with music. (There might be a SW update for the radio though.. check around)
__________________
Reply With Quote
  #5  
Old 08-09-2013, 09:23 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 236
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 1029
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by StaticFX View Post
no.. the streaming was terrible in my 2011 (iPhone 4s) it would play, but at double speed and skipping. And USB was no better. Your best bet is to just load up the HD with music. (There might be a SW update for the radio though.. check around)
I am not sure what is happening. Since I can not get a signal for my S4 in my home, I set it up to use WiFi preferred but when I called some one with my S4 over Uconnect in the ride, although I could hear them clearly, they could not really hear me and static. I am unsure if I was on WiFi or the carrier network at the time but I was on a rural road. I looked on the apps menu and noticed that in addition to yelp tere was also WIFI listed. I was under the impression that the Uconnect WIFI was a pay extra service from Uconnect unless they are including it free for a while like the Sirrius radio. What say you? BTW at times the Sirrius radio cut out momentarily on the rural road.
__________________
Reply With Quote
  #6  
Old 08-09-2013, 09:29 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927088
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by NebularMan View Post
I just bought a 2011 JGCL and have hooked my phone to uconnect and am only able to get phone commands working. Dooes anyone have the S4 steaming audio working?
Which Radio are you Running? If you are running an RHR, you can install 2.136 and it fixes a lot of issues with Bluetooth Streaming. (Give me the radio model lower right corner).

Your Radio likely came with 2.120 and that is buggy as crap. There is also a Gracenotes update to 4118. SOX keeps this up for us.

If you can't find the downloads, let me know and I will cross post the info.
__________________
Reply With Quote
  #7  
Old 08-09-2013, 09:32 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1245
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by fumblefingers1 View Post
I am not sure what is happening. Since I can not get a signal for my S4 in my home, I set it up to use WiFi preferred but when I called some one with my S4 over Uconnect in the ride, although I could hear them clearly, they could not really hear me and static. I am unsure if I was on WiFi or the carrier network at the time but I was on a rural road. I looked on the apps menu and noticed that in addition to yelp tere was also WIFI listed. I was under the impression that the Uconnect WIFI was a pay extra service from Uconnect unless they are including it free for a while like the Sirrius radio. What say you? BTW at times the Sirrius radio cut out momentarily on the rural road.
you need to pay for the wifi ($10 / day) so im sure it wasnt that. Try it again, but pull over... and check the signal on your phone. If its still staticy (how do you spell that?? lol) then transfer the call to your handset and try talking on that. If its good, then maybe you have an issue with your mic. if its bad, then prob the signal on your phone.

if it sounds good on your phone... hang up, then press the assist button... talk to the uconnect people. if they say its static as well... then maybe set up an appointment at the dealer.


as far as the SXM, yeah.. its common. People have said the signal drops easily (i had it drop under trees!! and it was only a few trees!
__________________
Reply With Quote
  #8  
Old 08-09-2013, 09:56 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 236
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 1029
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by StaticFX View Post
you need to pay for the wifi ($10 / day) so im sure it wasnt that. Try it again, but pull over... and check the signal on your phone. If its still staticy (how do you spell that?? lol) then transfer the call to your handset and try talking on that. If its good, then maybe you have an issue with your mic. if its bad, then prob the signal on your phone.

if it sounds good on your phone... hang up, then press the assist button... talk to the uconnect people. if they say its static as well... then maybe set up an appointment at the dealer.


as far as the SXM, yeah.. its common. People have said the signal drops easily (i had it drop under trees!! and it was only a few trees!
Thanks for your help understanding. I believe the mike is Ok because when I say "launch yelp" Uconnect understands me. I am also having trouble with a very weak signal in my Homelink. My Mighty Mule gates work with their own openers but rarely with the GC. My old GC worked fine. Is there any way to increase signal strength?
__________________
Reply With Quote
  #9  
Old 08-09-2013, 09:19 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 236
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 1029
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Today I also paired my wife's smart phone as #2 on the phone settings and left my S4 as the default. next I turned on my phone and turned my wife's phone off. About 5 minute later I rec'd a call and my blue tooth connection showed 3 bars but the connection was full of static so the caller tried again and then gave up. The caller was on a different network than my phone so I don't know if it is trouble with the Uconnect or cell phone handshake. The caller was in a rural area with one bar and I was in a city. Any thoughts?

The Homelink problem of weak signal is driving me nuts also
__________________
Reply With Quote
  #10  
Old 08-18-2013, 03:42 PM
Member
 
Join Date: Jan 2010
Location: Nyack NY
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1766
NebularMan is on a distinguished road
Re: Samsung Galaxy S4 Uconnect

I asked the dealer if the radio had the latest and greatest and they said it did. It's 2.4 something off the top of my head. It's as if the S4 does not see the radio as an audio device but it sees it only as a phone.
Reply With Quote
  #11  
Old 08-19-2013, 07:51 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927088
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by NebularMan View Post
I asked the dealer if the radio had the latest and greatest and they said it did. It's 2.4 something off the top of my head. It's as if the S4 does not see the radio as an audio device but it sees it only as a phone.
Go into your settings/information screen and actuall post the version.
__________________
Reply With Quote
  #12  
Old 08-21-2013, 10:58 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 236
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 1029
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: Samsung Galaxy S4 Uconnect

Quote:
Originally Posted by NebularMan View Post
I asked the dealer if the radio had the latest and greatest and they said it did. It's 2.4 something off the top of my head. It's as if the S4 does not see the radio as an audio device but it sees it only as a phone.
My S4 on the 8.4AN radio using the latest version 13.19.0 installed in the GC after 7/15 works and recognizes the S4 for media. Be sure you have bluetooth selected on your S4 and turn off wifi. If you have more than one phone paired, be sure you have selected the correct phone in the phone menu. I forgot to delete my old phone when i paired the S4
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UConnect problems with Samsung Galaxy Parrot Trouble Shooting/Problems/Service 11 04-02-2014 12:16 PM
Samsung Galaxy S4 JGC2013 Tech Tips DIY/How To 5 07-30-2013 08:20 PM
UConnect text notifications with Samsung Galaxy S4... chukeer Trouble Shooting/Problems/Service 1 07-24-2013 06:16 PM
Does anybody have the Samsung Galaxy Note...? IXFE Audio/Visual/Navigation 8 12-10-2012 12:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community