Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-12-2013, 02:21 PM
Member
 
Join Date: May 2013
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
04blackz is on a distinguished road
Stupid UConnect

I'm having issues with my u connect and iphone. I'm not sure what's going on. It runs so slow, doesn't connect right half the time. And doesn't keep with with the album art and info. Problem happens with it being plugged in. I could understand Bluetooth being slow, but not with it plugged in. I'm not using the factory iphone cable but a Belkin one. I'm not sure if that matters. Anyone else have this problem?
__________________

__________________
Reply With Quote
  #2  
Old 11-12-2013, 02:35 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,229
Thanks: 28
Thanked 65 Times in 58 Posts
Rep Power: 43652
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Stupid UConnect

Quote:
Originally Posted by 04blackz View Post
I'm having issues with my u connect and iphone. I'm not sure what's going on. It runs so slow, doesn't connect right half the time. And doesn't keep with with the album art and info. Problem happens with it being plugged in. I could understand Bluetooth being slow, but not with it plugged in. I'm not using the factory iphone cable but a Belkin one. I'm not sure if that matters. Anyone else have this problem?
UConnect version current?
Done an upgrade recently?

You could try an official Apple cable, but if you can connect it to a workstation using the Belkin, can't imagine what UConnect would be worrying about.
__________________

__________________
Reply With Quote
  #3  
Old 11-12-2013, 02:44 PM
Member
 
Join Date: May 2013
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
04blackz is on a distinguished road
Yeah it was at the dealer about 3 weeks ago and they did a reflash and update on it. It's not registered with the uconnect yet cause of all the problems people were having. Idk what is wrong with it
__________________
Reply With Quote
  #4  
Old 11-12-2013, 02:45 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,851
Thanks: 86
Thanked 74 Times in 61 Posts
Rep Power: 570904
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
Re: Stupid UConnect

hi

which uconnect, which car??
__________________
All Uconnect Software

www.mydrive.ch

username: mygig@soxag
Password: gasolio

Reply With Quote
  #5  
Old 11-12-2013, 03:51 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,229
Thanks: 28
Thanked 65 Times in 58 Posts
Rep Power: 43652
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Stupid UConnect

Quote:
Originally Posted by 04blackz View Post
Yeah it was at the dealer about 3 weeks ago and they did a reflash and update on it. It's not registered with the uconnect yet cause of all the problems people were having. Idk what is wrong with it
Caution that your dealer may not exactly be up to date on current releases, and may have flashed you to an older version.

Presuming this is the 8 inch with Nav, current is 13:38:52 NA or 13:39:51 International. You can check it from the apps settings button.

This is not to say thats the problem... as sometimes I think their website should be
www.stupiduconnect.com
__________________
Reply With Quote
  #6  
Old 11-12-2013, 04:54 PM
Member
 
Join Date: May 2013
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
04blackz is on a distinguished road
It's a 2014 grand Cherokee limited. And I'll check it later tonight and let y'all know.
__________________
Reply With Quote
  #7  
Old 11-12-2013, 05:14 PM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 861
Thanks: 0
Thanked 39 Times in 30 Posts
Rep Power: 3420
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Stupid UConnect

I'm running version 13.19, and I still can't get my fiance's iPhone to work...even plugged in.
__________________
2014 Granite GC Overland 4x4 3.6L / Mud Flaps / Pedal Set / Lighted Door Sills / Slush Mats & Cargo Mat / H11 Phillips Fog Light Bulbs / Skid Plates (Front & Middle Only) / Tinted Front Door Windows (35%) / Airaid CAI / Build Date: 12/13 / 8.4AN v14.25.05
Reply With Quote
  #8  
Old 11-12-2013, 05:19 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,046
Thanks: 307
Thanked 321 Times in 283 Posts
Rep Power: 1801510
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Stupid UConnect

Quote:
Originally Posted by GCLimited View Post
I'm running version 13.19, and I still can't get my fiance's iPhone to work...even plugged in.
So why don't you take a break from posting, and update your uConnect software. It might help.



---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #9  
Old 11-12-2013, 05:59 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,229
Thanks: 28
Thanked 65 Times in 58 Posts
Rep Power: 43652
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Stupid UConnect

Quote:
Originally Posted by 04blackz View Post
It's a 2014 grand Cherokee limited. And I'll check it later tonight and let y'all know.
Check this out.
Jeep Grand Cherokee WK2 - Grand Cherokee Service Bulletins and Recalls
__________________
Reply With Quote
  #10  
Old 11-12-2013, 07:21 PM
Member
 
Join Date: May 2013
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
04blackz is on a distinguished road
Yeah I saw that. Interesting all the damn reflashes there are for this car. Looks like I'm gonna be taking a trip to the dealer now
__________________
Reply With Quote
  #11  
Old 11-12-2013, 10:30 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Aug 2013
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 484
wuaname is on a distinguished road
Re: Stupid UConnect

Sad that we all are having these uconnect problems . Seems like dodge didnt do enough testing b4 putting it out on the market never had that problem b4 with prior vehicles gps, electronics, etc then again they werent american brands.

Since this isnt a regular owner caused problem, or maintainance, is dodge providing a loaner car when you take it in for problems that they didnt fix b4 going into production or are you stuck with a rental car and costs bc jeep drooped the ball?
__________________
2014 GC Limited, V8, removed resonators
Reply With Quote
  #12  
Old 11-12-2013, 11:02 PM
Member
 
Join Date: May 2013
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 536
04blackz is on a distinguished road
Re: Stupid UConnect

Every time i've had to take it in for warrenty work, i get stuck with a rental/having someone pick me up. Psh jeep's too good for courtesy cars! Not impressed at all! So far I've had a new transmission gasket, then new tranny, then uconnect problems (got reflashed but still having problems) and a new oil pressure sensor put in, all with less than 7k on the clock...
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anything different about UConnect 8.4 radio RA3 and UConnect Access Via Mobile REDDIZE Audio, Video, Navigation & Electronic Modifications 4 08-19-2014 11:55 PM
stupid,stupid me jeep5.7 Grand Cherokee - WK 9 10-16-2011 02:23 PM
This may a stupid question, but sometimes my stupid questions pay off. southernfryedyankee Wheels/Tires/Brakes 5 03-27-2011 11:25 AM
stupid ? Rosewood Trouble Shooting/Problems/Service 17 03-09-2011 12:56 AM
Man, did I look stupid! rdalcanto Grand Cherokee - WK2 - 22 01-30-2011 04:11 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community