Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-19-2014, 10:19 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Troutman, NC
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 306
2014falcon is on a distinguished road
The uConnect radio is frustrating...

I have a GC Summit with that magic radio that does everything for you except perform correctly.

The satellite radio seems to work as it should, never a problem. The navigation is good, nary an issue.

But that media portion of the radio is anything but reliable. Men have been put on the moon and brought back, and we build mighty ships that launch civilization killing aircraft, but Fiat can't fix that damn radio to automatically acknowledge and play data from an SD card/USB stick when selected. WTF? It can't be that hard.

My GC was built in August 2014. I have the latest update 13.48.XXXX installed, and the same problem in one fashion or another keeps popping up. After starting the vehicle up, the media isn't recognized sometimes, or the song count is doubled or tripled.

If, when I start the car, the media doesn't start , I can do the radio reset and it will usually recognize the SD card afterwards, and play normally.

After turning the car off, it's a crap shoot whether it will start again automatically when the car is started.

Friends of mine who see this occur automatically remove this car from their want list.

Come on, Fiat/Chrysler, ya'll got enough government to fix this!
__________________

__________________
Reply With Quote
  #2  
Old 01-19-2014, 01:07 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,850
Thanks: 296
Thanked 296 Times in 262 Posts
Rep Power: 1801272
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: The uConnect radio is frustrating...

Have you tried reformatting the card and reinstalling the songs? If you do, a radio reset before reinstalling the card is a good idea. There have been a number of threads on this topic. Often it comes down to a problem with the media ... even though it may work ok on a computer.


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #3  
Old 01-19-2014, 01:30 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Troutman, NC
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 306
2014falcon is on a distinguished road
Re: The uConnect radio is frustrating...

Yea, I transferred music from a 32-gB SD card to a 8-gB SD card and the same result.
__________________
Reply With Quote
  #4  
Old 01-26-2014, 10:11 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Troutman, NC
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 306
2014falcon is on a distinguished road
Re: The uConnect radio is frustrating...

****UPDATE! *****UPDATE!

Good news!

After Bill suggested reformatting the SD card, and even though it was already formatted to FAT32, I decided to re-format it. That was last Monday, 1/20.

I've waited a week with bated breath to see how the SD card reacted. I just spent 15 hours riding to Daytona and back this weekend with the radio playing continuously, and it never missed a beat.

So, it's played flawlessly since last Monday with no runs, no hits, no errors. I guess the reformatting did the job. I couldn't be more pleased.

Thanks, Bill!
__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anything different about UConnect 8.4 radio RA3 and UConnect Access Via Mobile REDDIZE Audio, Video, Navigation & Electronic Modifications 3 07-03-2014 09:54 PM
Using Pandora Radio with Uconnect BobsWK2 Audio, Video, Navigation & Electronic Modifications 3 01-20-2014 10:27 PM
FRUSTRATING. Uconnect won't play folders correctly Hazemonster Audio, Video, Navigation & Electronic Modifications 5 01-18-2014 05:16 PM
So frustrating five.7 Hemi Grand Cherokee - WK2 - 0 06-03-2012 08:41 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community