Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #277  
Old 07-02-2013, 03:38 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 856 Times in 468 Posts
Rep Power: 1927037
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by Milous View Post
13.19.0 fixes - addendum

Radio reset, screen lockup, blank screen or sluggish system response time.
Compass indicator turns off.
Erratic changes to vehicle icon on NAV map.
Touch screen shut down message.
Radio surround sound will not stay ON.
Loss of radio presets.
Uconnect apps don't load.
AM/FM popping noises and/or static.
Backup camera display is blank.
Also adding to Milous update. If you have any of the listed symptoms above or included in post #1, even if you have 13.19.0 already loaded, you can reload this same update. I have verified on multiple 13.19.0 vehicles including one with a factory load that certain items did not work including slow Nav and inoperative VR until reload. Once the reload was complete the sample vehicles were completely stable and trouble free.

It is possible a factory reset would also fix these conditions on a 13.19.0 but it has not been confirmed as of the time of this post.
__________________

__________________
Reply With Quote
  #278  
Old 07-02-2013, 05:45 AM
gigi_boy_156's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2012
Location: Berne / Switzerland
Posts: 185
Thanks: 0
Thanked 13 Times in 4 Posts
Rep Power: 1005342
gigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond reputegigi_boy_156 has a reputation beyond repute
Can anybody tell me, when will be the new Software available for European Cars?
__________________

__________________
Reply With Quote
  #279  
Old 07-02-2013, 06:10 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 856 Times in 468 Posts
Rep Power: 1927037
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by gigi_boy_156 View Post
Can anybody tell me, when will be the new Software available for European Cars?
I would suggest that you PM Sox. He will probably know if you can use the North American software and or if he has another version.
__________________
Reply With Quote
  #280  
Old 07-02-2013, 06:17 AM
Premium Member
 
Join Date: Jul 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 800
Sleves is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

Is this update good for Canadian jeep?
__________________
Reply With Quote
  #281  
Old 07-02-2013, 06:38 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 856 Times in 468 Posts
Rep Power: 1927037
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by Sleves View Post
Is this update good for Canadian jeep?
As long as it is a 2014 Jeep Grand Cherokee and you select the right radio model then yes.
__________________
Reply With Quote
  #282  
Old 07-02-2013, 07:24 AM
bertball50's Avatar
Member
 
Join Date: Jan 2013
Location: central iowa
Posts: 269
Thanks: 62
Thanked 5 Times in 4 Posts
Rep Power: 853
bertball50 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

do i need to delete my iphone and then pair it again after i've had my uconnect updated?
__________________
delivered 6-12-13 full review to come at 500 miles
2014 summit deep cherry red with jeep brown hemi.

Previous Jeeps:
1997 Limited
2004 Special Edition
2005 Rocky Mountain Edition (Wife's)
2006 Limited
Reply With Quote
  #283  
Old 07-02-2013, 07:49 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 856 Times in 468 Posts
Rep Power: 1927037
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by bertball50 View Post
do i need to delete my iphone and then pair it again after i've had my uconnect updated?
That is usually advisable.
__________________
Reply With Quote
The Following User Says Thank You to Willx For This Useful Post:
  #284  
Old 07-02-2013, 10:10 AM
studio1930's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 268
Thanks: 19
Thanked 21 Times in 13 Posts
Rep Power: 1098
studio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond repute
Garage
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by gmnagle77 View Post
Hello,
Mine came from the factor with the 13.19. But when I select the auto-on for the heated/vented seats teh check mark disappears after a moment. Also, my iPhone 5 connected fine, and I have zero texts on it. When I got one, it did not show on the system. Thoughts anyone?
Make sure you Jeep engine is running when you are adjusting the settings. The crazy engineers at Jeep decided to clear many of your settings a few seconds later if your Jeep engine is not running.
__________________
--------------------------------------------------------
2014 Grand Cherokee Overland 4x4, Max Steel, Morocco Black int, ORA II, ATG

Reply With Quote
  #285  
Old 07-02-2013, 10:24 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 856 Times in 468 Posts
Rep Power: 1927037
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Also when you see check marks disappear, it is telling you that the module did not acknowledge the command (of course if the vehicle is in accessory mode this may affects the state modules are in).

UConnect requests that modules do things and for user experience reasons the check mark is put in immediately then verified the module took the command.
__________________
Reply With Quote
  #286  
Old 07-02-2013, 11:17 AM
studio1930's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 268
Thanks: 19
Thanked 21 Times in 13 Posts
Rep Power: 1098
studio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond repute
Garage
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by Willx View Post
Also when you see check marks disappear, it is telling you that the module did not acknowledge the command (of course if the vehicle is in accessory mode this may affects the state modules are in).

UConnect requests that modules do things and for user experience reasons the check mark is put in immediately then verified the module took the command.
Which means that if a programmer knows a module won't take a setting due to the engine not running then the settings should be grayed out so that you cannot try and set it. Basic programming 101. They could go a step further and have a pop up message that says you must start your Jeep to change these settings. Wow!
__________________
--------------------------------------------------------
2014 Grand Cherokee Overland 4x4, Max Steel, Morocco Black int, ORA II, ATG

Reply With Quote
  #287  
Old 07-02-2013, 11:31 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Florida
Posts: 234
Thanks: 20
Thanked 4 Times in 4 Posts
Rep Power: 977
fumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond reputefumblefingers1 has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

The dealers just got this bulletin so mfg after 6/15 should have new software but all on dealer lots or in transit need update!
Service Bulletin NUMBER: 08-049-13
GROUP: Electrical
DATE: June 29, 2013

SUBJECT:
RA3 And RA4 Radio Enhancements

OVERVIEW:
This bulletin involves upgrading the software on the RA3 or RA4 Radio.

MODELS:
2014 (WK) Grand Cherokee

NOTE: This bulletin applies to vehicles built on or before June 15, 2013 (MDH
0615XX) equipped with SMART TOUCH 3 AM/FM/SAT/BT/VOICE (sales code
RA3) or SMART TOUCH 4 AM/FM/SAT/BT/NAV/VOICE (sales code RA4).

SYMPTOM/CONDITION:
A customer may experience, one or more of the following conditions.
Radio reset, screen lockup, blank screen or sluggish system response time.
Loss of vehicle position on NAV map.
Compass indicator turns off.
Erratic changes to vehicle icon on NAV map.
Touch screen shut down message.
Radio surround sound will not stay ON.
Driver memory feature causes Sirius XM failure.
Loss of radio presets.
Battery drain - due to radio remains on.
Uconnect apps don't load.
AM/FM popping noises and/or static.
Backup camera display is blank.
__________________
Lee
Customer Care
Chrysler Group LLC
__________________
Reply With Quote
  #288  
Old 07-02-2013, 11:39 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Pittsburgh
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 472
gmnagle77 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

Hello,
I did as you suggested. I had a friend text me while I was in the Jeep (after clear all prior texts) The engine was running. The texts came to the phone, but the Uconnect said zero inbox. Any other thoughts? And I still can't get the seats to auto turn on when remote started as the box wont stay checked in the settings.

Quote:
Originally Posted by EdwinDiaz View Post
Go to the Bluetooth settings on your iPhone. In the paired devices screen, click the blue arrow on the right where it says uconnect. Make sure "show notifications" is turned on.
__________________

__________________
Cheers & Gears,
GMNAGLE77
2014: JGC,Limited, 3.6L, ADG, AHN, RA4, Black Forest Green, Black Leather
2008: JGC, Limited, 4.7L, Luxury with side steps
Reply With Quote
Reply

Tags
13.19.0, 8.4an update, jeep 8.4, jeep uconnect, uconnect 13.19.0 update, uconnect 8.4

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anything different about UConnect 8.4 radio RA3 and UConnect Access Via Mobile REDDIZE Audio, Video, Navigation & Electronic Modifications 4 08-19-2014 11:55 PM
UConnect glock17 Grand Cherokee - WK2 - 12 03-26-2013 09:39 AM
Uconnect Wi-fi Jpeyatt Audio, Video, Navigation & Electronic Modifications 8 01-16-2012 10:35 AM
NEW UNOFFICIAL 1/4 Mile, 12.77@107.5 Tim@NCTSLLC At The Track 27 10-17-2009 12:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community