Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #337  
Old 07-04-2013, 02:54 PM
AZhiCntry's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Prescott, AZ
Posts: 543
Thanks: 280
Thanked 26 Times in 25 Posts
Rep Power: 48924
AZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by Willx View Post
From what I understand about this, anyone seeing this message should document this and mention it at your next service visit. I believe it is a flag of a firmware issue on a specific component on the radio. There are some firmware updates in the pipe but I don't know when they will arrive.

As for Pandora, still no dates but the app will just go live at some point and possibly this month tmk. (This is still old knowledge... No one has seemed to have the update for this).
In the 3 months since owning this veh I did not see the "phone needs service warning" until I installed 13.19. I've seen it 3 times now. I'm still having screen freezes and random reboots. Is there a firmware update available at dealers now? Should I try a factory reset - reinstall 13.19?
__________________

__________________
2014 GC Limited V6 4x4, white w/black & frost beige, LuxII, RA4, ORA II, Cooper Discoverer AT3's. :D:D:D
Reply With Quote
  #338  
Old 07-04-2013, 03:28 PM
Premium Member
 
Join Date: Feb 2013
Location: McKinney, Tx
Posts: 50
Thanks: 2
Thanked 5 Times in 5 Posts
Rep Power: 670
Gene20354 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

I decided to install the update today. I updated from a problem free radio running 13.10.0. The update process was flawless. Upon reboot all of my pre-sets were still available. The equalizer was reset and the surround sound was off.
__________________

__________________


Daily Driver
Honda S2000

2014 Max Steel V6 4x4
Reply With Quote
  #339  
Old 07-04-2013, 03:31 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2012
Location: Manhasset, NY
Posts: 172
Thanks: 2
Thanked 24 Times in 16 Posts
Rep Power: 326378
jdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond reputejdchamp31 has a reputation beyond repute
There are no Firmware updates available as of yet. They are in the pipe. The WiTech programmers that the techs use need to be updated first so they can flash the new modules for the radio in the Powernet architecture. They focused on the more important modules first ie: PCM, ABS, etc... There is stuff in the works. Stay tuned.
__________________
Reply With Quote
The Following 4 Users Say Thank You to jdchamp31 For This Useful Post:
  #340  
Old 07-04-2013, 07:20 PM
PB617's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Location: Boston, MA
Posts: 162
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 818
PB617 is on a distinguished road
I only got the 911 service message with the 13.19 update and it was only once when it rebooted after the update was done. I have not had any reboots or freezing with mine since i've owned it, It's been solid.

I also agree that Sirius sound quality is crap and won't be renewing it. Streaming pandora from my iphone with bluetooth sounds 10x better!
__________________
2014 Jeep Grand Cherokee Limited | Granite | 4x4 | HEMI | LuxII | 20" Wheels | 5000k LED Fogs | 20% Tint

Reply With Quote
  #341  
Old 07-04-2013, 07:51 PM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 438
Thanks: 15
Thanked 29 Times in 24 Posts
Rep Power: 1572
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

+1 on the Sirius sound quality. I've been listening more and more to local HD (FM) radio lately; the HD sound quality is amazing! Makes Sirius sound flat.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.05!!
Reply With Quote
  #342  
Old 07-04-2013, 08:11 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 77
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 636
libby2cm is on a distinguished road
Garage
Quote:
Originally Posted by Northland View Post
+1 on the Sirius sound quality. I've been listening more and more to local HD (FM) radio lately; the HD sound quality is amazing! Makes Sirius sound flat.
+2

Sent from my SCH-I605 using Tapatalk 4 Beta
__________________
Reply With Quote
  #343  
Old 07-04-2013, 08:59 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2012
Posts: 111
Thanks: 22
Thanked 1 Time in 1 Post
Rep Power: 1040
Celestinemusic is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

I have the RA4N and the 911 Phone Requires service message comes and goes. I noticed that it always comes when the Sprint service signal strength drops to 1 bar or possibly less. I am still running version 13.10.0 and I hesitate to upgrade it as other than that periodic message, my system has been stable. My phone always connects properly and I don't have reboot issues. The nav always works and is in the right place, etc. I wonder why everyone with the same software version doesn't experience the same set of problems. There are probably hardware problems mixed in, but whatever they are, lots of people seem to have the same ones.
Do those with knowledge think that I should update the software version?
__________________
Reply With Quote
  #344  
Old 07-04-2013, 09:04 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927086
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
The Service 911 system message is strictly about the cell system in the vehicle. The update most likely does not fix this issue. All vehicles that see this error will at some point in time need a firmware update. The problem is not caused or made worse by the software updates.
__________________
Reply With Quote
The Following User Says Thank You to Willx For This Useful Post:
  #345  
Old 07-05-2013, 08:58 AM
Lankness's Avatar
Premium Member
 
Join Date: Aug 2011
Location: Pearland, TX
Posts: 856
Thanks: 69
Thanked 69 Times in 62 Posts
Rep Power: 1147509
Lankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond reputeLankness has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

I hadn't seen the 911 system error until the 13.19 update. I saw it at the end of that update, and it has flashed on mine a few times since when booting the system at start.

For the firmware update, I am assuming that is going to require a dealer trip when available?
__________________
-------------------------
Kevin

2014 Max Steel GC SRT, built by the bad boys at JNAP .
2002 Camaro SS with lots and lots of go-fast goodies...
Reply With Quote
  #346  
Old 07-05-2013, 09:10 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927086
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: UConnect 13.19.0 - Unofficial

Kevin,

sadly yes, I am nearly 100% sure this is a dealer visit. It appears there needs to be an update done to the Cellular Component in the radio. I will share more when I know more about this.

Thx,
__________________
Reply With Quote
  #347  
Old 07-05-2013, 10:22 PM
Member
 
Join Date: Apr 2013
Posts: 62
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 618
justice37 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

I drove 13.19.0 for 10 hours from yesterday..
(improved from previous version)
1. no random reboot anymore.
2. faster speed and better touchscreen accuracy
(new issue found)
1. SXM preset reset - once.
2. GPS clock stuck at 11:43 AM and not going - once.
3. Nav button was not responding - twice. (Nav screen is not showing up after I touch the Nav button, it is solved after long wait or long touch)
4. MP3 play stuck, no sound, no play - once
5. There are two select menus for "Nav turn-by-turn display in cluster"; one in nav setting, another one is in uconnect setting.
__________________
Reply With Quote
  #348  
Old 07-05-2013, 11:09 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 859 Times in 469 Posts
Rep Power: 1927086
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by justice37 View Post
I drove 13.19.0 for 10 hours from yesterday..
(improved from previous version)
1. no random reboot anymore.
2. faster speed and better touchscreen accuracy
(new issue found)
1. SXM preset reset - once.
2. GPS clock stuck at 11:43 AM and not going - once.
3. Nav button was not responding - twice. (Nav screen is not showing up after I touch the Nav button, it is solved after long wait or long touch)
4. MP3 play stuck, no sound, no play - once
5. There are two select menus for "Nav turn-by-turn display in cluster"; one in nav setting, another one is in uconnect setting.
Give it a couple days.... if it is not OK, reload the update.
__________________

__________________
Reply With Quote
Reply

Tags
13.19.0, 8.4an update, jeep 8.4, jeep uconnect, uconnect 13.19.0 update, uconnect 8.4

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anything different about UConnect 8.4 radio RA3 and UConnect Access Via Mobile REDDIZE Audio, Video, Navigation & Electronic Modifications 4 08-19-2014 11:55 PM
UConnect glock17 Grand Cherokee - WK2 - 12 03-26-2013 09:39 AM
Uconnect Wi-fi Jpeyatt Audio, Video, Navigation & Electronic Modifications 8 01-16-2012 10:35 AM
NEW UNOFFICIAL 1/4 Mile, 12.77@107.5 Tim@NCTSLLC At The Track 27 10-17-2009 12:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community