Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #829  
Old 07-24-2013, 12:13 PM
JoeK's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 368
JoeK is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

I recently upgraded to 13.19.0 and I decided to check then uconnect assist. It worked...sort of. When I pressed the mirror button for the first time a green light went on but nothing happened and the light just went out. Then I went to the access screen and pressed the mirror button again. This time it did work. The three screen buttons came up. I pressed customer care and the call went through. I ended it before anyone answered.
Took our second trip to North Carolina from New Jersey and the Nav system really enjoyed itself with a number of route recalculations even though I was on I-95 and stayed on I-95 for about six hours. It did not change any routes or show me on a different road. Maybe it was bored. The radio will also not jump to the preset traffic channel 90% of the time when I press the traffic button on the radio screen. The button lights up but nothing happens. It did work today when I pulled out of the garage. I also think my rain sensitive wipers are now sun sensitive. Go on during rain and occasionally when just tooling along in nice weather. I will adjust the sensitivity and see what happens.
__________________

__________________
Reply With Quote
  #830  
Old 07-24-2013, 12:54 PM
Member
 
Join Date: Mar 2013
Posts: 173
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 573
RFF111 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

Willx:

I purchased my 2014 Overland in March and am still running 13.05 with no issues. Last night, I finally got around to checking to see if the actual buttons on the rear view mirror worked properly as I was scheduled to have 13.19 installed by dealer today (which I cancelled). Sure enough, when I tried to access the system via the button on the mirror, I received a message saying that I was not registered and to call the number provided. I called and verified that I was in fact registered and in the system, and after being put through a series of tests to make sure everything else was OK with the radio, they put a ticket in for my case and said they would get back to me. My question is this. Information on another thread seems to indicate that my radio is "too old" and needs to be replaced in order to handle the new software. Is this really the case??
__________________

__________________
Reply With Quote
  #831  
Old 07-24-2013, 01:03 PM
Willx's Avatar
Specialist


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,532
Thanks: 479
Thanked 740 Times in 395 Posts
Rep Power: 1926319
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by RFF111 View Post
Willx:

I purchased my 2014 Overland in March and am still running 13.05 with no issues. Last night, I finally got around to checking to see if the actual buttons on the rear view mirror worked properly as I was scheduled to have 13.19 installed by dealer today (which I cancelled). Sure enough, when I tried to access the system via the button on the mirror, I received a message saying that I was not registered and to call the number provided. I called and verified that I was in fact registered and in the system, and after being put through a series of tests to make sure everything else was OK with the radio, they put a ticket in for my case and said they would get back to me. My question is this. Information on another thread seems to indicate that my radio is "too old" and needs to be replaced in order to handle the new software. Is this really the case??

Yes and no, All radio hardware built from day one is compatible with 13.19.0. If you end up going for a service visit, the dealer is required to load 13.19.0 before proceeding to any other fix (except if you are running prior to 13.10 and have a specific symptom then it is immediate replacement).

Most of the radios will update fine, during the update there are many radios though that will get identified as having a hardware issue where they need to be replaced.

There is really no way to tell for sure if the radio has a component problem without the update though... hence step one, the dealer will load the update first.

To calm your concerns, the very first Jeep I tested and updated was Built in February and came with 13.05 ... It never had any issues, the remote start A/C worked perfectly and it never got a Service Phone System Error. It has been since sold to a happy customer and I have touched base with them and there has been no issues with the system (Currently runs 13.19.0).

__________________
Reply With Quote
  #832  
Old 07-24-2013, 01:19 PM
Member
 
Join Date: Mar 2013
Posts: 173
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 573
RFF111 is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

That is very good news. Because I have had literally no issues with my radio to-date and am quite happy with its performance, even running the ancient 13.05. I cancelled my software install today and moved it into August because my truck is part of the recall for the defective headlights so I decided to get the update and that issue fixed at the same time. Like I said, the only issue for me so far is that I don't have U-Connect connectivity via the buttons on the mirror even though I confirmed with U-Connect that I am in the system and registered until next March.
__________________
Reply With Quote
  #833  
Old 07-24-2013, 03:04 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 565
Thanks: 0
Thanked 15 Times in 15 Posts
Rep Power: 874
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

You should update JUST for the speed difference alone! Just do it yourself it was easy
__________________
Reply With Quote
  #834  
Old 07-24-2013, 03:09 PM
Premium Member
 
Join Date: Apr 2013
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 399
ebang is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

I wish they add an option to turn the music off when we turn the engine gets turned off like most other cars. Sometimes, I cannot tell whether I had turned the engine off because the music is still on. Music only turns off when I open the door...
__________________
2014 White Jeep Grand Cherokee Overland V6 4X4 Black Interior
Reply With Quote
  #835  
Old 07-24-2013, 03:10 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Fresno, CA
Posts: 226
Thanks: 22
Thanked 7 Times in 5 Posts
Rep Power: 658
adthebadstud is on a distinguished road
Garage
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by schmieg View Post
Just updated to 13.19 and only found two quirks. The auto headlights seem to be on all the time and every once in a while, the rain sensing wipers make three passes, even though the sun is shining and it's a dry day. I'll give it a bit of time to see if it works its way back to normal.
This happened to me today all of a sudden in broad daylight. The wipers turned on and then the auto high beams turned on. Lasted for about 30 seconds each.

Things keep adding up since I upgraded to 13.19... not that I think everything was caused by the update, but I think that it may have just sent my leaning car problems over the edge.
__________________
2014 Overland 4x4 V6, Black ext, Black int, Advanced Tech Package. EC169841

My First Jeep. Current Status: Chrysler Buy Back (It's for sale in Wisconsin! http://www.vanhorndodge.com/vehicle-...-wi-id-6432659
Reply With Quote
  #836  
Old 07-24-2013, 03:12 PM
Willx's Avatar
Specialist


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,532
Thanks: 479
Thanked 740 Times in 395 Posts
Rep Power: 1926319
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by ebang View Post
I wish they add an option to turn the music off when we turn the engine gets turned off like most other cars. Sometimes, I cannot tell whether I had turned the engine off because the music is still on. Music only turns off when I open the door...
Not sure but I think you can set this in the engine off options.

Every Car I have driven in the last 4 or 5 years, the radio has stayed on... best way to verify is which light is lit around the start button as to whether it is still in "Run" mode
__________________
Reply With Quote
  #837  
Old 07-24-2013, 03:18 PM
JoeK's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 368
JoeK is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

Oh good. I am not the only one with sun sensitive wipers...
__________________
Reply With Quote
  #838  
Old 07-24-2013, 03:22 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Cincinnati, Ohio
Posts: 133
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 454
schmieg is on a distinguished road
Re: UConnect 13.19.0 - Unofficial

Quote:
Originally Posted by JoeK View Post
Oh good. I am not the only one with sun sensitive wipers...
I had the wiper and light problem immediately after updating to 13.19.0, but it went away after about 24 hours and hasn't returned.
__________________
Reply With Quote
  #839  
Old 07-24-2013, 03:24 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 565
Thanks: 0
Thanked 15 Times in 15 Posts
Rep Power: 874
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

Heres some fun...

from the iso i pulled the wallpapers


56 < Limited


57 < Overland


58 < Overland


59 < Summit


60 < SRT



Now.. heres the question. How does the radio know what the model is? All of these are in the one file (under different file names) Im going to take a guess it HAS to be a setting - how else could it know?
Maybe in the Engineering menu? If it is.. we can at least change the image by picking a different model? no?
__________________
Reply With Quote
  #840  
Old 07-24-2013, 03:32 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,475
Thanks: 258
Thanked 257 Times in 228 Posts
Rep Power: 1800512
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: UConnect 13.19.0 - Unofficial

Isn't the radio tied to the vin?


---
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
Reply

Tags
13.19.0, 8.4an update, jeep 8.4, jeep uconnect, uconnect 13.19.0 update, uconnect 8.4

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UConnect glock17 Grand Cherokee - WK2 - 12 03-26-2013 09:39 AM
Anything different about UConnect 8.4 radio RA3 and UConnect Access Via Mobile REDDIZE Audio, Video, Navigation & Electronic Modifications 1 02-18-2013 01:19 PM
Uconnect Wi-fi Jpeyatt Audio, Video, Navigation & Electronic Modifications 8 01-16-2012 10:35 AM
NEW UNOFFICIAL 1/4 Mile, 12.77@107.5 Tim@NCTSLLC At The Track 27 10-17-2009 12:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community