uConnect 15.26.1 is buggy; I want to downgrade. - Page 10 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #109  
Old 08-30-2015, 10:53 PM
Member
 
Join Date: Mar 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1412
richardyc is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

I got the 'earth' screen today every 10-15mins or so. It was kinda cloudy today, and I thought maybe the signal was weak or issue with the antenna. I rarely use my NAV driving to work during weekdays, so I am not sure if this is a new issue or it's been like that since day one. my 15 jeep GC is about 2months old. I am still on 15.06.1, figured if I bring it in to the dealer, the first thing they will do is to update my software to 15.26.1, so I am downloading that right now. should I do the update?

Reply With Quote
Sponsored Links
Advertisement
 
  #110  
Old 08-30-2015, 10:56 PM
Hitchhiking
 
Join Date: Aug 2014
Posts: 1,264
Thanks: 9
Thanked 196 Times in 168 Posts
Rep Power: 0
skunkd is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by richardyc View Post
I got the 'earth' screen today every 10-15mins or so. It was kinda cloudy today, and I thought maybe the signal was weak or issue with the antenna. I rarely use my NAV driving to work during weekdays, so I am not sure if this is a new issue or it's been like that since day one. my 15 jeep GC is about 2months old. I am still on 15.06.1, figured if I bring it in to the dealer, the first thing they will do is to update my software to 15.26.1, so I am downloading that right now. should I do the update?

I had the same issue today as well first time I saw it happen on my unit. It was cloudy here as well so I thought the same. Interesting. I have the latest update though so it's most likely the reception but it was really annoying that the map goes black and doesn't correct itself unless you leave the nav screen and come back to it.


Sent from my iPhone using JeepGarage
Reply With Quote
  #111  
Old 08-31-2015, 02:27 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1904
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by Roadkill
None of this *ever* happened before this latest firmware update. I'm downgrading the moment we get a terminator working. Actually, now that I think about it... RR, how often does the system bitch about the antenna if it's disconnected? Once per engine start, or does it nag every five minutes or something?
It'll appear every time the radio boots-up and will soon timeout or can be dispatched by touching the screen. In the first set of backyard experiments it stayed gone for over an hour but I don't know for certain if it stays away for the session or might come back periodically when underway. I think it would be the former, but no proof.


Quote:
Originally Posted by Roadkill
Does disconnecting the antenna completely prevent registration on the data network?
Sadly, No. Disconnecting the antenna significantly limits the registration but it still occurs when very close to a Sprint tower.


================


Today's update:

I put a 50Ω termination on the pink port…



and acted on Mr. Roadkill's suggestion to disconnect the remaining antennas.

Quick to appear was a new nag screen about the sat. radio antenna…




The sat radio antenna nag was persistent as long as SXM was selected on the radio screen.

The registrations are still occurring but are further diminished. The range is under 1/10 mile and the displayed service level is mostly "1x" compared to mostly "3G" up til now.

I plugged the sat and terrestrial antennas back in and repeated the course with no changes observed from when they were disconnected.

So, we have the ability to limit the registration to Sprint, which helps to mitigate the risk of someone on the outside penetrating the vehicle network, but the radio still manages to connect once in a while.

Close but no cigar...Gotta find that leak.
Reply With Quote
The Following User Says Thank You to Rocketrancher For This Useful Post:
  #112  
Old 08-31-2015, 08:30 AM
Senior Member
 
Join Date: Sep 2013
Posts: 1,307
Thanks: 46
Thanked 164 Times in 132 Posts
Rep Power: 2872
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by Rocketrancher View Post
Sadly, No. Disconnecting the antenna significantly limits the registration but it still occurs when very close to a Sprint tower.
Bummer. I checked your pics of the board... the Sierra Wireless card doesn't appear to be removable. Is it?

Quote:
the radio still manages to connect once in a while.
I have a tip of the hat for the engineers who made their radio datalink harder to eradicate than a cockroach infestation.

Quote:
Close but no cigar...Gotta find that leak.
Thanks for your continued research on this. Do you suspect that continued network registration is arising from board traces (or otherwise within the radio housing)?
Reply With Quote
  #113  
Old 08-31-2015, 03:34 PM
Member
 
Join Date: Mar 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1412
richardyc is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Did the update this morning, but it installed 15.17.5, I downloaded it from molar ownersconnect with my vin #, so not sure why they they think this is the latest version for me. Still got the earth screen after the update, so I think it's issues with the satellites and give it a few days before calling the dealer.
Reply With Quote
  #114  
Old 08-31-2015, 04:15 PM
Member
 
Join Date: Sep 2014
Posts: 264
Thanks: 17
Thanked 48 Times in 38 Posts
Rep Power: 7444
michaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond repute
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by richardyc View Post
Did the update this morning, but it installed 15.17.5, I downloaded it from molar ownersconnect with my vin #, so not sure why they they think this is the latest version for me. Still got the earth screen after the update, so I think it's issues with the satellites and give it a few days before calling the dealer.
like a third of the gps sats would need to fall out of the sky for the system to become unreliable. There's something like 31 working US GPS sats and the system works with like 18 as the minimum and 24 for "fully operational"

It is effecting everyone with uconnect and no one else.

do the math. Still think it's the sats fault?
Reply With Quote
  #115  
Old 08-31-2015, 07:27 PM
Senior Member
 
Join Date: Sep 2013
Posts: 1,307
Thanks: 46
Thanked 164 Times in 132 Posts
Rep Power: 2872
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by michaelk View Post
It is effecting everyone with uconnect and no one else.
Furthermore, I'm willing to bet it's only affecting 2014 vehicles with latest firmware, and 2015s with recent firmware as well.

Quote:
Originally Posted by richardyc View Post
give it a few days before calling the dealer.
I think you'll be SOL if you want the dealer to downgrade your firmware version to a known working previous release, especially given the latest release is considered a "recall" due to the horrible remote exploit.

The GPS system is fine. It's not "the satellites".

http://www.navcen.uscg.gov/?Do=constellationStatus

There would be widespread media coverage due to major transportation systems being affected... air travel, cell phone navigation, every other GPS based system, etc.
Reply With Quote
  #116  
Old 08-31-2015, 07:29 PM
Da Jeeper's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Feb 2012
Location: Chicago
Posts: 625
Thanks: 87
Thanked 71 Times in 56 Posts
Rep Power: 2414
Da Jeeper is on a distinguished road
Quote:
Originally Posted by Roadkill View Post
Furthermore, I'm willing to bet it's only affecting 2014 vehicles with latest firmware, and 2015s with recent firmware as well.

I think you'll be SOL if you want the dealer to downgrade your firmware version to a known working previous release, especially given the latest release is considered a "recall" due to the horrible remote exploit.

The GPS system is fine. It's not "the satellites".
I have a 15 on old firmware, dodge durango and jeep cherokee have this problem as well
I called uconnect and they dont onow what's wrong other than an issue with google servers was there thought
Reply With Quote
  #117  
Old 08-31-2015, 07:29 PM
GoPlzGo's Avatar
formerly 14summithemi
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2013
Location: Cleveland, OH
Posts: 3,242
Thanks: 362
Thanked 580 Times in 484 Posts
Rep Power: 25706
GoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond repute
My '14 8.4AN is not affected but it is intentionally 1 version behind and I have no active UConnect subscription....
__________________
'15 JGC SRT Bright White Red Vapor...Borla ATAK Cat-back w/ ceramic coated axle-back, aFe Momentum GT Pro 5R Stage-2 Intake & Billet Tech Oil Catch Can
Reply With Quote
  #118  
Old 08-31-2015, 07:40 PM
Premium Member
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Apr 2015
Location: bartlett,il
Posts: 135
Thanks: 14
Thanked 40 Times in 32 Posts
Rep Power: 779
hemirt is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Hi, I'm here outside of Chicago and had the same problem with the earth showing on my 15 srt, called dealer and said a teck would have to look at it, so I'm waiting to see if it clears up
Reply With Quote
  #119  
Old 08-31-2015, 09:50 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1904
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Just another datapoint, but I'm holding at v14.25.50 and it just keeps on tickin'.
I've never seen the earth screen, although I do manually visit the receiver status screen every once in a while.

I don't believe its the satellites.
TI says "its the mirrors", but that's something else...

My money's on a bad code release.
Reply With Quote
  #120  
Old 08-31-2015, 11:01 PM
Senior Member
 
Join Date: Sep 2013
Posts: 1,307
Thanks: 46
Thanked 164 Times in 132 Posts
Rep Power: 2872
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by Rocketrancher View Post
I've never seen the earth screen, although I do manually visit the receiver status screen every once in a while.
When the 2014 model 8.4AN nav crashes it goes to a black screen that says "Navigation is being activated". This is the same display you see if you try to enter the map right after starting the vehicle, before nav has a chance to completely startup.

My guess is the '15 owners have an Earth graphic added to decorate what amounts to be the same screen. I've never seen any spiffy Earth graphic on the 2014 on any screen in any case. Too bad we can't easily mod our firmware (haha).
Reply With Quote
The Following User Says Thank You to Roadkill For This Useful Post:
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil life algorithm still buggy Roadkill 2014+ Jeep Grand Cherokee Ecodiesel 3.0 7 01-19-2015 09:33 PM
Want to Downgrade from my 2005 REC NAV jsquire1 Troubleshooting/Problems 3 11-14-2013 08:45 PM
The Buggy :: 2012 Jeep Grand Cherokee SRT8 Challenger15 Member Garage Discussions 0 01-04-2013 08:48 AM
My system downgrade - Finished w87will Audio, Video, Navigation & Electronic Modifications 80 10-27-2010 11:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.