uConnect 15.26.1 is buggy; I want to downgrade. - Page 8 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #85  
Old 08-16-2015, 02:59 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1030
jeepgrandcherokeesal is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Wow, so a $.02 10K ohm resistor and a shield... Great work! I'll order some D fakras off ebay.

If anyone had registered for uConnect Access, you'll notice that the vehicle mileage and date still update on the "mopar web dashboard" every time the radio phones home, even after the trial expires! If the terminator works, that should never update again. Or, if someone is confident enough, could try pushing the 911 button The call should fail!

Reply With Quote
Sponsored Links
Advertisement
 
  #86  
Old 08-16-2015, 11:05 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,720
Thanks: 291
Thanked 296 Times in 231 Posts
Rep Power: 91372
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: uConnect 15.26.1 is buggy; I want to downgrade.

I let my trial expire without renewal, and my mileage only updates when I take it to the dealer for service, never on its own. Recalls are only registered on my "web dashboard" when the dealer performs them. I'll have to try the 911 button and see what happens, but I've been led to believe it will work regardless of subscription status.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #87  
Old 08-16-2015, 11:10 PM
Senior Member
 
Join Date: Sep 2013
Posts: 1,312
Thanks: 49
Thanked 164 Times in 132 Posts
Rep Power: 2883
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by jacko15 View Post
I'll have to try the 911 button and see what happens, but I've been led to believe it will work regardless of subscription status.
That's the point: if the cellular link has been appropriately severed, as is our intent, then the 911 call button will no longer work under any circumstances.
Reply With Quote
  #88  
Old 08-18-2015, 12:23 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1909
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Greetings everyone!

I had another adventure yesterday but the results weren't quite as grand as I'd expected.

I changed the cap on the terminator to fully-enclosed the resistor. It seems to have reduced the range at which the tower would be detected (from ~1/2 mile to ~1000 feet) but I really wanted to see it gone altogether.

This is Rev1 of the terminator. It's an SMB connector with a resistor and cap of 5/32" brass tubing soldered on. The difference between it and Rev0 is the longer cap with the end crimped and soldered…



and then plugged-in…



I'm wondering where the leak might still be and thought I'd take a look under the hood of the radio in the meantime.
Made some more snapshots to share:

The back of the radio, display face down (Rev0 termination in place)…



The back casting, lifted-off. One board attached to the casting, another below that may or may not come off at the same time. Note the Sierra device and Sirius tuner. If you explore this region, be sure to observe the routing of the little black cable. The connector on the Sirius tuner swivels and the cable should be dressed back downward when reassembling...



The inner board lifted off a pass-thru connection to the display and a couple of thermal pads…



And then there was this friendly little "welcome back"...



But the radio (and my heartbeat) came right back upon engine start…





So, I'm in pondering mode again. Some thoughts I have are of the pink connector and how it factors into the antenna network serving the Sierra module. Also if those antenna shields are bonded to the case or isolated, which might still leave our little terminator acting like a stub. I reckon I'll start there next time.
Anyone have an idea?
Whatever happened to the days when we wished our radios had more sensitivity?
Reply With Quote
  #89  
Old 08-18-2015, 08:21 PM
Member
 
Join Date: Oct 2014
Posts: 56
Thanks: 17
Thanked 9 Times in 8 Posts
Rep Power: 11225
CaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond reputeCaptWill has a reputation beyond repute
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Whatever happened to the days when we wished our radios had*more*sensitivity?*

Lol, isn't that the truth!

Could there be RF leakage through the screen? What about installing a shielded terminating resistor or shunt, on the pink connector? Can you check to see if red connector shield is chassis ground?

Can't think of anything else, Dave. You're doing a way better job than I could. !

on edit: I just thought of something else, even though it is a long shot. If there is stray RF behind the back of the unit, is it being loosely coupled to the GSM antenna/cable, and radiating some energy from there? Possibly shunting the disconnected antenna cable would eliminate that possibility.
Reply With Quote
  #90  
Old 08-18-2015, 09:13 PM
Member
 
Join Date: Jul 2014
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 950
HSTNJEEP is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Anyone have the issue of changing satellite stations, yet the on screen information stays the same? It actually changes stations but does not reflect it. I had this problem before and after the update at the dealership.
Reply With Quote
  #91  
Old 08-19-2015, 02:27 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1909
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by CaptWill View Post

Could there be RF leakage through the screen? What about installing a shielded terminating resistor or shunt, on the pink connector? Can you check to see if red connector shield is chassis ground?
Quote:
Originally Posted by CaptWill View Post
on edit: I just thought of something else, even though it is a long shot. If there is stray RF behind the back of the unit, is it being loosely coupled to the GSM antenna/cable, and radiating some energy from there? Possibly shunting the disconnected antenna cable would eliminate that possibility.

Good thoughts, Will. I wondered about the screen, thinking maybe a patch was behind it to get wifi into the cabin, but it's outside the metal housing and I didn't notice any rf connections passing thru to the outside besides those on the back half.

Next session, I'll check those potentials and see what lies on the pink one. I anticipate finding phantom power on pink. Will also try shunting the red line.
Reply With Quote
  #92  
Old 08-19-2015, 03:56 PM
Member
 
Join Date: Sep 2014
Posts: 264
Thanks: 17
Thanked 48 Times in 38 Posts
Rep Power: 7450
michaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond repute
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by jeepgrandcherokeesal View Post
...

If anyone had registered for uConnect Access, you'll notice that the vehicle mileage and date still update on the "mopar web dashboard" every time the radio phones home, even after the trial expires! If the terminator works, that should never update again. ...

you have a 14 and you see mileage on moparownerconnect website?
Reply With Quote
  #93  
Old 08-19-2015, 08:56 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1030
jeepgrandcherokeesal is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by michaelk View Post
you have a 14 and you see mileage on moparownerconnect website?
Yup. Once logged in, click on "Maintain and Care" then "Maintenance Schedule". There's a "Current Mileage" box with the odometer reading and the read date.
Reply With Quote
  #94  
Old 08-19-2015, 09:00 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1030
jeepgrandcherokeesal is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by CaptWill View Post
...Can you check to see if red connector shield is chassis ground?
That is an important question... There is no direct path to the ground. From an RF standpoint, the car is floating!
Reply With Quote
  #95  
Old 08-20-2015, 03:55 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1909
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

(Perhaps interesting reading)

Valasek/Miller whitepaper on the jeep exploit
http://www.ioactive.com/pdfs/IOActiv...ar_Hacking.pdf

FCCID submittal for Sierra module
https://fccid.io/N7NGTM2

Preliminary Product specification for the Sierra module
https://fccid.io/pdf.php?id=1553301
Fig 2.3 is interesting; Sect.8 is ironic
Reply With Quote
The Following 3 Users Say Thank You to Rocketrancher For This Useful Post:
  #96  
Old 08-20-2015, 03:09 PM
Member
 
Join Date: Sep 2014
Posts: 264
Thanks: 17
Thanked 48 Times in 38 Posts
Rep Power: 7450
michaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond reputemichaelk has a reputation beyond repute
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by jeepgrandcherokeesal View Post
Yup. Once logged in, click on "Maintain and Care" then "Maintenance Schedule". There's a "Current Mileage" box with the odometer reading and the read date.
Quote:
Originally Posted by michaelk View Post
you have a 14 and you see mileage on moparownerconnect website?

1) Way cool- thanks for pointing that out.

2) They suck even more than I thought- they’re clearly reading data from the vehicle but made a decision to not share it with us. So they probably have location data, run status, lock status, speed limit, error codes, etc, etc like the other brands of telematics do, but they don’t bother sharing.
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil life algorithm still buggy Roadkill 2014+ Jeep Grand Cherokee Ecodiesel 3.0 7 01-19-2015 09:33 PM
Want to Downgrade from my 2005 REC NAV jsquire1 Troubleshooting/Problems 3 11-14-2013 08:45 PM
The Buggy :: 2012 Jeep Grand Cherokee SRT8 Challenger15 Member Garage Discussions 0 01-04-2013 08:48 AM
My system downgrade - Finished w87will Audio, Video, Navigation & Electronic Modifications 80 10-27-2010 11:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.