uConnect 15.26.1 is buggy; I want to downgrade. - Page 9 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #97  
Old 08-21-2015, 04:21 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1861
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by HSTNJEEP View Post
Anyone have the issue of changing satellite stations, yet the on screen information stays the same? It actually changes stations but does not reflect it. I had this problem before and after the update at the dealership.
Haven't seen that here. Does it matter if you're on any screen, seeing the channel up in the margin, or on the sxm screen?

Reply With Quote
Sponsored Links
Advertisement
 
  #98  
Old 08-23-2015, 05:04 PM
dgold21's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Aug 2015
Location: California, USA
Posts: 23
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 504
dgold21 is on a distinguished road
Garage
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by HSTNJEEP View Post
Anyone have the issue of changing satellite stations, yet the on screen information stays the same? It actually changes stations but does not reflect it. I had this problem before and after the update at the dealership.
This happened to me one day, it worked itself out though...I restarted the car a couple times and it didn't help, but later in the day I started it and it was working normally.
Reply With Quote
  #99  
Old 08-24-2015, 12:59 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1861
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Weekend update -

Apologies, I ended up with little time today, but did get some new data:

The shields of the radio's antenna connections are bonded to the housing, hence each other, thru little spring fingers (ref. 3rd pic in post of 17aug11:23p)

I found no phantom power on the pink antenna connector. I'm liking the idea that this a(n open) diversity antenna connection.

There was still continuity between the shield of the dangling cdma antenna feedline and the radio housing which, at first, made me want to think that the vehicle was also common, but that's a bogus conclusion right now because the other two lines were still connected and all lead to the sharkfin. I should've yanked them but the clock was ticking. Maybe I can sort this out soon.

I did, though, put crude foil shields around the dangling red connector (verified shield continuity to the foil) and in the cavity around the pink connector, tucked into the bonding fingers with continuity. Then took a test drive and found that the registrations are even more intermittent now and pretty much just happen within 1/10 mile of the tower.

I'll try a proper termination on the pink thing, and sort out the grounding.
Reply With Quote
The Following User Says Thank You to Rocketrancher For This Useful Post:
  #100  
Old 08-24-2015, 01:40 AM
Senior Member
 
Join Date: Sep 2013
Posts: 1,288
Thanks: 46
Thanked 155 Times in 126 Posts
Rep Power: 2811
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Great follow up, RR. Have you considered doing an experiment where every other antenna attached to the unit is simply disconnected (i.e. GPS, satellite, terrestrial radio, etc) and their respective ports are covered via foil shield while leaving only your CDMA antenna terminator in place? Antenna diversity/coupling makes sense from a design standpoint, but it seems that an experiment of this type would allow that to be ruled out as a causal factor for ongoing registrations, at least insofar as the other sharkfin antennas are concerned.

Perhaps that is what you were already describing, in which case I apologize for being obtuse.
Reply With Quote
The Following User Says Thank You to Roadkill For This Useful Post:
  #101  
Old 08-24-2015, 11:17 AM
GoPlzGo's Avatar
formerly 14summithemi
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2013
Location: Cleveland, OH
Posts: 3,155
Thanks: 339
Thanked 561 Times in 470 Posts
Rep Power: 25577
GoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond repute
Quote:
Originally Posted by michaelk View Post

1) Way cool- thanks for pointing that out.

2) They suck even more than I thought- they’re clearly reading data from the vehicle but made a decision to not share it with us. So they probably have location data, run status, lock status, speed limit, error codes, etc, etc like the other brands of telematics do, but they don’t bother sharing.
Yup, my '14 with long expired UConnect subscription is "phoning home"....just noticed it has an accurate mileage from 8/16, been nowhere near the dealer service dept....don't like the eavesdropping.... Doesn't lack of subscription take away their "right" to collect any data thru that service? I know its the way of the world now but.....
__________________
'15 JGC SRT Bright White Red Vapor...Borla ATAK Cat-back w/ ceramic coated axle-back, aFe Momentum GT Pro 5R Stage-2 Intake & Billet Tech Oil Catch Can
Reply With Quote
The Following User Says Thank You to GoPlzGo For This Useful Post:
  #102  
Old 08-24-2015, 06:13 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1861
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by Roadkill View Post
Great follow up, RR. Have you considered doing an experiment where every other antenna attached to the unit is simply disconnected (i.e. GPS, satellite, terrestrial radio, etc) and their respective ports are covered via foil shield while leaving only your CDMA antenna terminator in place? Antenna diversity/coupling makes sense from a design standpoint, but it seems that an experiment of this type would allow that to be ruled out as a causal factor for ongoing registrations, at least insofar as the other sharkfin antennas are concerned.

Perhaps that is what you were already describing, in which case I apologize for being obtuse.
Thanks RK!

That's a good idea to drop everything off; I'll put it on the checklist.

Actually, I was working based on the module block diagram that shows a connection for a diversity/receive antenna that's unique to our hardware...



...and thinking that there could still be some tickling of the receiver from that open port.

I'll expect to get some squawks from dropping-off the GPS antenna, since the diagram also shows some diagnostics there, too.

The adventure continues after I get some more parts…..ordered some singles so I don't have to parallel things that won't fit in a tube.
Reply With Quote
  #103  
Old 08-25-2015, 01:04 AM
Senior Member
 
Join Date: Sep 2013
Posts: 1,288
Thanks: 46
Thanked 155 Times in 126 Posts
Rep Power: 2811
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by 14SummitHemi View Post
Yup, my '14 with long expired UConnect subscription is "phoning home"
I never signed up for the free trial of uConnect--I thought FCA already had too much info on me as it was, and I never believed that being able to control my vehicle functions via the internet/smartphone was a securable goal.

Interestingly enough, the only mileage updates I have ever gotten are when the tech enters it when I go in for service.

Of course, I know FCA is still tracking me around (hopefully not for much longer!), but I'm guessing those of us who didn't sign up never got this particular linkage between their different backend systems.
Reply With Quote
  #104  
Old 08-25-2015, 11:47 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2011
Location: South Coast
Posts: 53
Thanks: 11
Thanked 20 Times in 13 Posts
Rep Power: 1861
Rocketrancher is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by Roadkill View Post
I never signed up for the free trial of uConnect--I thought FCA already had too much info on me as it was, and I never believed that being able to control my vehicle functions via the internet/smartphone was a securable goal.
Ditto. And after reading their privacy policy I was thinking "Grand Trojan".

Quote:
Originally Posted by Roadkill View Post
Interestingly enough, the only mileage updates I have ever gotten are when the tech enters it when I go in for service.
I checked the other nite and the only entry was from a comp. oil change 8000 miles ago back on 5May.
Rather good feeling, there.

Quote:
Originally Posted by Roadkill View Post
Of course, I know FCA is still tracking me around (hopefully not for much longer!), but I'm guessing those of us who didn't sign up never got this particular linkage between their different backend systems.
Got my fingers and toes crossed
Reply With Quote
  #105  
Old 08-30-2015, 08:56 PM
Tarponbeach's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Sep 2013
Location: Maryland
Posts: 214
Thanks: 21
Thanked 35 Times in 27 Posts
Rep Power: 1407
Tarponbeach is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Anyone else having the issue where the nav. map is up, and suddenly a photo of the earth comes up with the text "Navigation System is Initializing" ?

Never happened on my '14..
__________________
2015 GC Overland
Granite Crystal / Black
Reply With Quote
  #106  
Old 08-30-2015, 09:07 PM
Da Jeeper's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Feb 2012
Location: Chicago
Posts: 625
Thanks: 87
Thanked 71 Times in 56 Posts
Rep Power: 2372
Da Jeeper is on a distinguished road
Re: uConnect 15.26.1 is buggy; I want to downgrade.

Quote:
Originally Posted by Tarponbeach View Post
Anyone else having the issue where the nav. map is up, and suddenly a photo of the earth comes up with the text "Navigation System is Initializing" ?

Never happened on my '14..
I read in a couple places today that there are a few nav's acting up. I am only guessing, maybe they are doing maintenance on the satellites???
Reply With Quote
  #107  
Old 08-30-2015, 09:24 PM
Senior Member
 
Join Date: Sep 2013
Posts: 1,288
Thanks: 46
Thanked 155 Times in 126 Posts
Rep Power: 2811
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by Da Jeeper View Post
I read in a couple places today that there are a few nav's acting up.
Today my nav crashed no less than 8 times during a 100 mile drive. After the sixth nav crash/reboot it froze for 15+ minuted, meaning it was unresponsive to zoom buttons and attempting to route to a destination displayed "FAILED"... however the position on the map continued to update in real time.

A soft reboot of the radio caused the nav to resume its regularly scheduled crash/reboot cycle.

None of this *ever* happened before this latest firmware update. I'm downgrading the moment we get a terminator working. Actually, now that I think about it... RR, how often does the system bitch about the antenna if it's disconnected? Once per engine start, or does it nag every five minutes or something? Does disconnecting the antenna completely prevent registration on the data network?

I'm basically at the point where I'd be willing to dismiss an error message once per starting the vehicle if it means I can securely downgrade to a known-good firmware.

Quote:
Originally Posted by Tarponbeach View Post
Anyone else having the issue where the nav. map is up, and suddenly a photo of the earth comes up with the text "Navigation System is Initializing" ?

Never happened on my '14..
Your nav just crashed and rebooted. Never happened on my 2014 before this latest firmware release.
Reply With Quote
  #108  
Old 08-30-2015, 10:29 PM
Da Jeeper's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Feb 2012
Location: Chicago
Posts: 625
Thanks: 87
Thanked 71 Times in 56 Posts
Rep Power: 2372
Da Jeeper is on a distinguished road
Was on the KL forum and there navs are rebooting as well...not sure if its limited to jeep?
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil life algorithm still buggy Roadkill 2014+ Jeep Grand Cherokee Ecodiesel 3.0 7 01-19-2015 09:33 PM
Want to Downgrade from my 2005 REC NAV jsquire1 Troubleshooting/Problems 3 11-14-2013 08:45 PM
The Buggy :: 2012 Jeep Grand Cherokee SRT8 Challenger15 Member Garage Discussions 0 01-04-2013 08:48 AM
My system downgrade - Finished w87will Audio, Video, Navigation & Electronic Modifications 80 10-27-2010 11:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.